Export mocha pro project to mocha ae

Hi

I finished a project in mocha pro v5.6 plugin and I wish to export it to a user that does not have mocha pro but has mocha ae. I see if I export a .mocha file, it does not open in Mocha Ae giving this message:
image

isn’t there a way around this issue? I think compatibility is important here even if there are features that were used in mocha pro, they could be disabled but at least the splines and tracking information should crossover. something like export as Mocha Ae maybe?

I think there should be a way to export from mocha a mocha ae file with limited functionality at least.

As a workaround, open the exported mocha project in the text editor of your choice and change this line:
FileVersion.value=3002
to this:
FileVersion.value=3001
You’ll then be able to open the file in the bundled mocha AE CC.
Mik

Thank you Mik this looked like it would work but with a real project when I do this and import the new mocha file, it act’s as if I did nothing. no window or nothing. if I do this with a blank project it seems to work. going back and forth I am getting all sorts of errors too.

here’s a test project. if you have the time, see if you can get that mocha pro file to open in mocha ae:
https://drive.google.com/drive/folders/18s5e_UxhJvOufvMNI5XnvfBALPIumDc_

I see the problem.

mocha V5 has the ability to track “Layer Below” which isn’t handled by the older mocha AE.

The best way to solve this is from the mocha Pro Plugin. Before saving out the project, change the Input Clip on the Track Page from “Layer Below” to “Input”. Do this for every layer.

Alternatively, to fix it up from mocha AE:

  1. Go to the Track page.
  2. Select the top layer and set the Input clip to “Input”.
  3. Do the same for the bottom layer.

I hope this helps.
Mik

thanks Mik.

I am getting the same error. it seems the splines crossover fine but can’t link to the clip. did it work for you in the project I sent?

where can I find more information about this feature “layer below” tried to look for it in the manual but couldn’t. what is the proper use for it?

Do you mean you’re still getting the “Unable to get base clip info” message?

“Layer Below” means to use the same input clip for tracking as any layer below. If there is no layer below the current layer then the main Input clip is used.

I tried to do this again and it worked this time. the reason it did not work before is that it seems if you have the eyeball off on the layer, it does not keep the input layer “layer below” setting - it just jumps back to “layer below”. turning the eyeball on for the spline, then setting it to “input”, keeps the setting. would you call this a bug?
55

thanks for all your help. I really think a feature such as export as mocha ae is valuable to mocha pro users. even with loss of pro features, the splines are important. hopefully my voice was heard on this matter.

Yes, I’d definitely call that a bug. Sorry it wasted your time.

advocate for making mocha ae an option on export and we’ll call it even :slight_smile: users should not change code of project files. if it’s possible, it should be accessible IMO.
appreciate your help and input.