Export shapes to Fusion via Silhouette fails

I tried to export shape data to Fusion directly from Mocha Pro 2020.5 OFX that was running in Silhouette and it failed to export any animation data. I can copy the shape data to Silhouette and then export it to Fusion and works perfectly. I also tried saving the Mocha project and opening it with Mocha Pro plugin in Fusion and it had no tracking or shape animation, just the shapes.
I tried exporting the same shape to After Effects just to see if that work and it does, so I also tried opening the project from the Mocha Pro plugin inside of After Effects and it works the same as it does in Silhouette. But I can not export the shape data to Fusion from Ae either. So it appears something is broken with the Fusion exporter from other hosts, at least Ae and Silhouette, and the ability for Fusion to read Mocha projects created by these hosts. Launching Mocha Pro and creating a project from Fusion and tracking and roto etc all works as expected.
Any help would be appreciated, Thank You.

Can you let us know the fusion version as well? I will tag @MartinB because this sounds like a bug we need to test.

@TimH What are the frame ranges you are seeing in Mocha inside Fusion? If you are seeing shapes but not animation, it may be that the keyframes are being offset.

I’m on the latest version of Fusion Studio 16.2.4 build 9. OS is Windows 10
The frame ranges are all the same across hosts, start at frame 1001. The sequence actual numbering starts at 1001, so everything matches correctly, timelines and footage.
If I copy and past the shape data from Mocha inside of Silhouette to Fusion the shape comes with no animation at all its not offset its just not there. This is the same with the Mocha project created in Silhouette and opened in Fusion all the frame ranges are correct and match, start at frame 1001 but contains no animation either tracking or roto, its a data ghost town ;-). As mentioned it all works with Ae both receiving shape data exported from Mocha running in Silhouette and also opening the Mocha project within Ae that was created in Silhouette.
Please let me know if you need anything else, thanks for taking the time to look into this.

@martinb Have you any news on this issue I’m having?

Are you able to send the project and export in question? You can send it to us directly if you want to avoid the public forum, or you can DM me via the forum messages.
The export in question would also be good to look at.

Thanks @martinb I will get that file to you.

Just so i’m clear on the process:

  1. You are running Mocha Pro OFX inside Silhouette 2020.5 (or AE)
  2. You roto the file in Mocha OFX
  3. You export to Fusion shapes (.comp)
  4. You paste the shape data into a Fusion graph
  5. The shapes exist, but not the keyframes

Is that a fair summary?

Essentially any time you try to use the plugin version of Mocha Pro in another host, it is not creating keyframes.

I’ve not been able to reproduce this yet, unfortunately.

The project file you sent me seems pretty straightforward.

Have you tried exporting a simple tracked shape to see if the same problem occurs?

Can you send me your log file btw? I’d like to see if any error messages are popping out.

Sorry for the delay here it is.

Sent to you again via pm

@martinb @maryp


Yes your correct using the plugin in more that one host mainly Silhouette and Fusion at the moment.

I have found where the issue is, yay:

  1. Shape data will always be sent to frame 0 in Fusion, so my bad it was there all along just along way from home where it should have been on frame 1001. This is in spite of all hosts use the same start frame of 1001. I don’t think this is correct, or is it a bug?

  2. Tracking data exported from Mocha in Silhouette comes into Fusion perfectly, So no drama.

  3. If I start and save a Mocha project in Silhouette and then open it in Fusion it changes the Mocha project setting which I cant alter, setting the start frame to 0. See attached images. I think this is a bug?
    This makes it very difficult to share data between Fusion and Silhouette as Mocha creates different start times, Mocha in Fusion will always be 0 in the project settings.

Thanks so much for taking the time to look at this.

Is there a solution to the mismatch with project settings. Is there a way to force Fusion to use the timeline frame start numbers and not 0.
Many thanks for any help on a resolution to this.

Some OFX hosts do force a frame start of 0, which can be frustrating for internal time changes.
Can you show me your fusion timeline setup?

Hi @martinb here is the timeline and also the defaults that I have set for Fusion.
Let me know if you need anything else.

I think there may be a problem between the range in Fusion and the Frame offset in Silhouette versions of Mocha Pro.
Fusion is setting the right range, but the saved project in silhouette has a preexisting frame offset, which could be throwing out the keyframes.

You can see this if you export out the comp data and paste it to a file for both environments:
a) Mocha in Silhouette is exporting at frame zero
b) Mocha in Fusion exports at frame 1001

So there is a discrepancy in the way the two operate.

I’ll have to think about the best workaround for this, but at least the cause is clear now.

Sorry for the late reply @martinb, greatly appreciate your time in working through this. Hope that you can find a solution. Thanks again!

HI @martinb, just a quick question with there in the future be support for importing Silhouette shapes into the Mocha Pro plugin?

Yes, but I can’t say when just yet. The original implementation of the importer was done in Python via scripting, which the plugin doesn’t support yet.

Thanks for taking the time to respond @martinb, appreciated.
I will be greatly welcomed when it arrives and make the Mocha plugin even more useful in what can be done using the plugin within Silhouette, and for those without access to the standalone version of Mocha.