Exporting Insert Clip

I’m inserting text onto moving people and some equipment they’re carrying / wearing. I’ve been working, so far, with mocha AE v3–but am having a lot of issues with my tracked surface going behind the mocha camera because of the nature of the movement in my shots. It was suggested I try the insert module in mocha Pro, eliminating the need to export corner pin data and thereby avoiding the camera issue.
I’ve tracked an object in my clip, imported my insert clip (text) and attached it to the track. What I need to do now, though, is export ONLY that inserted text with its alpha channel intact, and NOT the background (original clip). Is this possible? I can’t quite make sense of the Export Rendered Clip dialogue box. What is the Revert to Clip section? Also, Save Alpha Channel is greyed out / unavailable.
Any advice much appreciated.

Hi Martin,

Thanks for your response. Located the Composite and Layer sequences. Had also managed to export the layer as a Quicktime file–but not with alpha intact. Is this possible?

I’ve just run into another question mark… When I reopened my mocha Pro project–where I’d already tracked a shot, inserted my text, rendered it out, etc.–I got a yellow “warning” on screen (not in a dialogue box) reading, Overlay Error - Illegal insert clip; the insert clip was not shown and the background footage was displayed in monochrome. I (somehow–no idea how) got rid of the warning message and my insert clip reappeared–but the footage is still black and white. Any idea what I’ve done there…?

Incidentally, have your developers had a chance to look at the mocha AE project I was having problems with last week? I’ve not gone back to it myself since we were chatting. I’m currently working from an entirely new project in mocha Pro (trial version) and not having any of the previous problems…

Cheers

I’m inserting text onto moving people and some equipment they’re carrying / wearing. I’ve been working, so far, with mocha AE v3–but am having a lot of issues with my tracked surface going behind the mocha camera because of the nature of the movement in my shots. It was suggested I try the insert module in mocha Pro, eliminating the need to export corner pin data and thereby avoiding the camera issue.

I’ve tracked an object in my clip, imported my insert clip (text) and attached it to the track. What I need to do now, though, is export ONLY that inserted text with its alpha channel intact, and NOT the background (original clip). Is this possible? I can’t quite make sense of the Export Rendered Clip dialogue box. What is the Revert to Clip section? Also, Save Alpha Channel is greyed out / unavailable.

Any advice much appreciated.

Hi Martin,
Thanks for your response. Located the Composite and Layer sequences. Had also managed to export the layer as a Quicktime file–but not with alpha intact. Is this possible?
I’ve just run into another question mark… When I reopened my mocha Pro project–where I’d already tracked a shot, inserted my text, rendered it out, etc.–I got a yellow “warning” on screen (not in a dialogue box) reading, Overlay Error - Illegal insert clip; the insert clip was not shown and the background footage was displayed in monochrome. I (somehow–no idea how) got rid of the warning message and my insert clip reappeared–but the footage is still black and white. Any idea what I’ve done there…?
Incidentally, have your developers had a chance to look at the mocha AE project I was having problems with last week? I’ve not gone back to it myself since we were chatting. I’m currently working from an entirely new project in mocha Pro (trial version) and not having any of the previous problems…
Cheers

Ok. Not sure how I’ve done that–although I did try a few different settings in my original efforts at exporting the insert clip with alpha… Where would I have set it as a matte clip? In the Insert Module, should Alpha Insert Clip and Alpha Background Clip both be None? How do I relink the original clip?

Ok. Not sure how I’ve done that–although I did try a few different settings in my original efforts at exporting the insert clip with alpha… Where would I have set it as a matte clip? In the Insert Module, should Alpha Insert Clip and Alpha Background Clip both be None? How do I relink the original clip?

Completely overlooked the Relink… button.
Another quick question: is the mesh in the Insert Module keyframeable?

Completely overlooked the Relink… button.

Another quick question: is the mesh in the Insert Module keyframeable?

When you render the insert with the render forwards button on the timeline you will get 2 separate renders: A Composite file with the insert rendered into it, and a Layer file which contains just the insert with an alpha channel. You can view both of these from the clip drop down in the top right of the Viewer

These clips are automatically rendered to your Results folder as TIF or DPX (depending on the preference set), but then you can choose to select either the Layer or the Composite to export to another format from the Export Rendered Clip option.

When you render the insert with the render forwards button on the timeline you will get 2 separate renders: A Composite file with the insert rendered into it, and a Layer file which contains just the insert with an alpha channel. You can view both of these from the clip drop down in the top right of the Viewer
These clips are automatically rendered to your Results folder as TIF or DPX (depending on the preference set), but then you can choose to select either the Layer or the Composite to export to another format from the Export Rendered Clip option.

You can relink the clip from the Clip tab. You just need to select the clip from the drop-down. Alternatively just re-import the clip in the insert drop down.

If it is black and white, it sounds like at some point you fed it in as a matte clip. Using a clip as a matte clip will convert it to greyscale, so you would need to relink the clip.
We are still investigating the surface problem.

If it is black and white, it sounds like at some point you fed it in as a matte clip. Using a clip as a matte clip will convert it to greyscale, so you would need to relink the clip.

We are still investigating the surface problem.

You can relink the clip from the Clip tab. You just need to select the clip from the drop-down. Alternatively just re-import the clip in the insert drop down.

That was very informative and it should be in the manual!
I tried exporting to Quicktime format with alpha and it worked.
You have to render Layer and Composite sequences first for this to work.
If you don’t render first and go straight to Export rendered shapes - Mocha crashes (2.6.2). Probably it can’t find anything to export and gets angry :slight_smile:

That was very informative and it should be in the manual!
I tried exporting to Quicktime format with alpha and it worked.
You have to render Layer and Composite sequences first for this to work.
If you don’t render first and go straight to Export rendered shapes - Mocha crashes (2.6.2). Probably it can’t find anything to export and gets angry :slight_smile: