Exporting Shape Data not importing correctly in AECC14 (Mocha Pro 4.1.2)

When pasting exported shape data from Mocha Pro 4.1.2 into AECC14, whether through “Paste Mocha Mask” command or pasting directly into the layer, a mask appears in the correct position, but no shape keyframes are pasted, so the shape does not track like it should.

I was using this functionality just today in Mocha Pro 4.1.1 just fine, until I updated to the new version. Tracking data seems to export fine, just not shape data.

What’s going on?

It sounds like your shape is almost certainly pasting off of your timeline. This is usually caused by long clips in AE being brought into mocha and only tracked in small sections. You can try trimming your in and out points in mocha or looking for the keyframes on the timeline to fix this. You also might consider looking into mocha import+ for AE, it fixes a lot of these sorts of in and out point issue automatically for you. We don’t make it, but mamo world does. http://aescripts.com/mochaimport/

I am sure the data is being pasted offscreen. Take the layer you pasted your data on to, tick the menus down until you can see where your keyframes should be, if you see no keyframes, drag the clip right or left until you do see them. It’s that what you’re tracking is much smaller than your clip in AE.

However, it could also be a project misalignment problem. When you paste or import your mocha data into the final composite or edit, make sure you are pasting or loading your data in at the first frame of the clip, otherwise your data will not line up.

Project settings such as frame rate, dimensions and pixel aspect ratio must be match between your mocha project and your destination software. Make sure these values match the settings in your compositor or editor and inside of mocha, otherwise your tracking data will not match when you export it.
If your are using Adobe After Effects, the target layer you are pasting data to should also be the same size as your AE composition. A good After Effects troubleshooting tip: create a new solid that is the same size as your composition. Paste your track or roto shape data to this layer. If it does not line up, the issue is mostly likely a project mismatch.

Please let me know if you have any questions and I will be happy to help.

Im having the same problem with mocha pro v4.1.2 it will export the shape of the mask but no tracking data is exported

I will repeat myself. :slight_smile:

It sounds like your shape is pasting off of your timeline. This is usually caused by long clips in AE being brought into mocha and only tracked in small sections. You can try trimming your in and out points in mocha or looking for the keyframes on the timeline to fix this. You also might consider looking into mocha import+ for AE, it fixes a lot of these sorts of in and out point issue automatically for you. We don’t make it, but mamo world does. MochaImport+ V6 - aescripts + aeplugins - aescripts.com

To confirm that your shape is pasted off the timeline, take the layer you pasted your data on to in AE, tick the menus down until you can see where your keyframes should be, if you see no keyframes, drag the clip right or left until you do see them. It's that what you're tracking is much smaller than your clip in AE.
However, it could also be a project misalignment problem. When you paste or import your mocha data into the final composite or edit, make sure you are pasting or loading your data in at the first frame of the clip, otherwise your data will not line up.

Project settings such as frame rate, dimensions and pixel aspect ratio must be match between your mocha project and your destination software. Make sure these values match the settings in your compositor or editor and inside of mocha, otherwise your tracking data will not match when you export it.

If your are using Adobe After Effects, the target layer you are pasting data to should also be the same size as your AE composition. A good After Effects troubleshooting tip: create a new solid that is the same size as your composition. Paste your track or roto shape data to this layer. If it does not line up, the issue is mostly likely a project mismatch. We address this in our newest tutorial: https://vimeo.com/117445440

Please let me know if you have any questions and I will be happy to help.

and I will repeat myself I have read your reply to the first person with this problem and have watch the video’s and did as you have requested but still there IS NO tracking data sent to AE when using paste mask! I reverted to using mocha for AE and did the same project with NO problems. It was only when I updated to Mocha v4.1.2 that this problem happened. I suggest you have your coders go in and fix the problem. Thank you :slight_smile:

I just tried a single track to paste a shape and that worked but when I have 2 tracks one tracking and one linked to the track layer for the roto is when I have the problem.

 

I have now uninstalled mocha pro- reinstalled it and re-upgraded it and tried another track now the data is there but offset down the timeline like you suggested, still makes it inconvenient computers make me nuts sometimes. thanks Mary.

OK, good! Sometimes threads don’t get read thoroughly, I know I skim a lot, I wasn’t trying to be rude I just wanted to make sure you had seen the troubleshooting. :wink:

I’m glad you got it sorted! In the meantime, we are actually working on a fix for this data offset. It has to do with how the data transfers into AE. :slight_smile: Hopefully we will have an update for it soon.

Cheers!
Mary

Hi Mary!

Sorry to take so long to post, I was in the middle of some deadlines and could not respond to you in a timely manner. My apologies!

You were correct. The tracking I was doing was a small portion of a longer video, and the keyframes were posted further down the timeline. That’s why it wasn’t present in the comp.

Thank you for responding so quickly, you really helped me out. Again, apologies for not getting back to you sooner.

No worries! Glad you got it sorted! :smiley:

This sounds similar to the issues I’m currently having. I was flying and pasting shapes into AE from Mocha having a blast. And then things suddenly got strange… I tracked, created a shape, linked the shape to the track and then exported the shape to AE. When I try “past mocha mask” it seems to be doing funky things on a pre-comped clip. When I past the mask on from one I get spaced out keyframes and the shape is off by about 20 frames or so. BUT, if I move the playhead in on the timeline say even a couple seconds the data points appear. But with space between the playhead and the first keyframes.

Any idea?

Nick

 

To anyone having this issue Mary is right. When you track a portion of a larger scene this happens. What I did to fix it was to create a temporary composition in after effects that was the same size as the ENTIRE clip not only the portion which I tracked. Then copy and paste the clip that has the hidden keyframe data to the temporary composition and expand the in and out points of the clip until you can see the hidden keyframes. From there you can copy those keyframes and paste them where they should be in your original composition.

Nick, I’d have to see what is going on with your shape, but in general, you have to double check all your footage and comp settings and make sure they match in mocha too. But it also sounds like you could have a corrupted shape. Turn the grid and surface tool on, if they disappear or get turn tesseract on themselves, then you know your shape has a corrupt track.

I am having the same problem, in my case, the very first frame is just stuck there (when pasted mocha shape on the top layer), it just not moving. I have read the full thread and i have checked everything but still couldn’t make it happen.

I have mocha AE CC.

Please help me and with this version only and also i am new to AE & Mocha.

 

Thanks

Dave

Hi Dave,

In the shape layer, twirl the shape down and look at your keyframes, yours will have pasted in outside of the comp if your shape is visible but not animating. Drag the layer until you can see your keyframes. They’re there if you can see the shape! They just aren’t pasting in at the right frame.

Try that and let me know?

Cheers,
Mary

thansk @maryp
I have fixed it
start frame=0

or
5