Extremely annoying UI bug in Mocha AE

System info:
OSX 10.15.4
Mac Pro 2019
3.3 GHZ 12 Core Xeon W
128Gb s933 DDR4
1x Radeon 580X
1x Radeon Vega 64

Software:
After Effects V 17.0.5

Have run into this problem occasionally over the last few months, but it seems to be worse now, or it’s just the clip I am working on.

Load up Mocha AE, works fine. Scrub the timeline, good for a few frames, then the UI goes nuts, and fills in with strange, zoomed-in segments of the video file or of the buttons in the UI. I can reset it by resizing the window, but it comes back as soon as I start re-scrubbing or track anything.

I did a screen cap to illustrate.

Would love a solution.

Should also mention:
GPU track turned off.
Cleared all caches.
Restarted AE multiple times…

I was going to mention disabling GPU tracking. The 2 GPU cards might point to something.
Have you tried installing Mocha Pro 2020? Curious if the same thing would happen as I believe there are more options in the GPU prefs.

I can certainly try installing a trial, but I wouldn’t want to have to pay $700 jsut to keep using the Mocha AE features I pay for in AE.

I should note as well, I currently have 4 monitors hooked up to my machine… I know there have been multimonitor issues in the past… Three run to the Vega 64, one runs to the 580x.
The monitor I work on is connected to the vega64.

All that said, I have used Mocha AE on this set up before, and it seemed to work ok. Not sure if it’s the latest AE update (or perhaps previous one), or something else… but it’s getting rather annoying :stuck_out_tongue:

One thing I haven’t tried is moving it to another monitor… curious if it happens across all 4…

And now, I cannot replicate the issue… seems intermittent, which is gonna make this harder to lock down.
Would love any direction to follow to sort this out.

Since GPU is disabled, quite possibly related to the multiple monitors. Perhaps our product manager, @martinb has some thoughts?

Thanks for being so thorough with your checks and hardware specs! This helps us a lot. It’s also useful to see the problem moving in the video.

At present we are seeing some weird bug-outs related to AMD cards that we’re trying to replicate. Like you mention above, the problems are intermittent and very hard to catch in the act!

Multi-monitor may be an issue as well. Are all the monitors the same resolution or do they differ?

If you’re able to share the reduced AEP project and your MOcha log (Help menu > view log) we can try to replicate on this particular shot and setup. You can DM me if you want to keep the details private.

Hey Martin. Thanks.
I will try and get the problem to pop up again tomorrow, and send you a project and logs. The ONE project it always pop up in is not one I can share, as the footage and content is still under wraps as per client request.

The monitors are NOT all the same resolution.
MY main monitor is 2560 x 1440 (the one I have seen this happen on)
I have 3 other 1080p monitors, 2 of which are rotated vertically. One is 90 degrees, and one is 270 degrees.

I will DM you when I have the faulty project and logs.

Cheers