Failed to allocate memory buffer!

I’ve been having this issue for a little while now, I can’t for the life of me figure out what’s causing it…


I’m simply trying to track my footage from AE in Mocha:

Animation>track in MochaAE

Mocha opens, I get the usual dialogue box, I click OK

After I click OK, I get the error message “Failed to allocate memory buffer. Please free up system memory by closing other applications.”

I’ve purged my memory & disk cache in AE. I’ve tried closing all other apps except AE. I’m updated with the latest CC apps (AE, others were updated at the same time).
And still, this issue persists.


System specs are: iMac Retina 5k, late 2015 model
OS 10.12.3
32G memory
3.2GHz Intel Core i5


I have 20G of ram shared between my Adobe apps, but I only have AE and PPro open. 12Gb left for other apps
Activity Monitor says I’m currently using 15.85 Gb of App Memory, 2.56 Wired, and 7.82Gb cached files.
Specifically it says that the biggest memory usage currently is 7.21G from AE. Next highest is kernel_task at 1.9, and PPro at 630Mb.

Any help or direction would be incredible - I’m getting to the end of my rope!

Hi there,

This is a known bug and we are very close to having a solution for it! Please stand by for a point release that should fix this for you soon. For now, you can save and close mocha and releaunch it and it should be a workaround for you to finish the shot with. Sorry for the inconvenience.


1 Like

Thanks Mary. In this instance, that doesn’t work - Ive tried multiple times, restarted, etc.

Over on the Cow, it was suggested I transcode the footage from mp4 to prores before importing, and that worked. It was just odd because other mp4 files worked for me in the past, but these few didn’t.
Anyhow, I’m looking forward to the point release, and thanks again for the reply!

I am sorry, I misread that and thought you were using the plugin. On the cow, if you were suggested to change the format and that worked the issue is a codec issue. The new mocha Pro 5 plug-in reads directly off your timeline and eliminates codec and file format issues like this one but for the standalone version that ships with after effects there’s a few steps you can take to fix this issue. Please note, the codec won’t be “MP4” or “MOV”, that’s the file type, the codec is the compression being used.

There are certain types of codecs and file types that mocha does not support, usually native, unprocessed codecs off of cameras and AVIs on Windows, and often MP4s don’t work in standalone mocha AE, legacy mocha Plus, or standalone mocha Pro. You may need to convert the file to something mocha supports, such as an uncompressed quicktime or an image sequence. If your screen is black or white for clips but not for images, it is most likely the codec for the movie files that is causing the issue.

View Documentation: supported file list:

Other troubleshooting tips:

Double-check that your quicktime drivers, codecs, and video card drivers are up to date, and that quicktime can open the file.
Try changing your codec to a more widespread codec. Usually any other quicktime format like animation, h.264, or JPEG compression should work, or another type of common .avi compression.
If the footage loads in quicktime but not in mocha, try converting the clip to a file we know for sure that mocha recognizes, like a TIFF or JPEG sequence, to test and make sure that mocha is running properly.

Please let me know if you have any questions and I will be happy to help you.

Still odd though - some files that opened fine (I tested out a few shot with a few different cameras) all seem to have the same codec as the ones that don’t work.

The one I’m having issues with is an MP4 recorded with a Sony a7S, 24p 50mbps (h.264 mpeg-4 avc codec)

The ones that worked are mp4 and mov from a C100 and a 5D, respectively, but both are telling me they also have the same h.264 mpeg-4 avc codec. They both are 24p but different bit rates, if that matters.

Anyhow, thanks again! Still love Mocha!!

Right, but even if a camera says it’s using a H.264 codec it might be using a very specific version of that codec for their camera. You can try installing the quicktime drivers (if any) from those respective cameras and see if it fixes the issue, as some manufacturers like canon have those on their website. The standalone mocha runs off a quicktime engine, so if you have any trouble getting quicktime to play nice with them mocha might not, and even if quicktime does play nice with them, mocha might not. The good news is we are planning on updating our image engine in an upcoming version of mocha and this shouldn’t be as much of an issue anymore.

Thank you!