Failed to open file... corrupted or unsupported format


#1

I was just working on a project yesterday - tracking some screens onto phones - and now when I send footage to mocha it shows up with a blank project - doesn’t carry over any info from AE. So then when I tried to open previous projects I got this error when trying to relink the media. Keep in mind I have not touched the footage. It’s the same codec as it was yesterday when working on it.

Appreciate the help, I’m also under a deadline and this is killing me.


#2

There are certain types of codecs and file types that mocha does not support, usually native, unprocessed codecs off of cameras and AVIs on Windows. You may need to convert the file to something mocha supports, such as quicktime or an image sequence. If your screen is black or white for clips but not for images, it is most likely the codec for the movie files that is causing the issue.

Keep in mind a codec does not refer to a file type, like AVI or MP4, it refers to the compression type. Both must be considered. Make sure you have the proper codecs installed on your machine or try a more universal codec to bring into mocha.

View Documentation: supported file list http://www.imagineersystems.com/support/documentation/#File_Formats

Other troubleshooting tips (because this sounds like it may be a driver or installed codec issue instead of a format issue):

Double-check that your quicktime drivers, codecs, and video card drivers are up to date, and that quicktime can open the file. (The most likely cause to these formats you listed not working is probably that the codecs need to be updated on your machine).
Try changing your codec to a more widespread codec. Usually any other quicktime format like animation, h.264, or JPEG compression should work, or another type of common .avi compression.
If the footage loads in quicktime but not in mocha, try converting the clip to a file we know for sure that mocha recognizes, like a TIFF or JPEG sequence, to test and make sure that mocha is running properly.

mocha supports most standard movie clip and image sequence formats. In order to use clips (ie. not image sequences) you must have QuickTime installed. Level of QuickTime support can vary depending on the operating system.

What to Do if mocha Does Not Support Your Footage
In the event that you are working in a format that mocha doesn’t support, we recommend converting the footage to an image sequence.

If you are just tracking, you can use any compressed format such as a JPG sequence and then use your original footage when you apply the data. If you are going to be doing rendering, such as using Mocha Pro’s remove or insert modules, then we recommend converting to a DPX or TIFF sequence.

Make sure of the following when converting to an image sequence:

The frame rate, aspect ratio and dimensions are the same as the original footage.
If you are creating proxy footage, make sure the aspect ratio and frame rate are the same.
If you are using a particular bit depth, make sure you convert to the same depth if you are using the footage for rendering inside mocha
If using compressed footage, don’t set the compression too low, as this will create artifacts that may hinder tracking and roto.
Make sure mocha supports the sequence you are converting to!
If you would prefer to convert to a movie clip format then we recommend a standard format that QuickTime would understand, such as Animation.


#3

Mary,

I’ve seen your canned response to this in every post where someone says they’re having this problem. If you read my post, you’d see that this is happening to a project that I had already been working on. It was working fine yesterday, and now it is not.


#4

Sorry, I thought you were saying it was working in AE and not mocha, and didn’t realize it was working yesterday in mocha and not today. I have a “canned” response because it is literally the most common answer to the issue and I find many users don’t look up supported formats. I am glad you search the forums. :slight_smile:

However, if your issue is suddenly appearing, that is weird. Did you update your OS, codecs, or quictime lately? Did something change on your machine that we can use to narrow down the issue? What OS are you on? Why are you relinking the media? Could it be that if they are not on your hard drive you are having a networking error?

Let me know and we will try to track this down.


#5

So, I hadn’t even restarted my computer since yesterday. I left, and came back, and boom. No worky. I first noticed something was funny when I would send a clip from AE to Mocha, and it would start me off with a blank project, no clip, called “new”. Usually it makes a project with the same name as the clip I sent. So, while in mocha I opened up a previous track from yesterday, and where the footage was suppose to be was a bunch of yellow text telling me the file was unsupported or corrupted. So I tried to “relink” to that same clip - also a different, identical clip on a different HD - and I got the error message. Then, I restarted my computer thinking, hey, magical reboot! Same thing.

 

The QuickTime files are Apple ProRes 422 HQ 4K files. I also just made a QuickTime with JPG compression, and that didn’t work either… and literally just now tried it with H264 from a 7D, and XDCAM HD, and another ProRes 422 1080p file. Same message.

Appreciate the help.


#6

OK, is this a work machine that could have been updated without your knowledge while you were away? Sometimes IT can roll out changes without your knowledge.

It might be that the codecs are no longer working properly. Can you try, even though nothing should have changed, updating your quicktime program, or uninstalling and reinstalling quicktime and mocha? Because JPEG compressed quicktimes should absolutely work every time, and mocha uses quicktime as it’s image engine. Prores only works if the codec is properly installed, which it also should be, but can you double check and make that your prores codec is up to date?


#7

Also, can you please answer the following questions?

What OS are you on?
Why are you relinking the media?
Could it be that if the files are not on your hard drive and instead on the network and you are having a networking error?


#8

I’m on Yosemite.

Also, I tried to relink the media, upon opening an existing project, it told me it couldn’t recognize the footage. So I tried to relink it. There is no network drive. It’s an internal SSD.

I uninstalled AE and Mocha, and reinstalled it. Now it works as before, only overtime I try to save the Mocha project it crashes. If I try to send footage from AE to Mocha, and there is already a mocha project open (not named the same or using the same footage) it crashes.

But now I suppose that’s a new/different issue and I’ll have to start a new thread if I want to get that resolved.


#9

Nah, you don’t have to start a new thread to get that resolved. Can you email me the file though? maryp@imagineersystems.com

I will see if I can recover it.


#10

I’m having the exact same problem, help!!!


#11

If you just restarted your machine, your mediaIOserver might not be running. Try restarting, waiting a few minutes for all processes to start, and then starting mocha.

Can you let me know if that helps you?


#12

When I just had this same problem in Hitfilm, I just had HF export the file back out as an mp4, which it was to begin with, and then brought that back into the media panel. I then opened up the newly exported clip in Mocha and it worked fine… not all mp4’s are created equal i guess…


#13

Right, MP4 is the container, the codec is different, like animation or JPEG codecs are not the same as prores, etc.


#14

 
<div id=“kpm_content_wrapper” class=“notranslate”>Hello,</div>
<div class=“notranslate”></div>
<div class=“notranslate”>I am having the same issue. Just installed QT on Windows 10, using the latest version of AE CC (14.1.0.57) and I can’t open any of my clips in Mocha AE. I’ve tried multiple file formats exported using a number of different codecs. What else can I do here?</div>


#15

Have you tried using JPEG or PNG frames? Have you tried animation or uncompressed .MOV files?


#16

So sad that there is no clear reasons and explanations of how to avoid such a bug… Last time I felt so was probably with Windows 95

image

Could that be a problem? It pops up when opening Mocha. Trial standalone.

image

P.S. It can open images. and no, I don’t have blackmagic codecs installed.


#17

It’s the same answer, Mocha can’t read the codec you are using.


#18

maybe it’s time for you to revisit that answer - it’s useless… As the link in the error box of the soft also… The link you are sharing always also is pretty much useless when talking about this issue…
answering which codecs Mocha support and where do we get them would be much more productive…


#19

I can’t really change the answer, it remains the same. But I didn’t see how old this thread is, yeah, I can see that the link is broken since we updated the site. You can find supported formats in our documentation here on the new website: https://borisfx.com/support/documentation/mocha/6.0.0/#_file_formats

It’s the same information we have in our help file.

Everything else still applies. As to whether or not Mocha supports whatever codec you are using on your machine, we can’t have a comprehensive list for that because we have no way of narrowing down your OS, whether or not you have quicktime installed, whether or not you have those specific codecs installed, etc. We can’t have a “comprehensive” list of codecs for movie files because it varies for every machine. Image files are much more stable for this reason across the board.

In your screenshots above, I have no way of knowing what codec you are using, but I can see it is an MP4. In general, .MP4s rarely work well in Mocha in windows, but .MOV files usually do. Basic codecs like Animation and JPEG or PNG usually work on Windows, but it really depends on your machine, whether or not you have quicktime essentials installed, and whether or not you have the proper codecs for what you are trying to use installed on your machine. But don’t expect things like ProRes to work on Windows.

In the rapidly approaching future, we are working to have Mocha AE to read whatever the host reads and not launch externally, and that should fix this issue for everyone.

Cheers,
Mary