"Failed to track frames" when using the "track all views" feature

Hi, I just recently upgraded to mocha pro to handle some stereo monitor inserts I’ve been struggling with for a while. The tracker will run through the sequence just fine, but if I turn on the “track all views” feature, it will get to about 50-60% of one frame, then stop completely with the error message “Failed to track frames”.

I’m attempting to track a computer monitor that is displaying a pure black and pure white tracking pattern I made. Because it’s a computer monitor, and it’s ON, there’s a significant amount of this bluish glow in the background, and it’s majorly throwing off my tracks. Rather than looking at the white dots, mocha seems to be paying more attention to the way the blue glow moves. So what I did was I exported a separate sequence that just uses the red channel with slightly crushed whites and blacks. So within the area on the monitor I’m trying to track, it’s pure black and pure white. This gives a much more solid track… in 2d… I can track it in stereo if I just turn off the “track all views” feature, but I’d really really like to be able to keep that on, as it takes a lot of the work out of lining up the two initial frames… plus I’m a little bit worried about drift when leaving it off.

I’ve also tried – instead of using the red-channel + contrast method above – drawing tight circles around each individual tracking marker to get mocha to focus on just those areas. Well unfortunately this means that if there’s a sudden movement, ALL of the track marks slide off and it fails. My guess is mocha doesn’t search outside the splines, so all it sees after that point is black.

I don’t suppose there’s any way to dictate to mocha which area’s are “important” or not, while still having it search a larger area, is there?

Hi Trevor,

Can you send me the shot on dropbox or google drive? I will have to experiment with it and see if I can get you a workflow that will sort it easier. It’s hard to diagnose without seeing it.