Frame not rendered in clip "Remove input" Can not remove object

I don’t know whay I am doing wrong but when I try to render the clean plate I created to remove an object I get this message and it does not remove the object "Frame 524 not rendered in Clip “Remove input”.
I have input clip on “input” Cleanplate clip on “Clean plate input” use cleanplates exclusivelly marked.
When I press the render button I get this error message all the time. I am on latest version of MochaPro 7.5.1 and Davinci Resolve 16.2.4. It was easy to do before but the update to Davinci or Mocha has messed things up I think. I also see that when I create a plate it is an exr file32bits (I dont remember it this way before but it has been a long time I don’t remove anything with Mocha- I use the clone tool as with 32 bits I can not use the healing brush) Can I convert the plate to TIFF 16bits so I can use the healing brush?
Well I am lost and stuck . Any hint what is activated or not that makes me unable to render the clean plate and gives me this message. Thank you

I’d definitely give 16 bit tiffs a try and see if that cleared it up but 32 bit should be supported. This sounds like a potential bug so I am going to tag @martinb

Ok I am a little lost with a few things now. I tried to roll back to version 7.02 that I know for sure worked and I unistalled throwing to the paper bin the ofx placed in the davinci ofx folder and removed any remaining boris files with an uninstaller. I installed version 7.02 but when I go to the help version I still see v 7.5.1 So first confusing thing. I install the v 7.02 again just in case (as before I had to manually remove because I got a message than a newer version was installed and did not let me roll back to 7.02) So I am no sure in what version I am now. Is there a way to know . Maybe a new feature in 7.5.1 that was not before in 7.02 so i can be sure what version I am in.
In any case I tried to save again in TIFF 16 bits and it does not matter what I do always get the same message : "Frame xxx not rendered in Clip “Remove input”. and nothing happens the clean plate does not remove the object . ?¿?

Can you send me a screenshot of your remove setup?

Well Finally I got my mistake. I was making the initial track outside the object I wanted to remove and this is because it could not remove it. As I was linking the selected object to the initial track I thought that it was not necessary that the background track needed to contain the object to remove. Rookie mistake but I use Mocha Pro not very often (part of because it is quite a difficult program to manage:-D and try to avoid this kind of complex work as much as possible). In any case I was unable to attain the removal because I think the object to remove is too complex, at least for me. There is a sun that messes up the interpolation and I think I would need to retouch every frame one by one (at least the first second when it comes out from the stone). I would like to attach you the video so you can see it and it would be great to hear how you would attack a removal like this and if you think that Mocha could manage such a thing. I want to remove the phone antennaRemoval of phone antenna that gets discovered behind the megalith. The problematic frames are the ones close to the megalith as no method I tried (lineal, interpolation,…different values of smoothing etc, the brightness of the sun messes up the plate.
https://www.dropbox.com/s/yy4brq5nk2xddgt/Menhir2.mp4?dl=0
Also what would you track?. I selected a big square containing the monolith and surrounding area but the track was not good at all and I had to finally manual track the antenna The monolith covering the antenna makes me wonder what should I really track ? I though the terrain under the monolith (as this one stayed outside the stone) but this was causing the error because I was not including the antenna. That is the reason because I finally included with a huge square everything-monolith-antenna-and terrain but I doubt this is the best option… :roll_eyes:
Sorry for this for sure easy questions for an expert and thank you for your help.

I don’t even think you need the remove for this, as that might be overcomplicating the process, try drawing a roto thin and feathered roto shape around the pole and using that as a subtracted shape, duplicate the clip and place a the duplicated clip below the original clip, offset the clip a few pixels left or right. Call it a day.

1 Like

I am lost. Any video anywhere where it explains this process step by step. Thank you.

I don’t think I do have a tutorial for that. Step by step is:

  1. In your timeline, duplicate this clip exactly and place it above itself.
  2. Apply mocha on the top layer
  3. Draw a thin shape around the tower
  4. Save and Close Mocha
  5. Apply the shape data as a matte and use the checkbox to invert the matte
  6. Move the bottom level clip on the timeline right or left to reveal towerless pixels (for future readers, I mean position wise not time wise, the time needs to sync)
  7. Adjust any feathering to your satisfaction

I can’t remember if Mocha Pro in Resolve will apply a matte in the plugin or not, so if it won’t, then just export the matte and replace that workflow with applying a B&W matte in resolve as normal.

I do all the steps but when I invert the matte (step 5) I get a black mask (the shape I draw in Mocha)
When I move the clip in the timeline under it to the right I still have the top clip with the black rectangle.

Then I tried to make the same without Mocha (using davinci powerwindows in Resolve not Fusion) but again with no success. I
1- Duplicate layers
2- On the second layer draw a powerwindow with polygon tool around the antenna. Then create a an alpha output and connect the power window(polygon around the antenna) to the alpha output
3- I go back to the timeline and move the clip that is on the bottom to the right.
It does not work. There is a second where the antenna disappears when playing the clip but for the most part it is there.
:disappointed: I am doing something wrong but dont know what step is the one I am failing to do it right.

That’s odd, it should populate across the timeline if the shape is correctly tracked. I’d have to see what is going on to troubleshoot.

removin antenna video

Ok I recorder a video of all the steps I take. Maybe you can see what I am doing wrong

Ah. When I saw move the clip left and right I mean move the position of the clip, not move the clip on the timeline by shifting the position on the timeline. The clip has to line up perfectly. The position of the pixels needs to shift right or left. Not the timing of the clip.

1 Like

Thank you That was it. Brain fog on my side. :laughing: Thank you very much. Sometimes i get so fixed with the tracking and all the more detailed stuff and the easy thing you spoil it :face_with_hand_over_mouth:
Thanks again. This is a similar method to moving the node sizing in the node sizing tab inDavinci. Good enough results in this case. Now I have another weapon to confront object removals.

Oh good, I am glad that solved the problem.

1 Like