Gaps between keyframes when using Apply Export


#1

I’m tracking 4k footage in After Effects v 16.0.1 with the Moca AE plugin v 6.0.1. The exact resolution is 3840x2160 at 29.97fps and the clip is ProRes 422LT.

The tracking is working perfectly fine. I save the Mocha project and go back to AE, then click on ‘Create Track Data’. Once that’s open, I select my layer and click the “gear” checkbox. The tracked keyframes are created fine. Then I select my top layer (simple iphone screen replacement graphic) which is also 3840x2160 @29.97fps, and click on ‘Apply Export’. The keyframes are copied over, but they are strangely spread across the timeline with 4-5 frames between the keyframes. This has happened ever since I’ve started using AE 2019.

The only work around I’ve found thus far, is to manually create a Corner Pin effect on the top layer and NOT use the ‘Apply Export’ button in the Mocha effect panel. Then I go to the Corner Pin effect and pickwhip each corner to the appropriate keyframes on the Mocha tracked layer.

Is this a bug in Mocha AE? Anybody have this problem, and have you found a solution?


#2

This sounds like you have a stretch or retiming value on your footage layer (either intentionally or accidentally).

If you need to keep the footage retimed, you’ll need to precomp it before applying the mocha plugin as we take the raw source material without modifications.

Let me know if this is not the case.


#3

I wish that were the case, and that was the first thing I checked. I’m using the raw source footage in my comp with no time remapping at all. No stretching either.


#4

Hmm that is bizarre then.

Are you able to send us the project file to take a look? Spaced keyframes usually always means a timing mismatch of some kind, but i’ll need to see it first hand to look it over.


#5

I know right? Here’s a link to a reduced project, that has the source clip of one of the problem scenes. On layer 1, I’ve manually created the Corner Pin effect and pickwhipped the relevant corners to the tracking data on layer 3. Layer 2 is the result of using ‘Apply Export’ directly from the Mocha AE plugin. I’ve verified that there is no time remapping or stretching happening, and the comp settings are identical to the clip I’m tracking.

While the copying and pasting of keyframes, or pickwhipping to relevant tracking data on the Mocha layer works, it prevents me from using AE’s motion blur. I’ve been resorting to using RSMB or CC Force Motion Blur.

Let me know your thoughts, and whether or not you have the same problem. Thanks!


#6

I redid the shot and I can get it to behave itself. I’m now just trying to work out why your version is NOT working!


#7

I’m currently entirely baffled by why your version is behaving weirdly.
The tracking data generation is off by .391 which seems to also be causing the spacing of 5 frames on applying the export.

I can get it to match if I use Mamoworld’s Mochaimport + tool, but i’ve had to hand your project on to the developement team to see if we can determine what in this project is causing a mismatch.


#8

All good. Really appreciate your help and experimenting on this. If you need any info in the meantime let me know.