Getting a Unable to complete operation (standard library error)

Hey all! Just doing a basic logo removal in Mocha Pro for AE. Getting a new error I haven’t seen before. Whenever I hit the gear icon to render a preview of the cleanplate, I get this error.

Unable to complete operation (Standard Library Error).

I get this error on the most recent version (6.1.1). Went back to 6.0.3 thinking it might have been the new version but it’s the same. The track works fine, just going to preview the cleanplate is where it errors out. And the plugin in AE won’t process the rendered frame either.

Tried it on both the 8K .r3d footage and a 1080p .mov proxy, tried a .tiff and .png for the cleanplate, did restarts, pretty much everything but uninstalling AE which I hope I don’t have to do.

Any ideas? Thanks all!

image

Can I see the whole Mocha interface? I think that might be helpful to diagnose this.

Hey Mary! Huge fan of your tutorials! :slight_smile:

Here’s a full screenshot. Let me know if you need any other views!

Can you check your surface tool on the BG and make sure it is visible for the entire timeline? If it disappears, try moving it to a more central location and making it smaller.

Then try deleting the cleanplate you have in the clip tab, and then reimporting the cleanplate.

I am so glad you like my tutorials!

Let me know if that works for you!

Cheers
Mary

1 Like

I checked it, and still got the same error even with the reimport. Here’s a zoomed out view so you can see the area I’m working in is pretty small. With that pesky error again!

P.S. I’m on 6.0.3 since that’s the previous version I had tried to see if this works. But as I mentioned above, 6.1.1 gives me the same error still. :frowning:

Interesting and aggravating all at the same time. Let me confirm with @martinb but I am concerned this might be a defect. We may have a workaround. Let me check!

Oh! can you try one more thing, can you switch over to CPU instead of GPU processing in the Mocha preferences? Then restart the host and try again? It might be a GPU error.

If you render, then render again, does the error turn up twice?

Also wha is your graphics card and current driver?

Hey all! My apologies for the delay in getting back to you.

@maryp so I didn’t have GPU currently enabled when I was getting this error. So I enabled it (had to confirm unsupported GPU) and it still didn’t work. So I don’t think it’s a GPU related issue!

@martinb I have 2x 1080Ti GPUs running the latest studio driver, V 430.86 but as I mentioned above, I didn’t have GPU processing enabled as the GPUs are listed as unsupported. Even when enabling support and restarting Mocha I still have this issue. Is there a log or something I could send you to verify the status of the GPUs?

Thanks everyone!

EDIT: @martinb yeah, I did try hitting render and then render again. It continues to show up even when pressing twice. I wish the error was more descriptive so I could better describe what’s going on!

EDIT 2: Forgot to mention, it doesn’t matter what frame I try this on, it will fail to render. If I try to render the BG layer it gives me the standard “Unable to replace layer pixels: no active layers found behind the layer” message so I know it’s specific to whatever this is doing. I’ve also tried clearing the project, trying different clips, deleting the Mocha project and starting over a few times, and the error consistently appears right at the render stage. :slight_smile:

That’s highly peculiar. Please send me the full imagineer.log as an attachment from Help > View log.
You can send it to martinb [at] borisfx.com if you’d prefer the content to be private.

Hey Martin! I don’t mind sharing the logs at all. Then anyone else who might get this error can come here and see the continued conversation. :slight_smile:

Here’s the log! Had to zip it so the forum would allow it to upload.

imagineerlog.zip (21.4 KB)

Okay so I’m not sure what happened but it’s working now.

I uninstalled 6.0.3 and re-installed it this morning. Tried with no luck. Then I just installed the update to 6.1.1 and now it’s working again! I don’t know if some element of the code library didn’t install on the first go-around? #shrug

Still have the log there just in case it turns up anything strange. I can confirm that I was having this error in 6.1.1 (that’s why I downgraded) but for now it looks like everything is where it should be. Thank you all so much for your helpful and quick support!

I am really glad that solved it, but we’d definitely like to pinpoint this in case it is a defect. Thank you, we will do more research.

1 Like

had same error message using intel gpu…

changed to nvidia, works now

Charl

I don’t quite understand the kind of question you asked,But l found some typical standard library error :
https://docsbay.net/common-library-problems. hopefully it helps!

Having the same issue: Standard Library Error
Using the Mocha Pro Remove with two Clean Plates.
Initially, the renders worked fine, I made some adjustments and then the module would stop render after about 24 frames.
I re-booted the computer, but still, it won’t render out the entire clip.
Running Mocha Pro 2019.5 v6.1.1
Avid MC 8.8.1 on iMac OS 10.13.6
Thank you.

Hi there,

Try updating to the new v6.1.2 version: https://borisfx.com/downloads/?&product=Boris%20Mocha%20Pro%202019.5