Great tracking in Mocha - doesn't line up in AE

I’ve been spending days trying to figure out why I can’t get the translation, scale, rotation, shear and perspective to match in AE like it does in Mocha.

I am working with 2:1 - 2048x1024 - 23.976
When I past the data onto my layer in AE CS4 which is the same size as the comp, only the first frame matching perfectly, but from then on then image is all over the place. What is causing this?

My AE comp and Mocha project is the same setting as the footage.

Ok. I just tested the clip you mention and it worked perfectly… 1st try.

  1. I imported the clip to mocha. Did not de-interlace OR remove pulldown.
  2. Tracked the same area that Andrew does in his tutorial.
  3. double checked my settings: fps and PR match AE
  4. Paste track data to 1st frame of AE layer.
  5. Delete scale, rotation and anchor point. Use just transformation like the tutorial.

Worked fine. Possibly you de-interlaced your clip? Not always necessary. mocha will only track frames if you do not select the “track fields” button.

Hope this is useful. I can not do a tutorial with this clip (don’t have the rights) but am glad to confirm the issue is not a sfw issue.

Cheers,
Ross

—Quote (Originally by tropx)—
Thanks Ross for the reply. I’ve checked, double checked, and triple checked frame rates, aspect ratios, comp parameters… you name it, at least a dozen times, and get the same results every time. I’ve even tried every variation of tracking with/without perspective, shear etc. I’m pretty sure that it must be an After Effects thing because I got the same results with PFtrack.

More info: The clip I’m using to test with is the Set Extension project clip from Andrew Kramers Set Extension tutorial, #45.

I’m using XP-sp3 OS, Quad processor.

It would be wonderful if some body could knock out a quick tutorial of step by step using that particular clip, and achieving the correct results. That way I (we) could pin point the problem.

If it were just happening to me, it would be obvious what the problem is, but there are too many people on this, and other forums having the same trouble.

Thanks Greatly!
—End Quote—

Almost any time people report this, it is either due to a mismatch in the frame rate of the mocha project, the source files and the AE comp. Check that AE is interpreting the frame rate of the source files correctly.

Also check the aspect ratio is set correctly.

Beyond this, you can send us your projects to check.

Hope this helps.

rosss@imagineersystems.com

I will take a look at the clip you are using when I get a chance.
Best,
Ross

I have the same problem. After going through the workflow correctly, I notice that if I step through the frames 1 at a time in AE, Mocha track Data, and AE are rock solid for about 2 or 3 frames then the next frame only Mocha track Data continues, and AE doesn’t move, then the same pattern repeats again. It’s almost like a pulldown cadence type of thing, which makes me believe that it’s an AE problem. I have the same problem with Pftrack. Is there some hidden setting in AE that I’m missing. That to me, would be the only thing that would explain why this happens only to a few users.

Something like this: ----= frames

AE --x—x—x–x—x—x—
MO -------------------------

Thanks Ross for the reply. I’ve checked, double checked, and triple checked frame rates, aspect ratios, comp parameters… you name it, at least a dozen times, and get the same results every time. I’ve even tried every variation of tracking with/without perspective, shear etc. I’m pretty sure that it must be an After Effects thing because I got the same results with PFtrack.

More info: The clip I’m using to test with is the Set Extension project clip from Andrew Kramers Set Extension tutorial, #45.

I’m using XP-sp3 OS, Quad processor.

It would be wonderful if some body could knock out a quick tutorial of step by step using that particular clip, and achieving the correct results. That way I (we) could pin point the problem.

If it were just happening to me, it would be obvious what the problem is, but there are too many people on this, and other forums having the same trouble.

Thanks Greatly!

Thanks for the quick step by step, I really appreciate it. Though it still doesn’t work for me. I’m going to uninstall, and reinstall AE, it’s the only thing I havn’t tried LOL!

However, I did discover some interesting things along the way.
AE reads the clip as 23.98fps - 198 frames. The AE timeline reads starting frame o, last frame 197.

Mocha reads the clip as 23.976, start frame o, last frame 197 (import pages). The Mocha timeline reads it starting frame 1, last frame 197.

Now, the most unusual discovery. If I track with the AE tracker from the floating window that I have up in my layout (in AE), I get the same results that I’m getting with Mocha. If I right click on the comp preview, and select track from the menu, then continue with the track, edit, apply etc. from the floating window… the tracking is rock solid!

Maybe I missed an AE bug fix or something. I know it’s a straight forward, very simple process, but it just doesn’t work for me for some reason. I’ll keep chipping away, and let you know how I come along.

Thank You very Much

Well, I finally got it to work. I downloaded an update for AE CS4 (ver.9.01), one of the fixes was for Mocha, and AE not reading QuickTime files correctly. I thought this has to be it… it didn’t help. Still same problem.

I then converted the clip to an AVI, and just got a blank white preview window in Mocha.

Even though I’m sure that I converted the clip to a jpeg seq. once before, and tried with no success, I tried that again, and it WORKED perfectly. Also, PfTrack works (had same problem as Mocha bsfore update).

My only conclusion is that, with the AE update, QT files still don’t work but jpeg sequences do. Being that PfTrack also works now, I have to assume that it was an AE problem, not Mocha.

update:

http://generalspecialist.com/2008/12/patches-for-after-effects-cs4-and.asp