Having issues with corner pin and tracking in general


#1

Here’s a video I whipped up to hopefully cover a lot of ground really quick instead of writing out a giant post. I’m fairly new to using mocha but I’m pretty sure something is wrong. I really hope it’s just me :smile:


#2

Hmm that is a weird one. Everything you’re doing seems to be correct.

Can you send me the project files? I’m curious to see if this has something to do with your large scale and rotation in the shot: martinb [at] borisfx.com


#3

Sure I could do that. Would Google drive be ok for you pull them from? I can upload them in a few and send them. What email should I share to?


#4

Yup, that works for me :slight_smile:


#5

Having the same problem the track looks great, but its not placing it in the right place.
I’'m using Transform with nulls, sometime the logo that I’m inserting won’t show up, just the raster box in AE?


#6

The issue I can see in the comp which may be causing a problem is you’re using a 1920x1080 clip inside a 3840x2160 comp and scaling the footage by 200%.

You need to precomp the scaled footage for it to be treated as the full size, and therefore generate the data correctly.
I tried this on the original (unscaled) footage and it applies to the right place.


#7

I’m having the same issue. Even if the framerate and size is the same. Pre-comp-ing didn’t do it either.

BUT: the work-around that you show in your video works if you do it like this:

  • do the tracking in mocha
  • create track data within the mocha effects panel in AE
  • do NOT “apply export” to any layer
  • now add the layer that you want to apply the tracking data to to your composition
  • pre-comp that layer
  • add the effect “corner pin” to that comp
  • Now here’s the important part: copy the corner pin data from your tracked layer one by one. So first you copy the “top left” data and copy it to the “top left” in the pre comp. Do the same with top right, bottom left and bottom right.

This worked for me. Still, that’s obviously not how it’s supposed to work.