Having trouble masking out Paint strokes,

Continuing the discussion from Having trouble getting Roto mask to work:

@marco -I am not sure if I am asking the right question. Both shapes are tracked and stick perfectly. What is happening is that I painted the bushes over the building. The alpha on the rectangle is set to obey alpha and inverted, so the strokes are only in the box; I made another shape and put it on the tree trunk to mask out the tree when it cuts in front of the buildings. My issue is that I can not get the alpha of the tree to mask out the box when it passes in front of the buildings. I inverted the tree alpha, used add and subtract bend mode, and I don’t know what I am doing wrong. The tutorials don’t cover the masking out part too well

Without seeing your project, I think the following will work. Don’t do the invert in the Roto node. Place the Tree shape above the rectangle shape and set it to Subtract. This will subtract the tree from the rectangle. In the Paint node, you can invert the alpha.

That is the current configuration , is there any way you can look at my project, this shot is due for class on Monday

  1. Set Bezier 1 to an Add Blend Mode and turn off Invert.
  2. Select the Tree Track layer and set the Blend Mode to Subtract
  3. Select the Node tab at the bottom right of the screen and set the entire node to Invert.
  4. Select Rebuild in the Paint > Auto Paint window

A couple of things…

  • In the future, it is not necessary to do the inversion within the Roto node. You can invert the alpha within the Paint node. I am leaving the inversion in the Roto node so that your paint strokes will rebuild properly as changing it now would require extra paint steps.
  • Setting a shape to Subtract only subtracts from shapes within the same layer. That’s why it had no effect.

Hope this helps.