[Help] Mocha Pro (AE) Remove module "freezes" my cleanplate clip in and does not track it even though I have a track

Hi there,

I’m running into a strange issue with Mocha Pro’s (AE plugin) Remove module. I’ve done a few shots so I’m moderately familiar with the program and can’t figure out why my remove isn’t working.

See the below video for more details on my problem and all the steps I’m taking
(pertinent question is at 2:18):
https://drive.google.com/file/d/1D0F5v4-X4s8J0vp8HWX02IfxlcxiBH8U/view?usp=sharing

Problem:

  • Trying to do a relatively simple track and then use the remove module to paint out the text in a credit card.
  • The remove module works fine on the frame in the cleanplate, but when I render backwards (or forwards) the remove is “frozen” on the cleanplate clip and it does not track my cleanplated area, so it looks like my track is a mask with “subtract” set, and you’re seeing my frozen cleanplate underneath, not moving or tracking. (Difficult to describe, easier to understand if you watch the above).

Any help would be appreciated - thanks!

Are you able to send me the original clip?
Also, try deleting the BG layer and duplicate the card layer, then try removing with the top card layer.

Actually, can you show me what your clean plate dialog has inside?
Check to make sure the listed clean plates are set to the frame you painted, as opposed to “All”

Hi there,

Thanks for the reply!

First, I tried deleting the BG layer and duplicating the card layer - did not work (still frozen but now the colours are crazy, I assume, becuase the BG pixel space is limited).

As for the clean plate dialog, sorry, not sure what that is - can you please clarify? If it’s the pulldown menu for “Cleanplate Clip” you can find that below:
https://drive.google.com/file/d/1hGDGZPjQlEYF_eXYHRBYFR63ZlVGXG-i/view?usp=sharing

Thanks for your help!

EDIT
To clarify, in case the clean plate dialog is the pulldown, I have some other attempts at clean plates (start and end) in there, but am only selecting the one that I want to actually use - is that my issue? I would have assumed it would only use the clean plate you’ve selected? And if so, is there some way to delete them from that pulldown - can’t seem to find?

I mean when you click the “Edit…” button, there is a dialog that shows up to list all your clean plates in the clip.

Wow, thanks, that did it!

I only had one clean plate in the clip and the frame number was set to “All” - I wasn’t sure how to edit it so I just highlighted it and typed the frame it’s referrencing and that fixed it. I didn’t even know this was an option!

Thanks for helping me solve my issue, greatly appreciated!

In the interest of educating me, and anyone else who comes across this in the future, can you speculate as to what went wrong here? How/why did the frame number get changed from the frame I was using it on to “All”, and under what circumstances should we manually change the frame number? Or even leave it as “all” for that matter?

Thanks again!

When you create the clean plate and the save dialog comes up, it should be assigned a frame number. If this frame number is deleted from the file name, or you import a clean plate later that has no frame number in the filename, Mocha cannot determine which frame you need it to be on and assigns it to be “All” which means it will replace any background over the entire timeline with the one frame.

Ah, that makes sense, thanks! I created the cleanplate then did some work on it in Photoshop, then imported it - there was a number in the filename but clearly it wasn’t recognized. Good to know, thanks!

Ok, so it could be a small bug in the interpretation there. We should look into that, as numbers should always be processed if they are the last part of the filename before the file extension.

Can you tell me what your cleanplate filename was, in full?

Sure, my file name was exactly what Mocha first named it as. In this case:

Clean Plate Shot 5_144.PNG

Note that I created a whole new project (after having the same issue on the first project) when I was troubleshooting. In the new project (seen in the above video) the frame numbers start at 0, instead of their original numbering, so in that version it would make sense that frame 144 wouldn’t be found (it would be frame 14). However, I still had the exact same bug in the original project (which did have a frame 144) so maybe that didn’t affect it. Hope that makes sense.

Thanks again!

Thanks. We’ll investigate if we need to improve our clean plate frame number parsing.