Help with 'crash occurred while invoking effect plug-in "mocha AE"'

Hello, I am having an issue with this error when trying to use Mocha AE in AE 2020 (I am using After Effect version 17.0.2).

The message 'crash occurred while invoking effect plug-in “mocha AE” keeps showing up when I access Mocha, forcing me to click “OK” and closes the application.

Any solution is extremely appreciated, thank you for your help.

Can you tell me a little more about your system? Do you currently use a supported GPU? If not, have you tried turning off GPU processing in Mocha Preferences?

We have a list of supported GPUs here: https://borisfx.com/support/supported-graphics-cards/

Please let me know and I will be happy to help you.

Cheers,
Mary

Hi, Mary

Thank you for your reply. I am using the “Intel Iris Pro 1536 MB” GPU. And no - I have not tried turning off the GPU processing in Mocha Preferences because every time I launch Mocha AE from after effect, the ‘crash occurred while invoking effect plug-in “mocha AE"’ keeps pops up and force me to quit the application.

Please let me know if there is a solution to this.

Best,
Obb

OK, Windows or Mac? I can see if we have a command line way to turn it off. I am certain we do have a way to do that I just have to find it in my notes. I will ask the dev team.

Cheers,
Mary

Hi, Mary

I am using a Mac. Thank you for your help.

Best,
Obb

Alright. @Martinb hooked us up with how to do this:

On the MAC, open the terminal. Make sure your AE and Mocha are both closed. The Terminal app is in the Utilities folder in Applications. To open it, either open your Applications folder, then open Utilities and double-click on Terminal, or press Command - spacebar to launch Spotlight and type “Terminal,” then double-click the search result.

In the terminal, type (or copy and paste)…

defaults write "com.imagineersystems.Mocha Pro Plugin 2020" "EnableCLRemover" "NO"

Then hit enter.

Then type (or copy and paste).

defaults write "com.imagineersystems.Mocha Pro Plugin 2020" "EnableCLTracker" "NO"

Then hit enter.

Now try to open AE and Mocha AE and see if you get the same results. Please let me know and I will be happy to help you further.

Cheers,
Mary

Hi, Mary

It’s still not working. However, the Mocha AE window does not pop up anymore - only the 'crash occurred while invoking effect plug-in “mocha AE”.

Can you email the crash log to maryp@borisfx.com?

Looking at your log, I am not seeing a problem with Mocha I can pinpoint. Can you try fully uninstalling AE and reinstalling AE? The crash log implies there’s a problem with the AE library itself and it may be a bad install.

Also, it looks like I may have given you the GPU command for turning off the GPU in Mocha Pro and not AE, try this.

defaults write "com.imagineersystems.Mocha AE CC Plugin 6" "EnableCLTracker" "NO"

And see if that helps.

Cheers,
Mary

I uninstalled, reinstalled, and tried the new code but it’s not not working.

'crash occurred while invoking effect plug-in “mocha AE” still showing up.

That sounds like a bug, can you copy the text from the dialog that comes up after mocha crashes and paste it here? The logs you sent are not those logs.

Process: After Effects [990]
Path: /Applications/Adobe After Effects 2020/Adobe After Effects 2020.app/Contents/MacOS/After Effects
Identifier: com.adobe.AfterEffects
Version: 17.0.2 (17.0.2)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: After Effects [990]
User ID: 502

Date/Time: 2020-02-26 19:12:21.358 +0700
OS Version: Mac OS X 10.13.2 (17C88)
Report Version: 12
Anonymous UUID: 9840F825-29E8-C835-3C97-8D4486A1C08F

Time Awake Since Boot: 1900 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000078
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [0]

OK, I am looping @Martinb in and seeing if he has any suggestions.

Sorry for the confusion, but can you send the full log from the report dialog please? It should look something like this:

The data you copied there is only a small portion of the full log. We’d need to see the entire log to help determine the crash. You can send this log to Mary and we can take a look properly.

Hi, Mary

Below is the link to the full Report Dialog from my Mocha AE issue.

https://docs.google.com/document/d/1bx_1ws1l9C62Q0Nzu8PHV4oxUbVKzLU70Q6Jn5nccAo/edit?usp=sharing

Best, Obb

Thanks, this is just what we needed. We’ll review.

Can you please go to your autosave directory and backup/remove the files?
By default, the autosave directory is here: ~/Library/Application Support/Imagineer Systems Ltd/Autosave

I recommend:

  1. Copy all the file to a backup directory
  2. Delete the files
  3. Reopen AE and try to launch Mocha

We suspect this crash has to do with a corrupted autosave file.

@heyitsobb , did this help?