Help with insert module

Hi. I’m new to Mocha Pro. I’ve tracked an area on an arm and need to add a layer in After Effects to show a bruise. I’m going to use the ‘warp’ feature, so I’ve added a grid to help align the plate. But I can’t get it to reduce in opacity. I’ve set the blend opacity down to 25% and noting changes. I’ve re-started. Deleted the Mocha effect and re-worked it again from scratch. Still I get to the grid stage and can’t reduce the opacity. I’ll see if I can attach a screen grab of the issue.

Has anybody had this, or is it a know issue?

Thanks. D

What happens when you hit the render forward button? Does the opacity show then?

Hi. Yes it renders with the correct lowered opacity. But then I loose the ability to adjust the warp shape. Also, frames not yet animated have the grid missing and a text frame to say they’re not yet rendered.

D.

Yeah, I think we changed something about the way that worked a version back. Let me ping @martinb and see if this is intended workflow now or if it’s a regression.

Thanks Mary. Without being able to reduce the opacity at this stage of placement it’s impossible to see the dots we added for tracking and alignment.

Thanks. D

There does appear to be a regression here. Very strange.

Sorry about that, i’ll make sure a bug is filed. As a workaround, set your insert layer opacity instead and it should carry through to the insert module as alpha.

For example:

  1. Create a new solid in after effects
  2. Apply the “checkerboard” effect
  3. Set the layer to 40% opacity
  4. Precomp the layer and move all attributes into the new comp
  5. Set the checkers layer as your insert layer in the After Effects plugin Mocha Pro module settings
  6. Open Mocha Pro GUI and set the insert clip as “Insert Layer”

Not ideal, but at the very least you’ll be able to use it.

I’ve also attached two grids at 50 and 30% opacity if you just want to directly import a grid to use:
30:


50:

Another workaround is to set “re-render on parameter change” on while you are working.
This is in the Viewer Preferences dialog.