Hidden masks above a tracking layer still mask it

When I need to prevent moving FG objects from preventing a good track, I do a rough of the FG object and put that layer above my track.

But if I hide the layers above, I would not expect the top layer to effect the track below. But it does.

This did not happen in previous versions. I assume this is a bug?

The FG matte has always occluded the bottom regardless of visibility.

To avoid this, you either need to:

  1. Place the tracking layer above the layer
  2. Disable the FG layer by right-clicking and choosing “Deactivate layer at current frame”

However, if you would prefer the layer to be disabled from the calculation when it is not visible, we can add a feature request.

Thanks.