How do I change 32bit to 16bit using the cleanplate Remove module?

When Im in Fusion/Resolve and load Mocha Pro ofx, I want to use a cleanplate to retouch in photoshop. But when I open in photoshop the image is much brighter and in 32bit resolution?

Is Photoshop applying it’s own color profile to the image? You should be able to change your image output preferences in Mocha Preferences too.

I get to choice adobeRGB 1998 and sRGB…thats the only option.

What format are you saving the image in? TIFF or EXR?

I can only save as tiff.

OK, I have to do some research and find out what’s going on here. Check and make sure Photoshop isn’t applying an alpha oddly, just in case, because I have seen it do that sometimes.

Can you also check and see if you can assign colorspace values manually in the clip tab and see if that helps you?

I will see if this is a defect.

Cheers,
Mary

Can you let me know what version of Resolve and what version of Mocha exactly you are using? On what OS and what version of Photoshop?

MacOS High Sierra V.10.13.6
Resolve Studio 15.3.1.003
Mocha Pro Plugin 2019 V. 6.0.3

Seems that when I created a cleanplate from Mocha it gets much brighter, just by looking at it in the finder.

The image is from mocha and photoshop
. see how photoshop is much brighter?

Yes, I have seen this before, just trying to track down either the fix or log it as a bug.

1 Like

Hey, I got it to work when I only use it as a plugin on a node in Resolve.
But in Fusion it doesn’t work.

1 Like

OK, that helps to narrow it down. Thank you. Make sure the colorspace in Fusion isn’t set to something weird or again that it isn’t doing a weird premult to the image. Nuke sometimes does the same thing, I have seen, if you don’t set the comp color space correctly.

1 Like

Just to be clear, I don’t use Fusion or Nuke, but I am a Mac user. Don’t judge what a high-end image, or complicated PDF file looks like by only hitting spacebar in the Finder. The Finder isn’t set up to view files like Photoshop or Acrobat using deep colorspace, profiles LUTs, etc.

Just thought I’d throw that into the mix. Good luck.

Before you jump down this rabbit hole, be aware that:

  1. Mocha 2019 v6.0.3 and earlier does not support Resolve
  2. Mocha 2019.5 when it is released (currently in beta at the time of writing) will only support Resolve 16 and up.

I’m not sure what the Resolve 15 color space will do to the OFX image data for Mocha 2019 as we haven’t tested it thoroughly for the above reason.

By default we always save out the highest bit depth and resolution available for a clean plate.

1 Like

Hi, I have the same issue with Mocha Pro OFX Plugin in Fusion Studio 18.
After creating clean plate in Mocha Pro’s Remove Tab I’m getting a TIFF 32bit instead 16bit. And it’s brighter.

I’ve tried multiple settings, and still getting the same result. Of course I can change image mode in PS from 32bit to 16bit but I have to manually match the color and gamma (HDR tonning pops up) to make image looking as close as original, which seems a bit pointless.

I get that Mocha takes out the maximum possible depth (seeing the older answer in this thread), but in your YT tutorials with AE + Mocha Pro it JUST WORKS. And it doesn’t matter if I change depth in Fusion. It just ignores it.
I would be happy to at least have a choice between 16bit tif and 32bit tif during export.

My setup:
Fusion Studio 18
Mocha Pro 2022.05 v9.5.2
Photoshop 2022 v.23.4.1
MacBook Pro 16 Apple M1 Max 64GB

In the pictures are my settings and issue. Is it a bug or am I doing something wrong?







I am going to have to ask @martinb about this one. I will tag him to chime in here when he’s available.

1 Like

Even when I unpicked “lock depth” option in Fusion’s Project and Global settings and in the viewer it shows for both nodes now that it’s float16 instead float32 for Mocha node as in screenshot before, in Mocha Pro plugin window still it’s default float32 in Clip tab.
And of course still getting brighter clean plates tif 32bit instead matched in look 16bit.
I have no idea what am I doing wrong.


The main problem is it appears Fusion just keeps sending 32 float images, regardless of your settings in the node graph. I just tried this myself. Even using the change depth node, Fusion always sends us 32-bit images. I’ll have to check in with the dev team to see why this is the case.

The good news at least is this won’t affect your workflow unless you plan to use the clean plates separately from the Remove module.

If you want to view your clean plate image in Photoshop with the screen color space, just change the proof setup here:

1 Like

As it turns out, this is just workflow in Fusion, and we only output at the depth we’re given as input to maintain consistency.
If you downgrade your cleanplate image to 16-bit in Photoshop you can still import it and it will render back to the 32-bit remove. You’ll just need to keep an eye on the remove render area if you go down the 16-bit path to make sure it looks consistent with the rest of the image.
You might be better off keeping it to the 32-bit workflow and view the image as stated above.