How do you draw a particle path?

I’d like to draw a path for a particle emitter to follow with timing based on a musical comp.

I believe I’d be able to figure out syncing with the rhythm if I could just figure out how to draw the path without use of deflectors.

The closest I’ve found to what I’d like to accomplish was posted here. But the post was dated in 2019 and the posted response doesn’t seem to be applicable to the most current version although there was mention that a later version would likely have it.

Has the feature mentioned by the responder to the post been implemented as of yet?

Hie There!

Are you working with the plug-in version or the standalone version of Particle Illusion? In the plugin version we have the Beat Reactor feature which synchronises the particle system with a selected audio source file.

Within the Particle Illusion GUI, you can animate the position of the particle emitter along a custom path with bezier spline handles. Let me know if you need help with that.



I am working with both actually. Synchronizing the particle movement with the music is fairly straight-forward. I just load an audio file from the within the plugin using the beat reactor and the rest appears to just work.

I’ve tried several different versions the particle plugin and the one that appears to give me access to both the plugin and stand alone within the host is the BCC Particle Illusion where it appears that I can select any preset using the FX Browser and further tweak it by using the “Launch PI 2023” button.

But creating the custom path is the part I can’t seem to figure out.

To create the custom path, while in the PI GUI just reposition the emitter over time and set the keyframe interpolation to linear or bezier. You will see the editable motion path being drawn on-screen. I’ll see if there’s a on-line tutorial for that and if not I’ll send you a rough screen recording demonstrating this.


1 Like

Hello Peter,

I think I’m getting closer now. Your directions were very helpful to get me going in the right direction. I was not able to locate the section where the interpolation is set but what I was able to do was

  • Turn the “Auto-Key” feature on
  • Press Play for a couple of seconds and move the particle point

This produced a dotted line in the viewer. Repeating those steps I was able to create several different points which upon playing back the particle emitter would move along those lines.

It doesn’t give the flexibility of controlling curvature of the path since the path is linear. So if there is a tutorial somewhere that visually breaks down what you’re suggesting; that would be great!

Hi, when Peter says ‘keyframe interpolation to linear or bezier’ he means the box at the end of each parrameter,

This will then give you Bezier handles so your path can be curved instead of linear

PS. if you want the emitter to pause on screen, to make it not moving, place two keyframes close together on screen but spread them apart at the top of the timeline,

1 Like


With your recommendation and the assisting responses of @Gid.Joiner I have been able to create bezier curves along my text by keyframing each consecutive position with a bezier path.

But for some reason after about the 4th keyframe (using the same procedure) I loose the ability to create the bezier and the emitter point displays a 3D positioner instead of the particle point. As you can see in my screenshot where I’ve circled the bezier points in green and the 3D positioner I get at the 4th point.

As a result the 5th keyframe is now linear.

I am also getting very degraded performance when moving the emitter point. It seems to default to attempting to perform a full render of the keyframe path every time I move the last key framed position and the UI is non responsive until the render has completed. Is there a way to turn that feature off?

In the video below, you’ll notice a light blue line that runs along the key frame track upon every move and see that the emitter on the viewer won’t reposition until that blue line hits the very last keyframe marker which slows the workflow tremendously. I don’t require a render every time I move the emitter point.

I have a title in cursive type font and I thought using the bezier would be the answer although a bit time consuming to trace the text this way to create the emitter path. But I’ve found using the linear path and keyframing to between points seems to be quicker. The only issue I’ve struggled with using the linear key framed path is the variation in speed at which it takes to get from one point to another depending on the distance between key framed points. In short, it doesn’t produce a constantly smooth emitter path as it speeds up and slows down.

Is there not any way to simply have the emitter trace the text with Particle Illusion using masking or something? I can’t imagine why such a simple task should be so challenging to achieve. :face_exhaling:

Hi, I’m going out for a while but can you post pictures or a vid of the full screen, it’s impossible to work out what’s going on from selections of the screen like that.
There’s no way I know of to turn off the blue line render, but if you reduce the amount of particles it’ll update quicker, then when you’ve created your line you can increase the Number back up.

@Gid.Joiner sorry for the delay.

Here is a short video of how I’m trying to trace the text using the bezier interpolation as suggested. You’ll see that I get the bezier handle at the beginning of the 1st point that I can use to create the 1st curve but though I ensure bezier is selected for every subsequent keyframe point, no handle is available for creating subsequent curves along the text. You’ll see near the end of the video clip that I can only create a linear line at the bottom of the “J”. Ability to curve is not available.

Hi, I thought it might be you don’t have enough power, but Pixie Dust looks to be at default settings & your PC looks like it has the power but it’s a Mac, I don’t know anything about those so I’m not sure what is going on with yours,

Your timeline isn’t moving tho, ?

It should be moving along creating little ■ keyframes at the bottom of the window…

Thanks for the response. At this point I’m not really concerned about the degraded performance. I believe that is a separate issue/concern that I’ll create a support ticket to address.

Time is moving. Maybe the screen resolution makes it appear that it isn’t moving. But if you observe near the end of the video when I press play the emitter travels along the path just fine as a confirmation.

The bigger concern and reason for the post is because bezier handles don’t appear to be available at every point to curve the path. Looking at your screenshot, I’d think I’m correct on presuming that; which means I can’t really get the fluency of controlling the path after the first bezier path is drawn.

Everything after that is restricted to Linear. If I’m correct on that, then bezier interpolation doesn’t really present a true end to end solution.

Hi, sorry if that picture is misleading, Bezier handles are available for every keyframe, I only posted that picture to show the keyframes

Maybe this is a better example

PS, I totally trust that you say the timeline marker is moving so pls don’t get me wrong,
I watched your video on Dropbox & I downloaded it, this is MediaInfo of the download 4096x2304

I have a Dell 31½" 4k monitor but at no time do i see the timeline moving or keyframes showing,
Like i say I believe you, it’s weird why it doesn’t show, maybe something to do with the screen recorder? :man_shrugging:

This what i see on MCP player full screen :man_shrugging:

Hmm… okay. In that screenshot I do actually see the continuous curved path you’ve created using the bezier handles in your screenshot. So what do you see that I may be doing differently to explain why I don’t get those handles as well? I see you have the auto key feature turned off whereas I have it on but I’ve tried it both ways with the same result. :confused:

Hi, the default keyframe is the linear one, every one of those I had to go to the box at the end of Position controls & change it to Bezier.

I’ve been getting numerous crashes, normally it crashes as it loads emitters or if i search for Pixie, I only get to pix… & it crashes.
At the moment I can’t open it at all, it opens the screen & then closes.
Windows & Nvidia just updated but it’s been crashing all evening,

Desktop Screenshot 2023.05.30 -

I have a post with Alan, (Can't launch PI) so i’ll continue in that one but at the moment I can’t carry on here, hope you work it out :+1:

Yes, I did the same as you when creating the keyframe points; so not certain what’s broken. I’ll try again this evening and if I get the same result, I’ll open a support ticket b/c obviously something is not working as expected. I have also been experiencing similar issues when launching PI standalone from the PI plugin within my Host (Resolve) It may or may not be directly related but it does appear that both issues indicate a communication problem. Thanks