How to properly view the image based matte

Hi, i create a new spline in layer1 then i also create another spline in layer2. If i swith ON ‘mattes’ and set it to ‘selected track matte’ then if i select layer1, i can see in the viewer that the matte from layer2 cut out the layer1’s matte. So the resulting matte is properly displayed in the viewer. This is just like what i’m expecting to be.
Now, with the same scenario, but this time i change the layer2 where i will use image mask instead of spline. Then when i view the 'selected track matte ’ of layer1, the combined matte is totally wrong. It should display the same result. The image mask (layer2) is working properly , it’s just i got weird view.
Is it a bug ?

Hi, i create a new spline in layer1 then i also create another spline in layer2. If i swith ON ‘mattes’ and set it to ‘selected track matte’ then if i select layer1, i can see in the viewer that the matte from layer2 cut out the layer1’s matte. So the resulting matte is properly displayed in the viewer. This is just like what i’m expecting to be.

Now, with the same scenario, but this time i change the layer2 where i will use image mask instead of spline. Then when i view the 'selected track matte ’ of layer1, the combined matte is totally wrong. It should display the same result. The image mask (layer2) is working properly , it’s just i got weird view.

Is it a bug ?

here are the screen shot :
clip.jpg - this is the clip i want to track , both the checkerboard and the red circle are moving independently.
clip with spline.jpg - this is after i create spline . red is layer1 and green is layer2.
matte view.jpg - i turn on ‘mattes’ and set to ‘selected track matte’. I select the layer1 in the list, so in viewer i got this image which is correct. So that’s the area that will be tracked (rectangle shape with the circle cut out)
now i change layer2 by using image based mask/matte.
using image mask.jpg - this is after i import the matte. I can see the red color indicating the mask.
wrong matte view.jpg - now when i turn on ‘mattes’ and set to ‘selected track matte’ , this is what i got which is wrong . it suppose to display the matte similar to previous setup (matte view.jpg). Why did i say this is wrong? because if we look at image, it’s indicating as if the track area also spread outside the rectangle, which is wrong. The track area should be limited inside the rectangle (spline in layer1).
Am i right ?

here are the screen shot :

clip.jpg - this is the clip i want to track , both the checkerboard and the red circle are moving independently.

clip with spline.jpg - this is after i create spline . red is layer1 and green is layer2.

matte view.jpg - i turn on ‘mattes’ and set to ‘selected track matte’. I select the layer1 in the list, so in viewer i got this image which is correct. So that’s the area that will be tracked (rectangle shape with the circle cut out)

now i change layer2 by using image based mask/matte.
using image mask.jpg - this is after i import the matte. I can see the red color indicating the mask.

wrong matte view.jpg - now when i turn on ‘mattes’ and set to ‘selected track matte’ , this is what i got which is wrong . it suppose to display the matte similar to previous setup (matte view.jpg). Why did i say this is wrong? because if we look at image, it’s indicating as if the track area also spread outside the rectangle, which is wrong. The track area should be limited inside the rectangle (spline in layer1).

Am i right ?

Ok, yes there does seem to be an issue there. I will have it checked out.

When you use an image amsk you will get the red image view of the matte in the viewer, so you will see this in the track matte. Are you seeing this or another issue?
Do you have a screen shot you can show?

When you use an image amsk you will get the red image view of the matte in the viewer, so you will see this in the track matte. Are you seeing this or another issue?

Do you have a screen shot you can show?

Ok, yes there does seem to be an issue there. I will have it checked out.

When you use an image amsk you will get the red image view of the matte in the viewer, so you will see this in the track matte. Are you seeing this or another issue?

Do you have a screen shot you can show?

From 1428870619808953380@xxx Thu Mar 07 05:26:51 2013
X-GM-THRID: 1428844649404231703
X-Gmail-Labels: Imagineer Forums,Sent,Inbox,Important
MIME-Version: 1.0
Received: by 10.52.122.35 with HTTP; Thu, 7 Mar 2013 09:26:51 -0800 (PST)
In-Reply-To:
References:
Date: Thu, 7 Mar 2013 09:26:51 -0800
Delivered-To: maryp@imagineersystems.com
Message-ID:
Subject: Re: New Post/Thread Notification: mocha Pro General Discussions
From: Mary Poplin
To: Martin Brennand
Content-Type: multipart/alternative; boundary=20cf307c9b321dc0bc04d7590377

–20cf307c9b321dc0bc04d7590377
Content-Type: text/plain; charset=ISO-8859-1

Are holdout mattes working for you? I am not 100% sure they are working
properly from some tests I did yesterday.

It would just be the footage though.

Cheers,
Mary

On Thu, Mar 7, 2013 at 2:40 AM, Imagineer Forums wrote:

> Hello,
>
> martinb has just posted in the mocha Pro General Discussions forum of
> Imagineer Forums under the title of how to properly view the image based
> matte…
>
> This thread is located at
> http://forum.imagineersystems.com/showthread.php?t=1926
>
> Here is the message that has just been posted:
>
> When you use an image amsk you will get the red image view of the matte in
> the viewer, so you will see this in the track matte. Are you seeing this
> or another issue?
>
> Do you have a screen shot you can show?
>
>


Mary Poplin
Product Specialist
maryp@imagineersystems.com
+1 (424) 645-5005 Work

–20cf307c9b321dc0bc04d7590377
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable

Are holdout mattes working for you? I am not 100% sure they are working pro=
perly from some tests I did yesterday.=A0

It would just be the foota=
ge though.

Cheers,
Mary

On Thu,=
Mar 7, 2013 at 2:40 AM, Imagineer Forums <forum@imagineersystems=
.com
>
wrote:

Hello,

martinb has just posted in the mocha Pro General Discussions forum of Imagi= neer Forums under the title of how to properly view the image based matte..=

This thread is located at http://forum.imagineersystems.com/sh= owthread.php?t=3D1926

Here is the message that has just been posted:

When you use an image amsk you will get the red image view of the mat= te in the viewer, so you will see this in the track matte. =A0Are you seein= g this or another issue?

Do you have a screen shot you can show?




--
Mary Poplin
Product Specialist
+1 (424) 645-5005=A0=A0Work

–20cf307c9b321dc0bc04d7590377–