Import Custom Shape

Hey everybody, I’m struggling with importing custom shapes. I’m running the Free Standalone Version on Mac OS 12.4 on a decent MacBook Pro (not M1 though).
When I try to import a jpg or png as shape the following happens:

  • I first make sure I select my custom emitter library
  • I select image (I tried png, jpgs, big, small, colour, B&W…)
  • dialog box comes up but the preview is “empty” and all checkered (if click turns all black, like a glitch). Interesting to note that Filename: stays blank and original size is 0x0 (???)
    Changing the size or colour doesn’t change behaviour.
  • Click apply. nothing happens. I can choose a standard shape and continue to work. very strange.
    I’d be so grateful if you can help me with this.
    Best regards
    Vince

Hi Vince,

Please send along the image that you wish to use as a sprite and I’ll take a look.

One item of note though - the original sprite size is 0 in the screenshot you provided so that’s a clue. Perhaps start by adding one of the factory installed emitters, then try to change the sprite to the image that you wish to use and let us know if that works for you.

Thanks,
Peter.

There were some issues with importing shapes in 2022.5 (and some earlier versions), so that might be what you’re running into.

Particle Illusion 2022 works with PNG images, so you can give that a try:

(Note that it’s possible to have PI standalone 2022 and 2022.5 installed at the same time.)

Thanks for your quick replies. I now tried different things messing up with saving the png in b&w, smaller, etc. the behaviour wouldn’t change. Then by chance I copied the pngs on the desktop and it seems I can import them (all sort of versions) only if they’re saved on the desktop. strange, right? but at least it seems to work this way. Maybe this workaround can be useful to others users.
If I find out more I’ll post here. Thanks again for your help. Best. Vince