Import Mattes not occluding XSplines

I following the instructions video Mocha Tips: import and export matte renders, where they import an image sequence and that alpha is used to occlude the layer below it.

I’ve tried to change the transfer modes, etc. but it seems like layer below is always a full frame of white alpha and the result is the inverse of the rendered matte above. The Xspline alpha doesn’t show up until you move the Xspline above the imported matte layer and then the Xspline alpha looks normal.

I think I’ve got a work around where I keep the Xspline above the imported alpha layer. I make the XSpline inverted and turn off processing AND link it to the imported alpha layer’s transforms.

Then basically I run the track but the track is on the imported alpha layer’s plane and that seems to work. But it that’s a lot of steps to make this functionality work.

Oh AND the rendered alpha needs to be inverted for this to work. So all around not intuitive.