Import TrackingData from Mocha AE to AE not working

Hey there!

I know the topic sounds familar to a bunch of simailar topics but maybe this is different. The problem:

In AE I select a clip and go to Mocha. Select the interesting part and track through the whole clip. The result looks really fine to me. But for a test I insert in Mocha via “insert clip” the target clip and play through it. It looks really fine. So I copy via “export tracking data” the format "after effects corner pin [supports motion blur] to the clipboard.

But if I paste the clipboard to the clip in AE the first frame of the clip looks fine but the others frames slip away.

both clips and the comp have the same framerate and framesize and I put the clip to the first frame before I paste the clipboard into it. any suggestions what is going wrong?

I work with:
After Effects CC 2017
Mocha AE 4.0.3
Format of the Clip that I send to Mocha is .mov

Framerate of all clips and the comp: 30fps
Framesize of all clips and the comp: 1920x1080

thnx for helping & best regards from Germany

Hi Nico,

Are the keyframes for the data spaced out or on every frame?
Can you show a screen grab of your mocha tracking window?

Hey Martin!

Thnx for your reply. I think I got the problem but I didn`t found a smart solution.

We record our videos in 60fps. Our standard proceed to transform the 60fps footage to our standard output of 30fps in AE is:

  • Import in AE
  • Transform the footage to 30fps
  • Put the 30pps footage in the 30fps composition
  • Speed up the footage in the comp to 200%

If we transfer this footage to Mocha, make the analytic stuff, copy the data to the clipboard an paste the data to a second footage that is originally a 30fps footage we got the described effect (First frame fits perfect. All other frames slip away).

the only workaround that we found is to transfer the 60fps outside of AE to 30fps. Than it works perfect.

However this workflow is not very smart for us. Do you know a solution aka better workflow in AE. Maybe a “pre-compose” thing?

thnx for helping

Right, so the source clip is actually 60 fps.

Unfortunately for Mocha AE the only way to address this is to either:

  1. Track the original 60fps clip and apply it back to the original 60fps clip
  2. Transcode the 60fps clip to 30fps and track in mocha
  3. Get the mocha Pro plugin, which will read the source clip directly from the timeline, rather than as a clip on disk.

ahh, now I am learning: this means that Mocha AE did not read the clip from the timeline. Mocha AE read the clip from the disk even though the clip in the timeline is converted to different fps-settings. right?

Correct. Mocha AE is a standalone application, so it can only read what you give it as a file path.

The Mocha Pro plugin, however, does read the timeline.

You can manually set the frame rate in Mocha AE yourself, but as you’re changing the AE frame rate and then speeding it up in the timeline I can’t guarantee you’re going to get the right results.

I might need to experiment with your project setup to fully understand the workflow.

1 Like

I think you responded this to the wrong person.


Carlos Anon

1 Like

thnx Carlos. I think I am not very familiar with this forumtool at the moment. But I will work on it… :slight_smile:

Hey Martin!

If you want we can go together throught our whole (little) process. So maybe it is a bug in Mocha AE and you get an value input for your development team.

If you are interested I will write our process down…

best regards

Hi Nico,

If you can send the project to me I can take a look. We can update the forum for everyone’s benefit once we resolve the problem: martinb[at]

Hi there I think you’ve messaged the person again.


Carlos Anon

Hi there!

My problem is that After Effects is not reading the Mocha shape ae file. I open the Ater Effectt project and track in Mocha without a problem. I export the shape data and try importing the file in After effects and I get an error message of the file not supported by program. I tried copying to clipboard but that didn’t work either.

I believe it is the extension type that AE doesn’t recognize. What is the fix for this?


Hi Maria. Can you make sure you are exporting the “export ae masks” option and that you have the Mocha Shape Importer installed properly? It sounds like an error in process, we have tested this on our end and it is working as normal. You will also need to make sure you are using a recent version of After Effects.

Let me know and I will be happy to help you.


I have all up-to-date installs for adobe products. I wouldn’t know if Mocha Shape importer is installed properly as it came bundled with After effects and didn’t require additional downloads.I use the export option “Export shape data” and I’ve tried copy to clipboard and save to a file but when I try opening the file in After Effects is when I get the error message.

When I try to import the file into After Effects and the window opens to choose a file there are no files that are being recognized as “acceptable files”. When I choose all files I can find the saved “shape file” from Mocha ae but I get the error message when I try opening it.

I’ve included screenshots to show my process. I did delete all the Adobe products and reinstalled them in case there was a corrupt file in the importer that caused it not to work properly. It didn’t solve the problem.


You need to copy the shape data only, just copy it to the clipboard, and then paste it into After Effects on your layer. You do not need to open the .mocha file, AE can’t read that. Please see our documentation.