Insert Module not working

Hi,

I am quite new to Mocha. I am trying to get the insert module to work. I can get a track no problem. Then I draw a mask for the insert I want to add, link it to the track layer… but I can’t figure out how to get it to work past this point.

I’ve watched many tutorials and in all of them the planar surface is set for the track layer, but never for the mask layer. However, for me the mask layer surface perspective is not linking to the track surface layer–the planar surface grid for the mask layer does not change at all.

Also the surface layer on the mask seems to be acting like the mask: the inserted layer is ignoring the mask I drew and instead using the surface rectangle shape.

I have had success in After Effects before by exporting the tracking and shape data, but now I am trying to go directly to Premiere using the insert module and I can’t get it to work at all.

What am I missing? I’ve watched so many tutorials and following the steps it still doesn’t work.

Thanks

Can you sent me a screenshot of the entire interface? You can blur the image in the screen.



Here I used a different shot so I don’t have to blur, but the problem is the same.

You can see the track is good, but the surface of the track is not applying to the insert and the mask shape is not applying either.

Thanks!

You have to drag the corners of the surface to the edges of the screen and they should work fine. Do that in the insert or the track tab.

The problem is, if I change the mask shape, make it smaller or irregular, the insert does not change with it, it is tied to the surface. In the attached image the visible surface is the one attached to the mask with the corners dragged out as you suggested.

In your tutorials I have only ever seen you apply a surface once (to the initial track) are you saying I also have to set the surface to the mask layer as well?

Yeah, definitely don’t mess with the shape. The surface tool is what you want to move. You can movie it anywhere at any time. The “track” is just math, the surface tool moves along with that math no matter where you put it.

Sorry, but I do want to change the mask shape. In the above for example, let’s say I want to insert into the upper left corner of the computer screen, wouldn’t I change the mask shape?

The surface tool is always rectangular. If I want a non-rectangular mask, how would I do it?

And can you please clarify that you are saying I should set the surface for the track layer and then again for the mask layer? (None of the tutorials do this-in the one where you change the tv screen in the bar I did not see you touch the surface tool when working on the mask)

Irregular shaped mask for example.

You can delete all the keys for the mask and it will still move along with the track too.

And you can set them to the corners of the screen same as the surface.

I think either we are talking past each other or I misunderstand your problem. Once you link a layer to the other layer, the track is the exact same. It doesn’t matter where you put your surface or shape, it will still follow that data. If the linked track data is accurate and your shape is accurate to the place you need it initially, then it should move along with the object you want it to.

The shape and the track are separate things. The shape is where the track is looking, the track is what the track is doing, and the surface tool is a “translator” for the math that is the tracking data. The shape and surface are both children of the track. The shape CAN BE keyframed into a matte, but it won’t affect the track.

I understand the principles. What I can’t figure out is how to get the insert to work. I am trying to insert something into the mask I create that is tracked to and shares the same surface as the track layer.

Yes I can get the mask to link to the track layer and track with it.

But it does not link up to the surface layer of the track.

And the insert is not paying any attention to what kind of mask shape I set.

Does that make sense? Am I not explaining the problem correctly?

Thanks.

I figured out one thing - I needed to specify which matte to use.

But I remain confused about the surface. Do I need to adjust the surface for the matte as well as the track layer? In your tutorials I have not seen you do this. It looks like the matte somehow links to the track layers surface, but I have not been able to do this.

If there’s track data on the layer, the matte moves with that tracking data.

Yes, I understand, and yes that works, the matte moves with the tracking data, that is not the problem.

I am talking about the planar surface and the planar grid.

When I create a matte it comes with a new planar surface. When I link the matte layer to the tracking layer the planar surface does not link. When I look at the planar grid, the insert for the matte layer has a different planar grid than the tracking layer.

In your tutorials when you add an insert I have not seen you need to adjust the planar surface for the matte layer, somehow yours links up to the planar surface of the tracking layer.

I need help getting the planar surfaces to work for the insert.

Would it be possible to describe the steps after I have created my tracking layer?

Thanks.

OK, yes.

  1. Track your original layer (this is complete I gather).
  2. Make a new layer by drawing a shape where you want it.
  3. Grab the surface tool on this new layer and position it where you want it.
  4. Go to Layer Properties “Link to Track.”
  5. Select the previously tracked layer in the dropdown menu.
  6. Your new layer should now move very nicely along with your tracking layer, since it is now pulling the tracking math from that layer.

That’s it, that’s all you have to do.

If you are using PowerMesh link to track won’t work, which is the only thing I can think of that would mean you couldn’t link one layer to another.

Cheers,
Mary

Ok. We are getting closer. Following your instructions everything now looks correct in Mocha Pro.

However, when I save out to Premiere Pro it’s still not there.

My plate is on v2, my insert is on v1. I can see the insert, but the tracking is not applying to it, so I see the wrong part and it’s just like I am looking through a mask to a static layer below. In Mocha Pro the insert is tracking.

Is there a step I need to take in Mocha before going back to Premiere to apply the track to the insert on v1?

I was confused earlier because I did not know you had to draw a second planar surface for the matte.

Thanks.

The second planar surface is not the matte, it’s the new plant surface for the new layer.

What happens if you select your insert layer in Mocha Pro, click “render” forwards for one frame, save and close and then use the plugin interface render options to render to the AE timeline.

And make sure your insert layer is underneath your clip. If it’s on top of course it will also render in Premiere on top of your Mocha plugin render.

I tried rendering the insert layer in Mocha Pro, and checking the render box in Premiere, and rendering in Premiere. Nothing changes.

The insert looks good in Mocha, but the insert on v1 underneath the clip as you said is not tracking in Premiere. It just looks like a mask through to the bottom layer with none of the tracking applied.

I’m going to tag @martinb then, this sounds like a bug and it might be related to some rendering issues we’ve been seeing.

Thanks! Please let me know if there is an update. And thanks for going through this with me.

Turn off “Apply Matte” if you’re rendering the composite inside Premiere, otherwise it will cut out the render. You only need Apply Mate if you’re planning to composite something over a track below the current one.