Invert Mask Issue


#1

I have a project (using Mocha in AE) similar to replacing a screen, where the hand sometimes passes in front of it. Actually 3 things pass in front of the screen.

For the first object that passes in front of the screen, I tracked it and used that as a matte to put on top and all’s fine.

For the other 2 objects, I tracked them both in a separate layer.
When I try to set them as matte’s in AE for some reason I can’t uncheck Invert Mask. So I am left with blacked out sections instead of foreground objects overlaying the screen.

I can’t figure out what is happening as it seems all variables are the same between the 2 instances.

Any idea why Invert Mask can’t be unchecked?

Thanks.


#2

You should be able to put the two objects passing over the top in a separate layer above, that might be easier. I am not sure why you would not be able to uncheck invert, that sounds like a bug. Can you try using the Mocha effect (copy and paste) on a layer above the screen layer and see if that works for you? It might be that you are trying to do too many things on one layer.

Cheers,
Mary