"Invert Z" option in BCC Fast Lens Blur stopped working

Hello, I just made an account to get help with this very puzzling issue, sorry about the lenght but I’ll try to keep it as concise as possible:

My old 1TB HDD C: drive died so I exchanged it for an EVO 870 2TB SSD and formatted it with windows 10 (same OS that I was running before HDD died) , after reinstalling After Effects and all plugins I had, I opened a project I had backed up on an external drive that I’ve been working on for a very long time now and everything looked as it did before, that is until I reached one of the many scenes where i used the effect “BCC Fast Lens Blur”.

The blur was in all the wrong parts of the scene because the “invert Z” option no longer did anything, every other BCC effect works flawlessly as I tried them individually on a layer with no other effects but no matter what I tried I couldn’t get it to work, on a side note when I select “view focus map” or “view z map” the preview DOES change the black to white and vice versa, but when I go back to seeing the actual scene it still doesn’t.

What I tried:

  • making a new aep and trying the effect there with nothing else.

  • deleting all BorisFX and Adobe files from ProgramFiles, ProgramFiles(x86), ProgramData and Temp after unninstalling both, and restarting the PC before a fresh install of them with no other plugins (exact same versions I had before formatting).

  • enabling and disabling my GPU in AE preview settings.

  • disabling OpenCL setting in BCC options.

  • trying different BCC versions (10, 11, 12, 13, 13.5).

  • moving Boris plugin from common to my Ae version’s folder.

  • reinstalling nvidia drivers and updating to latest.

Sadly none of these worked, I know I could change the effect manually 1 by 1 and edit the depth maps to achieve the desired result but the project is much too large and it would also ruin all the lumma matte effects and animations I did using said depth maps…

My specs:

  • Intel i7 3820
  • gtx 980
  • 32gb DDR3 RAM, G.Skill 8GBx4 DDR3-1600 CL10 RipjawsX 1600 MHz
  • EVO 870 2TB SSD
  • Asus ROG Rampage IV Formula
  • bwg750m PSU
  • After Effects CC14 (can’t update at the moment because some plugins I’m using for this project are not compatible with newer versions)
  • Continuum version 13.5 (2020.5)

Thank you in advance and apologies if this isn’t how one properly structures a post of this kind.


Thanks for reaching out about this. I have tried to reproduce the issue as described but the filter seems to be operating as expected on my systems. That said, I’m using the latest version of Continuum so there may have been an issue which has subsequently been fixed.

If you have a simple AE project where you’re reproducing the problem can you please send that to me along with screen shots showing the failure and I’ll see if I can reproduce with your project.

I’ll also roll back to the version that you’re using to see if that helps in reproducing the issue.

And here’s something for you to try - switch the Blur type between Faster and Smoother to see if that makes a difference.


Hi, thanks for helping out.

Here’s a video of me showing the problem I have: Z depth issue

Also the AE project in the video above I made now where the issue still persists:
Z depth issue.7z (564.3 KB)

Inside the file there is the aep and an image I used as an example.

These are the following versions of the BCC I reinstalled when trying to solve the issue, my After effects version, nvidia driver version and Windows version:
bcc version
Ae version
nvidia driver
windows version


I’m so sorry for wasting your time but I seem to have found a solution by trying out things while waiting for your kind reply.

The solution was to rollback my nvidia drivers…
I had the version: 531.41 (03/23/2023) when the glitch was suddenly occuring after a system format, so I rolled back to an older driver which was version: 516.94 (08/09/2022) to give it a shot and as you can see it seemed to have fixed my problem: https://i.gyazo.com/0a83d48500e3cc5b64343b7c000773d7.mp4

I’m grateful for your support and I hope this helps anyone still fiddling with such old software nowadays. If you somehow find a way to make it work on the latest nvidia driver by all means do let me know but you don’t have to I’ll just have to stick to this older one, or hope the next driver doesn’t have this issue.

Many thanks!

Edit: New beta nvidia driver from april released today also works fine!

HI James,

Wow - so it was a bug in the nvidea driver after all, which explains why you were seeing this while I couldn’t reproduce the error. Well that’s good to know and as you mentioned, your post may assist others who have encountered similar issues so thanks so much for letting us know about this.

Goad it’s working for you now!


Hi, I had a play with this earlier, more of a learning process for me,
AE with a UHD MP4 AVC & a B/W image as the Z Layer on the track below,
I could adjust the controls but after a while the Invert Z option did stop responding,
I got the same as - select “view focus map” or “view z map” the preview DOES change the black to white and vice versa
I tried 8-10 times with different Z Layer images & lost the Z Invert 4 or 5 times after fiddling withe controls for a few minutes,
starting a new project reset the functions,
I couldn’t find a way to replicate it enough to share, :man_shrugging:
RTX 3090 SUPRIM with the Nvidia 431.61 Studio driver.

Just sharing :+1:

Latest Continuum &

1 Like