Issue Extending framerange on SFX shapes imported to Nuke

I’m not sure what changed but there is a big problem extending SFX shapes I’ve imported into Nuke & Nukex. It’s happened multiple times in diff environments (mac/windows) and projects using sfx 2020 and latest 2021 sfx. I’ll track & roto my shapes in sfx bring them into Nuke- shot was extended so I’ll need to extend my shapes 10 frames. When I add any key frames to my shape in Nuke the interpolation is messed up as well as the mo blur. It’s unusable. Any ideas?? Anyone else have this happen?
I’m curious what is the issue all of a sudden?!

Welcome @instonefx The last frame of the shape is extrapolated so that the motion continues in the same direction. This is ensures that motion blur works correctly on the last frame. If you don’t want this behavior, you can change the interpolation of the last keyframe.

Hi @marco Thanks for the reply! I went ahead and tried different interpolations on the (original) last frame but all key frames after that are still out of whack. To clarify I had originally exported a tracked shape from frames 1001-1064 into NUKE. The shot was then extended 10 frames (1001-1074) I updated my project settings in nuke to account for the new 10 frames at the tail. Once I add any keyframes (beyond the original frame range)to my shape- the keyframes interpolate weird and the motion blur do not line up at all.

I am not seeing the issue on my machine. Can you send me a Silhouette project, Nuke script and footage so I can test on my machine?

@instonefx I moved this issue to the support system.

1 Like

Im under NDA so cant send but when I get a moment Ill try to dig up a test shot but this is what the issue looks like- and its happened on several shots, these images are one frame apart - ie: original last frame and first new extended frame-- all following extended frames have the same issue:


There is a known issue where some shapes will warp and twist in Nuke. This happens when a shape with smooth interpolation has its first keyframe later than the session start frame and the layer has tracking data applied to it. If this is your issue, it can be solved by:

  1. Changing the interpolation of the the first keyframe in Nuke to Smooth
  2. Setting the keyframe interpolation for this shape in Silhouette to Linear.
  3. Adding a keyframe for this shape at the beginning of the sequence in Nuke.

Yes I have ran into that problem as well and adding a keyframe at the beg has worked for me- but mine is a separate issue: Adding keyframes in NUKE to a tracked sfx shape after the plates frame range has been extended from original fame range. Ive never had issues before and I’ve been doing this for decades- so something is amiss… Also- The sr. comper I sent my .nk splines to had the same issue on his end and was stumped as well.

@Marco I have the .nk roto node I can send you with my shapes that were exported from sfx. Is there an email I can use to send that over to you? You can apply it over any footage - or just look at the alpha and see the mo blur issue. The discrepency starts at frames 164-165—>to the end ( project set to x0-195)
thanks again
M

You can click my image thumbnail and select Message. Thanks!