Issue with Rendering Lens Flare in Fusion


#1

Latest version of Sapphire 11.02. Latest version of Fusion 9.0.2 and MacOS 10.13.4

I’ve been consistently having problems rendering comps with the Sapphire Lens Flare in it. The node will play down fine if I view it in the flow, but when I try to render it will cause the render to never complete and it is always hanging up at the Lens Flare node.

This behavior has been seen on multiple different comps, and the computer restarted, etc…


#2

Here is a comp if anyone wants to try.


#3

Try disabling GPU in Sapphire and see if that makes a difference. If not, please contact our support team.

Alan.


#4

Where do you disable the GPU? Looking at the node here in Fusion and I’m not seeing anything about GPU.

How do you contact the support team?


#5

Just checking in again.


#6

Click the “help” button for that effect and there should be a GPU enable/disable checkbox.

If you need to contact support use this page: https://borisfx.com/support/open-a-case/

Alan.


#7

Gotcha. Just tried that and still having the same issue.

It got about 12 frames in and then freezes on that node.

It should be noted that the frame it chooses to freeze on isn’t always the same.

I submitted a ticket to the support team.


#8

Our testing has shown that the problem only happens when your output format is dpx. We don’t really have a solution for you other than switch to another format – we’ve logged the issue and our dev team will take a look, but a fix probably won’t happen soon.

Alan.


#9

I’ve tried several different output formats including various Quicktime formats. It isn’t just DPX when it happens.

Currently I literally cannot render my comps with the Lens Flare node in the chain. Lens Flare is really the only thing I use from Sapphire so I hope I can get it to work or there isn’t much point in keeping it.


#10

Does it matter which lensflare preset you’re using? Try clicking the “Edit lens” button to bring up the flare designer, then click “new” to get an empty flare, then add a single “blob” element and close the flare designer by clicking “ok”. Does that very simple flare still kill your render?

Alan.


#11

Yeah it doesn’t matter which preset.

I’ve had this happen in several comps now, all with different presets and different customizations made to the flare.

It doesn’t “kill” the render so much as, it will just hang on a frame on the Lens Flare node and just freeze. It’s not always the same frame, and sometimes I can get it to render all the way through so I can pre-render it out to a file, but most times not.

Have always tried Open CL On and Off within Fusion, but same result.


#12

Our test team found out that Sapphire 10 lensflare works fine in Fusion, so as a temporary workaround you might want to try installing v10.

Alan.


#13

How do I download 10?

I only see 11 on the site


#14

https://borisfx.com/support/documentation/sapphire-v10-for-resolve-nuke-vegas-fusion-studio-scratch-and-other-ofx-products/


#15

In the “legacy” versions section.

https://borisfx.com/support/legacy-downloads/#sapphire