Latest mocha pro lagging when back to AE

Hi ever since version 8 (2021, I am on 8.0.3) I have been getting lags when going in and especially out of Mocha. doesn’t matter the footage. here’s an example:
https://drive.google.com/file/d/1JQ8qNOqcBznW1vmFF8ADaew1rkeZq2xG/view?usp=drivesdk

Hi @Roei_Tzoref,
On my Windows laptop, it is faster launching and much faster coming back to AE (compared to what you shared). What are the specs of your system?

1 Like

This feels like it could be related to something we were seeing with drivers. Let me confirm with @martinb

1 Like

@Roei_Tzoref Can you make a workspace in AE without all the third-party script panels showing, reboot AE and then load Mocha?

We’ve had reports that some plugin and script panels with their own custom buttons cause a significant lag in performance.

1 Like

thanks @martinb I tried that. same effect Ae 18.0.1
https://drive.google.com/file/d/14wTuqDywlB8fKXWtboy1zoAj5hZSEkVw/view?usp=drivesdk

@rosss this is a new workstation but I recall it happened on my latest workstation too ever since mocha 8.x if I recall correctly.

Intel(R) Core™ i9-10900K CPU @ 3.70GHz 3.70 GHz 128GBRAM RTX 3080 10GB VRAM

Hi @martinb is this issue being examined maybe? it happens also in fusion for me too. when you are out of the mocha UI it takes several seconds for it to stop loading and give you control back in the UI.

the computer specs are great. it all started from 2021 and no update has fixed that since.

here’s a recording in Ae when it’s really bad:
https://drive.google.com/file/d/1dvRFWgfpu9Tr0wu6r6sSUl_bzBct2AYB/view?usp=drivesdk
here’s in fusion:
https://drive.google.com/file/d/1vg_m2DqtWR32Vy_-TYKxLS80zIErlHur/view?usp=drivesdk

must be some protocol or something trying to communicate with the app. is there something I should try and do?

In these videos, it looks like Windows is not letting go of the mochaui process for a really long time.

When you close Mocha, was is the process doing in task manager? Can you still see the process and is it releasing memory?

1 Like

thank you. checking this and I see when I close the UI. it’s its removed from task manager as well.
https://drive.google.com/file/d/1mswPms6eWuJuGwzNzdrbAspmZhG6TWK9/view?usp=drivesdk

You could try reducing the plugin memory load:

  • Launch the Mocha UI
  • Open preferences
  • On the system page, set the memory usage to 50%
  • Restart the program

thank you, I tried it. no dice. it’s still lagging. I wonder what in my system makes this happen. at work it doesn’t happen (weaker computer) I have a strong workstation, if you want to test it out with me maybe others also complain, I am free for that. if I ever have see this gets resolved and why I will let you know. thanks

The only other thing I suggest trying is removing the other third-party scripts/plugins and see if only having Mocha in the system loads correctly.
Do you have Premiere? Have you tried loading Mocha via that to see if the same lag persists?

I see this happens in premiere as well. I will keep track on this, it’s not the worst thing that can happen. guess if others complain I will be in that group to help solve this.