Licensing Tool Exists with Error code 6, Qt errors

Hello,
Not sure what happened, but I had a registered version of Mocha running perfectly fine on CentOS 8 as standalone and OFX version. Tried to launch Mocha Pro today after a few months of not using it and the both versions don’t seem to recognize the license. When I try to launch the licensing tool, it exists with a little pop-up window saying licensing tool error code 6. I’m running the latest build Mocha Pro 2020.5. Below is the error I found in the log file, I found a reference to the same error on the forum but I can’t seem to find the solution. I know something is messed up with Qt but I don’t know how to fix it. I opened a case but my support ran out a couple of months ago so I’m not sure I’ll get a reply there.

Apr 07 13:08:07 (mochapro) [RepriseLicenseManager]: mochapro: No license for product (-1)
Apr 07 13:08:07 (mochapro) [RepriseLicenseManager]: mpp-multihost-so: Wrong host for license (-4)
Apr 07 13:08:07 (mochapro) Wrong host (-193): _check_rehost(): No rehostable root dir
Apr 07 13:08:07 (mochapro) [RepriseLicenseManager]: bfxsuite: No license for product (-1)
Apr 07 13:08:07 (mochapro) [RepriseLicenseManager]: License Error: 0

mochapro: No license for product (-1)


Apr 07 13:08:07 (mochapro)

mpp-multihost-so: Wrong host for license (-4)
Apr 07 13:08:07 (mochapro) Wrong host (-193): _check_rehost(): No rehostable root dir


Apr 07 13:08:07 (mochapro)

bfxsuite: No license for product (-1)


Apr 07 13:08:07 (mochapro)
Apr 07 13:08:07 (mochapro) Please visit our FAQ at http://link.imagineersystems.com/mochapro-troubleshooting-licensing for further information.
Apr 07 13:08:07 (mochapro) Invoking “/opt/isl/MochaPro2020.5/bin/bfx-license-tool/bfx-license-tool” --gui --productline Mocha --feature mpp-multihost-so,bfxsuite,-mocha- --version 20200413
Apr 07 13:08:08 (mochapro) LocalTool: exit code was 6
Apr 07 13:08:08 (mochapro) – Begin tool error output –
Apr 07 13:08:08 (mochapro) Error String: Process crashed
Apr 07 13:08:08 (mochapro) Std Error: qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.
Apr 07 13:08:08 (mochapro) This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.
Apr 07 13:08:08 (mochapro)
Apr 07 13:08:08 (mochapro) Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.
Apr 07 13:08:08 (mochapro) – End tool error output –
Apr 07 13:08:08 (mochapro) – tool output is empty –

What are your read/write permissions on the folder where the license is kept? Generally, we suggest licensing questions go to the support team, as licenses are fairly confidential information and this is a public forum. https://borisfx.com/support/open-a-case/

Thanks Mary, fair enough. I just wasn’t sure if the support team would be able to rely as I couldn’t renew my annual support in time this year. I just received a reply so I’ll continue the conversation with the support specialist and close this thread.

In case you haven’t heard back via the case, here’s how you can fix this.

This message:

Apr 07 13:08:07 (mochapro) Wrong host (-193): _check_rehost(): No rehostable root dir

is basically saying that the unique identifier for your machine, which is created in /usr/genarts/rlm when you activate your license, has disappeared.

To fix that, you’ll need to reactivate, but first you will need to reset your license via the account page on our website. Once you’ve done that, you need to overcome the problem running the license tool on your system.

Some support library required for the license tool to open its user interface is missing from your system, but you should be able to activate from the command line instead. Use the command:

/opt/isl/MochaPro2020.5/bin/bfx-license-tool/bfx-license-tool --productline Mocha --feature mpp-multihost-so,bfxsuite,-mocha- --version 20200413 --activate ACTIVATION_CODE

Replace ACTIVATION_CODE with your activation code which looks like 1234-5678-1234-5678.

Hope this helps,

J-P

Thanks, J-P. :slight_smile:

Thanks J-P. What I don’t understand is why the xcb Qt library is not loading event though I have it installed appropriately. Any ideas?

Just as expected, I heard back from support and they are not able to help as my support contract expired. So hoping someone here has an idea around what’s causing the graphical licensing tool not to load despite having libxcb installed

It’s down to a missing symbol in libfontconfig which the version of Qt embedded in the license tool is expecting. We are currently planning to fully support CentOS 8 in the next major version of Mocha Pro. For now, I suggest you use the command line activation/deactivation options, which should work.

Hello, we have a similar problem on Rocky Linux (CentOS8).

In our case, we purchased a copy of OFX Mocha Pro.

I installed both OFX and standalone version of Mocha Pro, then run the cli command @jps suggested. And it prints this error message.

ERROR: Activation failed: This license is for a different host product. Can not install it here.

I guess I got this because we have only OFX license, but did not know the exact reason.

I need some advice. Thanks! :slight_smile:

Hi Kybin,

The equivalent command for OFX (assuming Mocha Pro 2021) is:

/usr/OFX/Plugins/BorisFX/MochaPro2021/Resources/mochaui/bin/bfx-license-tool/bfx-license-tool --productline Mocha --feature mpp-ofx --version 20200930 --activate ACTIVATION_CODE

You will need to tweak the path to bfx-license-tool if you are running a different version.

Best regards,

J-P

@jps Thank you very much!

Acutally I was confused our MultiHost license with OFX.

I changed the command to --feature mpp-multihost and successfully registered it!

Thank you again. Cheers!