Manual track affecting previous surface keyframes


#1

Hi. I’ve followed the various tutorials and walkthroughs regarding Manual Track for object occlusion but I’m having some difficulties replicating what happens in the videos. As I reposition the surface in manual track, it then misaligns/adjusts the surface in previous correctly tracked portion. I do not have the Uber key active - just normal auto keyframe.

My steps are:

  1. Auto track backwards for the simple portion with the surface correctly aligned.
  2. Position the timeline where the object obscures the screen.
  3. Switch to manual track, add keyframe.
  4. Scrub forward to where I can next see the screen.
  5. Reposition surface to screen corners.
  6. Track the rest of the shot.

At this point, if I scrub backwards, the adjustment I made to the surface to correctly manually align it has adjusted the auto track previous to this point, and my surface is no longer correctly aligned for the first portion of the clip.

What am I doing wrong? This isn’t the behaviour shown in Mary’s quick tip with the guy walking in front of the TV screen.
Many thanks,
Terry


#2

This could be related to the surface going behind the mocha camera. If there happens to be large changes in perspective or rotation this can sometimes occur. I’ve had similar issues and it always seems to be related to the surface going behind the camera. If you have the planar grid on you can see as you track frame by frame when things get out of line. My more labor intensive approach is breaking up such a track into multiple tracks (splitting the tracks on that frame where things get wacky). Then, combining the multiple track keyframes in AE or whatever your compositing app is.

The thread below mentions using the dope sheet to adjust keyframes to remove the unwanted distortion to the surface track. But, I’ve never had much luck with that. But anyway, food for thought.

You can visit this thread for some ideas:


#3

Hi Chris, many thanks for the reply and the suggestions. I had already read your discussion with Mary before because it came up when I searched for solutions.

I don’t think that’s the problem though as there is very little perspective shift - nothing extreme. I’ve watched Mary’s quick tip video on manual tracking and my footage is almost identical situation as that. A screen track in centre of frame that someone walks in front of, obscuring it for around 10 frames.

In Mary’s videos, it looks very simple to switch to manual track and skip those 10 frames, then align the surface to drive the track, and then carry on. However, it just doesn’t work for me the way it does in Mary’s video.


#4

I’ve seen Mary’s video which exactly describes what I need to do:
https://www.imagineersystems.com/videos/quick-tip-manual-track/

My situation is exactly the same as this, but once I change to manual track and adjust the surface, it misaligns the surface in the first portion of the track. It’s like it doesn’t properly set an initial keyframe?


#5

Hi Terry,

Sorry for the late reply, I was out of the office. OK, you probably just need to make a manual keyframe on that frame. Simply go to the righthand side of your timeline and find the key buttons, there will be an add keyframe button (+key icon) and you can just add the manual track at the place where it is properly aligned. Then make your new keyframe as normal, you should animate between the two. If you don’t then this is probably the surface and camera issue.

Please let me know if that helps!

Cheers,
Mary


#6

Hi Mary,
Really sorry, but this still isn’t working for me I’m afraid. I’ve made a very simple 5s test clip in AE of a white square moving in perspective.

  1. I track the first 10 frames, all good.
  2. Switch to manual track. Move a frame forward, press +key and adjust the surface.
  3. I then move 15 frames forward in the timeline (still in Manual Track mode).
  4. I adjust the surface to the correct position. Press +key (I’ve tried clicking +key before & after, neither make a difference)
  5. I then scrub back, and the surface is out of alignment at the start.

Mocha definitely isn’t registering the keyframes for manual track for some reason. Looking at the dope sheet, when I click +key as you suggested, it actually creates a keyframe for the spline control points, not the track parameters.

Also, as I’ve seen in your videos, when you adjust the surface in manual track mode, the X splines adjust accordingly. But when I do it, the X spline stays where it is, implying the track isn’t being adjusted. It definitely looks like Mocha doesn’t register the changes to the surface and insert a track keyframe when necessary, and the +key adds one to the spline shape rather than the track.

Do you have any idea what I’m doing wrong? I’m convinced I’m doing exactly the same thing as in your quick tip video.

 


#7

Hi Terry,

I would have to see it. Email me with the best number to reach you at.

Cheers,
Mary


#8


#9

Thanks, I am glad this got sorted. The keyframe can be made manually as a workaround.


#10

Thanks for helping me with this Mary, but I’m afraid I’m still not having much success!

I’ve just been repeating that same test over and over again, and I can’t get it to consistently work I’m afraid. Moving a surface point or edge only registers as an adjustment to the track around 1 in 4 times. Most of the time, as I reposition the surface, the X spline does not adjust/move accordingly. The adjustments on the manual key frame just don’t ‘stick’.

I’ve cleared my cache, I’ve tried both Pro and Plus on two separate computers. I’ve done that test around 10 times on each installation and I haven’t had a successful solid lock like I’ve seen in your tutorials once yet unfortunately.

You saw how it slipped that first time you tried it. Can you think of any other reason what might be causing it and how I can work around it, as adding a manual keyframe isn’t working - it seems extremely fragile!


#11

I did see how it slipped the first time I tried it, but deleting the keyframe and making a new one seemed to consistently fix it. If that workaround isn’t working for you, that’s a bug I can send to my dev team. But in general, the deleting the manual keyframe and keying the new one with the +key icon seemed to fix it consistently on your shot.


#12

Sorry Mary, but deleting the keyframe and adding a new one doesn’t fix it - it just isn’t working manually. It still slips every time and I can’t get the changes to the surface to drive the track. I haven’t been able to replicate it working again - there’s definitely something very strange happening!

I’ve redone that exact same test repeatedly, and I haven’t got it to work again since. I really quite desperately need to use manual tracking for a whole series of shots and at the moment, I just can’t get the feature to work.

Do you have any other suggestions or anything else I can try?


#13

Yes, try a thorough uninstall and reinstall. Because I am testing it on my end and not getting those same results.

Try this…

  • Uninstall your mocha software.
  • Find any Preferences (or .plist) files:
    • On pre-mavericks MAC this will be under /Users/*YOURUSERNAME*/Library/Preferences/
    • On Windows, open the command prompt as an administrator, type regedit in the window, and hit enter. Navigate to HKEY_CURRENT_USER/Software/Imagineer Systems Ltd/mocha
    • On Linux, simply navigate to ~/.config/Imagineer Systems Ltd/mocha Pro 4.conf
  • Delete your preferences files:
    • On pre-mavericks MAC Delete the files that begin with com.imagineersystems.mocha
    • On Windows, Delete the contents of any folder in HKEY_CURRENT_USER/Software/Imagineer Systems Ltd/mocha
    • On Linux, delete only the mocha Pro 4.conf file
  • Re-install the software from scratch by downloading a new mocha installer off of our downloads section.
 
  • If you are on Mavericks, you will need to try something else to delete your preferences because you will not be able to access and delete your .plist files the way you can on older systems. You may try one of the following techniques:
    • Use friendly solution:
      • Quit the app, and make sure it is not set to run at login.
      • Delete the app’s prefs file (typically in ~/Library/Preferences/Imagineer Systems Ltd/mocha.
      • Logout.
      • Login.
      • Launch the app. Follow mocha’s instructions to reset preferences.
    • Preferred solution:
      • Quit the app.
      • Open Terminal, paste the following, and press Return:
        defaults delete com.imagineersystems.*.plist
      • Launch the app. Follow mocha’s instructions to reset preferences.

#14

OK, I’ll try that Mary. I have two computers (one is a hire machine so had a fresh install just last week) and I’m experiencing the same thing on both, which would seem to make it unlikely to be a preferences issue, but it’s definitely worth a try. I’ll give it a go and let you know. Many thanks.


#15

If it doesn’t work, it is probably just being frustratingly fussy and may take a few attempts to get right with the deleting that keyframe and adding it back. And if that’s the issue, I can work with the team on improving that functionality.


#16

Success! Sort of, but big progress nonetheless! Before resetting my preferences I thought I’d try one last thing.

I’ve been using Pro and Plus version 4.1.3. I’ve just tried reverting back to the bundled Adobe Mocha AE and manual track works perfectly! Exactly how it should, rock solid every time - just like in your quick tip video.

I noticed that Mocha AE CC is version 4.0.1 (I’m still using CC 2014 as I don’t like CC 2015!).
So I downloaded Mocha Pro version 4.0.1 from your legacy download page. And that works too!

I don’t know if it’s a bug in 4.1.3 Pro and Plus, or if it’s only being caused by something specific to my machines (El Cap?), but rolling back to 4.0.1 definitely fixes the issue.
For now, I’ll just use AE CC as I only need the track module. Once my current project has finished I’ll test the matter further and see if I can get it working in 4.1.3.

Many thanks for your help Mary - really appreciate your patience.


#17

Sorry, forgot to say - in 4.0.1, there’s no need to delete or manually add keyframes as a workaround, it automatically keyframes exactly like we expected. I’m very relieved :slight_smile:

 


#18

Actually, that’s very helpful. If that’s a regression I am letting our dev team know right away. :slight_smile:


#19

Great, hope it helps! Just so you know, from memory, I think I’ve experienced a very similar problem with adjust track module too - the key frames have never seemed to ‘stick’ when I’ve used it, in much the same way. I’ll double check with this previous version and see if it’s any different to how I remember.


#20

Hi Terry,

Can you please record a video of your process in 4.1.3 and send it to me here: martinb[at]imagineersystems.com

I’m curious as I cannot replicate your results and want to match them precisely.

Cheers,