Manual track affecting previous surface keyframes


#21

Yep, no problem Martin, will do.

I worked on 15 shots over the weekend that all required manual tracking, and they all worked perfectly in 4.0.1

I worked my way backwards installing each of the legacy builds on your download page and 4.0.1 build 9018 was the first one that behaved how I’ve seen it in Mary’s videos. All of the higher versions would not record a keyframe when adjusting the surface in manual mode and the track would slip.

I’m sure it’s just something I’m doing wrong as I can’t understand how no-one else has had the problem, but seeing as I’m doing exactly the same process in 4.0.1 and 4.1.3 and getting different results with each, it seems very confusing!

I’ll try and get the video sorted today or tomorrow, cheers


#22

Hi Martin, I emailed you the video of my process. Let me know if you didn’t get the link or if you have any questions. Cheers!


#23

No worries Terry, i’ve replied to your email. To keep the thread updated, it may be to do with using a Wacom tablet… stay tuned.


#24

Hi. Sorry to resurrect an old thread, but this problem still appears to not be fixed. I think we established it is something to do with using a Wacom tablet, but seeing as it works correctly in 4.0.1 but not on any release later, it would appear to be an issue with Mocha rather than Wacom.

I’ve just checked it with v5.0.0 build 12092 and I’m experiencing the same issue with manual track, ie. it isn’t fixed yet.

Unfortunately with the type of shots I work on, the tracking surface is often fully obscured by a foreground object so manual track is essential to fill in the gaps, which makes Mocha fairly unusable. Do you have any idea when this might be fixed?

Many thanks.


#25

Hi there,

I kkow it’s a long post but I really want to help, check out why :

Just wanted to tell you I’ve been facing that problem very often these times, and I had given up my search for a solution because I didn’t find anyone having the same trouble (then no solution to a problem that no one sees), and I thought it was me… Looked for tips for hours (great videos btw), but everything works better in videos than in my projects, of course :wink:

Anyway, I think this is the only problem I couldn’t fix easily inside Mocha Pro. It’s sometimes a real pain because I like Mocha Pro so much, and therefore want to fix problems inside it instead of keyframing the problem path in another piece of software.

So at this point, I can add my experience to Terry’s one : switching to Manual track (with “A” on, which was also on before, and not “Ü”, just for you to know) to keyframe even tiny parts of a clip - where the surface has slipped out even if the spline is right - breaks previous automatic keyframes where the surface was ok

I don’t remember what my workaround was when I randomly succeeded in fixing this, but I think it was by deleting all keyframes > making manual keyframes on the problematic part FIRST > then make auto tracking - before and after this part - AFTER this problem path was solved. I think I remember the problem didn’t occurred when I performed auto tracking to easy parts after manual keyframes had been set up.

Then to summarize for me :

  • auto track > manually keyframing surface only where it slips = surface out of the manual keyframes range also moves (looks a bit like Uberkey is on btw, but I repeat it was not)
  • stating a spline at the first problematic frame (1pf) > tracking forward to the last problem frame (lpf) > manual keyframe the surface > auto track backwards from 1pf and onwards from lpf to the end = it may make it because auto track don't affect the previously manually keyframed surface
To be checked... Hope it can help...

 


#26

Thanks for the update, can you let us know what version of mocha Pro you are using? We want to make sure you’re on the latest version. And this will help us track down the issue if it is a bug!


#27

Hi Mary, thanks for your reply. Yes, I’m on Mocha Pro 5.0.1 build 12206, but the same bug has been present in every build since 4.0.1 (I’ve downloaded and tested each one in your legacy download section). I still use 4.0.1 when I need to do any manual tracking!

I’ve tested it on three different Macs, using three different Wacom tablets with various drivers. Build 4.0.1 works perfectly for manual tracking with a Wacom tablet, but anything after that doesn’t. I recorded a screen capture of the bug happening for Martin B - let me know if you would like me to send the link again.

Let me know if there’s anything else you need to know from me - be really great to get this fixed! :slight_smile:


#28

Hi Factory Sam - thanks so much for your reply. I’m so happy someone else has had the same problem - I thought it was just me! :wink:


#29

OK, I have let the our product manager know. Thank you!


#30

Hi all,

While this bug is flagged, it has not yet been addressed.

At present the main workaround is still to use the mouse for surface adjustments, rather than the tablet. Other operations such as roto should not be affected by the tablet.


#31

Hey,

Whaou, replies come quickly here, sorry about the delay of this answer… So :

@Mary : today as yesterday, I’m not in front of Mocha, but I can say I’m on Mac and I think it is Mocha Pro 4.1.2 (if it exists, anyway 4.x.2). In a few hours, I’ll reproduce it and report here every tiny things which may be interesting to know;

@Terry : " I’m so happy someone else has had the same problem – I thought it was just me!" Yep hahaha, that’s what I wrote above, it’s always good not to feel left alone :wink: And I repeat : this is almost the only problem I have with Mocha, this is the reason why I’m happy to be involved in the potential fix of it.

@martinb : ok, thx for your reply here. But actually, I don’t use tablets anyway. Read below for more explanations…

I have 2 big projects which include a lot of “insert” stuff, a kind of humor serial clips in which a young magician turns the contents of ad panels aside the road into what he feels more comfortable with :wink: So you understand that a lot of tracking must be made, and it’s not a problem with Mocha.
So I track everything and export the tracking data to (most of the time) Apple Motion, because the workflow is good for I can insert a drop zone there (and then easily propose different replacement content afterwards).

When a pole happens to occur between the cam and the ad, I track it before, put this track on top, the track the ad panel and everything is ok; but of course, when passing behind the pole, the surface sometimes needs tiny adjustment modifications : this when the problem may come, because doing it well with manual keyframes affects the surface in the beginning of the clip, where everything was right with auto track…

More info after reproducing it tomorrow

 


#32

Hey Martin :slight_smile: So does that mean you’re looking at fixing it? Or is going to be like the Avid DNxHD problem where users are just advised to work around it?
I don’t even have a mouse!

@FactorySam - I can confirm that for me, I only get the issue when using a Wacom tablet on recent versions of Mocha. Here’s the video I made of the problem, comparing version 4.1.2 with 4.0.1:

password: manualtrack


#33

Hi again,

I decided to rush up a few minutes to my Mocha Pro spot, just to be sure : so here I am in front of it, and I confirm version 4.1.2.
In the meantime, I see Terry’s video and yes, I recognize the trouble. In my experience (but the conclusion is the same), I realized there was a problem when :
1/ the exported track showed problems only after I manually adjusted a part;
2/ I saw after a test that the xspline shape was connected to the surface during auto track mode, not anymore when manual track;
3/ [and that’s the main reason, I couldn’t believe my eyes] I tried several times and noticed that, when my manual adjustment was made and I put the playhead where auto track was involved (and gave very good results), the surface was not ok anymore as it was before I switch to manual track.
This cannot be seen on your video because you’re focused on the connection between xspline and rectangle, but if I went back in the few seconds before, i.e. where you tracked your rectangle in the beginning of the clip, the rectangle was then off although it was ok before you manually tracked anything.


#34

I am having the exact same issue in version 5.5.1 (13127), so I presume this has not been fixed. I am using mocha on a Mac Pro on macOS Sierra. What’s weird is that I am not using a tablet, but a mouse. Still I am seeing the problem just as it was demonstrated by @TerryS in the video.


#35

Has there been a fix for this yet? I’m in Mocha Pro 5.5.2, and I’m having the the same issues with manual track. I’ve tried manually adding keyframes and all kinds of work arounds. But so far I’m just using it to get me about 70% there, then I’m manually tracking in After effects using Mocha Import and CC powerpin.


#36

This fix is in beta and coming soon!


#37

Is there a better way to manual track? I’ve got some tough tracking ahead of me.


#38

No, but if you join the beta you should get the fix and you can give us feedback. To join the Mocha v5.6 beta, please go to the following link:

https://www.surveymonkey.com/r/mochav560prerelease


#39

Thanks!
just signed up.


#40

I guess this bug fix is already in beta. But I just found the manual track error happens if have to undo.
Once I’ve had to undo it seems to breaks until I restart the software.