Manual Track makes the planer surface go wonkers

Hi! I’m tracking a phone that get’s a bit too much motion blur so in the end I’m trying to do some manual tracking, nothing advanced at all but the manual track makes everything go wild!
Here is a video showing it: Mocha Manual tracking problem - YouTube
I have tried this in both Mocha AE 6.1.3 and in Mocha Pro 7.0.2
Is there anything I’m missing in what I’m doing in the video?

After some more tests it seems to happen mostly when I don’t use a big tracking-field. As seen on the image I’m tracking only the trackin markers on the phone and some other dots on the phone and the manual track don’t work as expected. The AdjustTrack do work as expected tho.
I later now did a track with a big tracking field and the manual track now did work as inteded, so it seems to be something to do with smaller tracking areas.

If you tilt the surface too far in perspective it can break the virtual camera plane in mocha, when the surface goes behind the camera the track flips in on itself and the math gets thrown way out of line. That’s probably what is happening here.

Making sure not to tilt the surface too much can stop that, which is probably why the larger surface helps.

Do you mean tilt with the planer tracker or tilt with the manual track?
I just tried to move the center point so all 4 corners moves at the same time and I get the same result as seen here:

Yeah, that behavior looks like it’s breaking the plane, which is weird because it doesn’t look that tilted to me. But let me tag @martinb in because this looks like a bug that needs to be addressed.

Doing some roto today again, tracking another phone, nothing special and needed to do some manual tracking and everything goes wonkers again, exactly like in the video above. I have tracked and done some adjustments using the AdjustTrack.
I can send footage and project files if needed. This bug makes my tracks useless as I can’t finish them.

EDIT: After some tests it seems to be something to do with the AdjustTrack and ManualTrack that doesn’t go hand in hand. If I go to AdjustTrack and reset everything I can then do my manual track.
The problem here now for me is that my track have drifted before the manual part so to be able to continue my track I have to adjust it at some parts.

The current “solution” for now is to track and adjust. When done, reset the adjust track, do the manual track and then re-do the adjust track… Not ideal at all but at least all my work isn’t for nothing.

With adjust track, you have to make sure the surface is set before you jump over to the adjust track tab, and you have to set your master keyframes on the frame where they line up. As long as you put keyframes on all four corners as you go and make sure the dashed lines don’t turn red, it should work decently well.

Manual track you have to be super careful with, as you have to set a keyframe before you start animating the manual track, otherwise the results can be offset heavily.

Without seeing the project, I am unsure if this is a bug or maybe a workflow problem.

Can you tell me more?


Make a video showing exactly how I arrive to the bug: Mocha - Manual Track makes the planer surface go wonkers - YouTube
There is also a bonus-bug for you at 4:40 where there are some data left even after deleting keyframes.
I’m more than happy to send over my footage and project files and be to any help as this bug is a big one for me.


In adjust track, you need to be on the frame you’re going to use as your reference frame or it makes keyframes for you on that frame. So that’s where those keyframes were coming from. You can delete them in the dope sheet or you can reset the adjust track by hitting reset in the bottom left boxes.

With manual track, you have to go to your last good keyframe before the jump and adjust the manual keyframe to “set” it. Even though it’s “set” in the timeline, it’s fussy. It needs you to adjust the key before your jump. I agree this needs to be fixed, but the workaround is to set the key on the last good tracking frame before you jump ahead. Of you will get this offset.

Also, adjust track should be done when you’re completely finished with the track, manual or otherwise. The tabs in mocha work from left to right. So track, then adjust track, then exit modules like remove or insert.

In the meantime, we do have an overhaul of this workflow on our agenda. And I will tag @martinb so he can see your video too.