Mask Remains Static in AE

I’ve tracked an object in Mocha AE, copied and pasted the mask into my AE project, but the mask doesn’t move wit the object; it just stays still! I’ve tried opening a new project and starting completely over, I’ve tried different clips, but nothing I do makes the mask paste and move properly. What on earth is going on and, more importantly, how do I fix it?

Hi there,

You’re pasting in your keyframes off the timeline. You can find them in the layer you pasted them on if you move the layer around. I see you already have a support case though, so I will let this get sorted there with Jon, but I will paste a solution here in case anyone else runs into the issue too.

Look on the whole length of your clip and see if it’s pasting outside your comp range. A workaround for this is paste shapes on a solid of the same size as the footage you tracked in mocha and use that as a track matte to troubleshoot shape issues, that way you can slide the keys into place when they paste so far offscreen.

The reason you are encountering this is because the mocha standalone products like mocha AE are actually reading the full clip instead of the AE project. If you want seamless integration, try using the mocha Pro Plug-In, and trimming the comp to the work area, that will completely eliminate any copy and pasting errors as it reads from and renders to your timeline, and can even calculate motion blur with roto, it also has several other useful modules mocha AE doesn’t have, like remove and insert.

A workaround you can try in AE is trimming the frame range inside of mocha and seeing if that fixes your issue, but you still must make sure your frame rate and aspect ratio match.


Thanks for the response. Unfortunately, I’ve tried trimming the comp before tracking in Mocha, and I’ve even simply trimmed the video clip so that there were no extra frames when I imported to Mocha; the mask just stays completely still!

As for the support case, I have heard nothing back yet, and this site doesn’t have live chat support, so I’m doubtful my case will be resolved through “official support” means. As this is a time-sensitive project I’m working on, I can’t wait around for weeks (I know I only started the case yesterday, but I struggled with the problem for a week before contacting this site)

So when you say trimming your comp, have you tried the setting in AE “trim comp to work area,” instead of just making the frames in the comp shorter? The issue is that the layer mocha sources is the full clip, so if it’s hugely longer than the comp your keyframes are going to be way offscreen.

Did you try the test with the solid, pasting on a solid and sliding it left until you find your keyframes? They’re almost certainly there.

You say you tried trimming the video clip down to just the length of the comp and the data is still staying still, can you find the keyframes anywhere? What does the data look like in your comp other than “staying still,” as in, what do your keyframes look like? Does the spline line up on the object you have rotoscoped at all or is that off too? Alternately, if you just need to get the shot done and can’t troubleshoot this minute, try a two week free trial of the mocha Pro AE plugin and you can apply the shapes directly on the timeline.

If you need immediate, time sensitive support, contact our support team 1-888-77-BORIS between 9am – 6pm Eastern Standard Time (M-F). We do our best to respond to phone messages and email within 24 hours on business days. For written cases (and forums) we usually respond within one or two business days. But it’s usually much sooner than that.