Max duration of 300 frames in PI when launched from Optics

For some reason I can only get a max duration of 300 frames when I lave launched Particle Illusion from Optics. This is even though I have set it to 100 frames in Optics.

The 300 that is visible in Particle Illusion won’t change but yet if I launch Illusion directly it is no problem to change.

Any thoughts?

Hi
If you have a look in the Optics preferences, you’ll see Effect Duration. Changing that will affect the project length when you launch Particle Illusion from Optics.

Hope that helps. If that’s not the case, could you post screenshots of your Optics preferences and what you see when you launch Particle Illusion through Optics.