Mesh track not working

Hello,

I am doing a face replacement in Mocha Pro for After Effects. I did this several times and it worked beautifully. I open Mocha within After Effects, then I create a mesh and track it. I save it and go back to After Effects. I copy the Mocha Data from my tracked clip and then paste it to the reference frame which is the face that I need to apply to the clip. I then slick Render, and select Stabilize Warp. The first few times this worked exceptionally.

However, now…it no longer works. I go through the same process, but now it’s like the tack data for the power mesh is not being applied to the reference frame. It says it’s there…when I look and see where I select Render and Stabilize Warp. But then nothing happens. I am at a loss for what is wrong. Is there anyone here who could point me in the right direction?

i have version 8.0.2 from Feb 2021

I have also trimmed the clips to the same length and still no luck. I have uninstalled, reinstalled both mocha and after effects, but after working once, it just stopped

I might have to see this to diagnose it. Can we schedule a time I can call you? Email me at maryp at borisfx.com and I will see what I can do.

Cheers,
Mary

Alright, glad we could sort that out on a call.

What was happening is your original clip was offset off the timeline by a lot of frames at the head, but your clip you wanted to replace the face with was not and started right at the playhead. To get around this, we simply precomped your clip by moving all attributes into the new composition and made sure to trim it to the size of the comp exactly, so the playheads matched on both clips, and re-tracked. We also trimmed your shot to the size of the comp to help make your comp a little cleaner. We suggest when creating VFX shots that you make sure you are working on a nice and neat trimmed clip to the area you need for the length of a specific shot in an edit, and not loading in an overly long section of footage. This also helps your host with memory management as well.

Hope that helps anyone else running into this issue and I am glad we could sort out what was happening! And have a great day!
Mary