Mine Mocha bugs and features


#1

Hi :slight_smile:
I’ll write here bugs or something that not work for me here and features that I like to see in next versions.
Bugs:
1 - Pan tool not working sometimes - locked (with wacom tablet and middle mouse button), can’t pan viewport image. But, when I click on spline (shape) point and then trying to Pan again - it’s worked, but after several movements and track forward or backward by 1 frame - Pan is locked again, until I select spline point.
2 - When I import a second clip in Clip tab and then go to Track tab, can’t draw splines, the viewport switch to original clip for the time that I hold down button of mouse or pen trying to draw spline and then switched back to showing the second clip. Also, ‘Input Clip’ in Track tab is grayed out and show the name of original clip, not the second clip (the second clip is active in Clip tab).
3 - GPU rendering not worked well, errors.
4 - Output to Quicktime mov crashed Mocha when trying to render shapes.
5 - Shapes in AfterEffects CS5.5 not working correct - all shapes have “Opacity” keys with animated keys from 0 to 100 and back when shapes finished or started.
What I mean: If I have composition with 100 frames as example, and have 2 or more shapes that present only for several frames (or so). At the point where shape should be invisible, there are keys for ‘opacity’ for several frames and this cause shape to slow fade out or fade in, and this is not right. Shape should cut at that point, not faded.
Hope I describe it right :slight_smile:
Features request:
1 - Pop up the window with information when Rendering shapes is complete or when saving or exporting shapes.
2 - Preview window or preview inside the viewport during Render shapes will be useful to see that all is going fine (especially if you have several shapes with different Blend modes).
That’s for now, thank you.
I will update the list soon.
My working machine:
CPU - Q6600
RAM - 8GB
GPU - GTX560 ti 2GB, with latest drivers
OS - Vista x64
Wacom Intuos 3 tablet
Best Regards!


#2

Hi Nik,
If you’re getting crashes, we’d like to see the error reports. Please log any bugs or crashes you see to our support form rather than the forum, as it helps us log it as a case for follow-up.
In reference to your numbers:

  1. We’ve seen this occur if you sometimes click before you press the key, but if you’re able to repeat this behaviour (especially for the middle mouse button) then it’s something we need to check. Thanks for pointing it out!
  2. This is because projects are set for the clip you start with. Importing new clips is just for other functions, such as calibration, insertion and mattes. Even if you could import a new clip to track, we wouldn’t recommend this workflow as it means you would have to track multiple splines for different clips in the same layer palette.
  3. If you are seeing GPU errors, this is normally related to your graphics card drivers. We would like to know what the exact errors are so we can follow them up however.
  4. We need to see the crash reports please, preferably with the project file that was causing the problem.
  5. Again, please send us a project file and export txt example so we can test this. We’d like to fix any problems like this asap, so a reproducible version would be ideal.

#3

Which version of mocha are you on? Have you updated your graphics drivers recently?


#4

Does this occur only when you’re in hardware rendering mode? Do you get the same problem if you run the 32-bit version?


#5

Thank you for your feedback, this kind of report is always very helpful.
Cheers!
Mary


#6

—Quote (Originally by NikNastev)—
Hi Martin :slight_smile:
You can see this video about Zoom and Pan - in first half I can’t pan or zoom.
Link: www.orkastudio.com/mocha
BR!
—End Quote—
I’m having the same exact issue. 2009 Mac Pro Quad 2.26 GHz. 24GB ram. ATI Radeon HD 4870 512 MB. SSD Drive. 10.7.1 Lion. Mocha v2.30.
Did you resolve your issue? It seems to be happening more and more. A day or two ago it never happened.
Thanks!
Nathan


#7

Hi Martin :slight_smile:
Thanks for response!
I will prepare reports when I get crash again asap.
About point 1 - yes, it’s repeatable at different time interval - I can’t pan or zoom with middle mous button and with tablet pen. Viewport freeze. Sometimes I need to switch to different opened already software or to desktop and back to pan again.
2 - Ok, thank you!
3,4 and 5 - these days I’ll send you reports.
BR!


#8

Screenshot from OpenGl error:
Image: http://orkastudio.com/mocha/gpu-error.jpg
Cheers!
Nik Nastev


#9

Mocha 2.6.0. build 3797 - latest
Graphics drivers - 275.33 - latest drivers.
BR!
Nik


#10

Yes, this error present only when I’m in hardware rendering mode.
I use only 64-bit version, haven’t use 32-bit.
BR!
Nik


#11

—Quote—
This is because projects are set for the clip you start with. Importing new clips is just for other functions, such as calibration, insertion and mattes. Even if you could import a new clip to track, we wouldn’t recommend this workflow as it means you would have to track multiple splines for different clips in the same layer palette.
—End Quote—
Being able to change the shot is incredibly useful. For example, sometimes I use other software. A color corrected plate can be used for parts of the frame, A grid output from other software can be used to get through a difficult section. Sometimes shots are changed like degrained, undistorted or lengthened (this happens nearly monthly). It’d be nice if I could dynamically assign a plate to a layer. Seems like it’s already nearly setup to do that.
One of the main uses I have for mocha is as a step in working toward camera smoothing and stabilizing, or tracking blochy regions that other software can’t. Rarely does one tool complete an entire shot.
T