Mocca 2.0 cornerpin/scales past 100 and blurs image

Hi.

I have a shot with alot of distortion. Luckily Mocha tracked PERFECTLY!

but now my problem is, I need the corner pin and transform data, and i paste it into my after effects project… I can see it lines up PERFECTLY, but because of the scale going way past 100 percent, it takes my source image and makes it VERY soft, no matter how high res it I make it.

ok, so I precomp the layer on it’s own, so that I can collapse transformation, but it messes up the corner pin. I can’t figure this out at all.

I saw one other thread with someone with this same problem but I still can’t figure this out.

too weird, I even went back and made sure that I had way more pixels in my replacement art/layer than I even needed and it just won’t work due to going past 100percent in the transform data. Remove the scale transform data, and the corner pin doesn’t work.

Any help MAJORLY appreciated!!

Hi orobles,

What version of mocha are you running?

—Quote (Originally by orobles)—
How do I “define” the surface? Not sure i follow. I just tried to track backwards but it still made my scale 100% on frame 0. My last frame is the one I would like to set as 100%. Thanks alot for the help!
—End Quote—
Go to your last frame, click on the surface view (in the right hand panel) and drag your blue surface corners to fit how you would like it to be at that frame.
For example, say I have simple square sign that is coming straight at the camera and turning slightly. I track the shot, then on the last frame (where the sign is the largest) I drag the corners of the surface to fit the scale and perspective of the sign at that point.

Hi orobles,

I’ll quote J-P who mentioned this the other day in another thread (http://forum.imagineersystems.com/showthread.php?t=905):

—Quote (Originally by J-P)—
The translation, rotation and scale data is worked out relative to a reference frame, which is the frame where you define your surface in mocha. So if you define your surface in a frame where the object is small, that size will be taken as 100% when you copy to AE. If the object gets bigger, a >100% scale factor will be applied, which results in softening in AE.

To get the best results, you should line up your surface with the object when it’s large in the frame - as close to 100% as possible. This way, most of the scaling will be to <100%, with no loss in quality.
—End Quote—

Does that help?

Hi orobles,
I’ll quote J-P who mentioned this the other day in another thread (http://forum.imagineersystems.com/showthread.php?t=905):
—Quote (Originally by J-P)—
The translation, rotation and scale data is worked out relative to a reference frame, which is the frame where you define your surface in mocha. So if you define your surface in a frame where the object is small, that size will be taken as 100% when you copy to AE. If the object gets bigger, a >100% scale factor will be applied, which results in softening in AE.
To get the best results, you should line up your surface with the object when it’s large in the frame - as close to 100% as possible. This way, most of the scaling will be to <100%, with no loss in quality.
—End Quote—
Does that help?

—Quote (Originally by orobles)—
Thanks for the quick reply. I started the track from the object being very small. If I understand correctly, I should try starting the tracking from when it is the largest on screen and going backwards? My shot if for a commercial from the point of view of a dog on the floor. and he goes in and out (the camera that is). Thanks again… I am gonna try this right now. =)
—End Quote—

You can keep your tracking data from where you had it, but define the surface at the largest point when you are done.

—Quote (Originally by orobles)—
Thanks for the quick reply. I started the track from the object being very small. If I understand correctly, I should try starting the tracking from when it is the largest on screen and going backwards? My shot if for a commercial from the point of view of a dog on the floor. and he goes in and out (the camera that is). Thanks again… I am gonna try this right now. =)
—End Quote—
You can keep your tracking data from where you had it, but define the surface at the largest point when you are done.

—Quote (Originally by orobles)—
How do I “define” the surface? Not sure i follow. I just tried to track backwards but it still made my scale 100% on frame 0. My last frame is the one I would like to set as 100%. Thanks alot for the help!
—End Quote—
Go to your last frame, click on the surface view (in the right hand panel) and drag your blue surface corners to fit how you would like it to be at that frame.

For example, say I have simple square sign that is coming straight at the camera and turning slightly. I track the shot, then on the last frame (where the sign is the largest) I drag the corners of the surface to fit the scale and perspective of the sign at that point.

Hi orobles,
What version of mocha are you running?

—Quote (Originally by orobles)—
V2.0.0 on the OS-X mac. I am on After Effects CS4. Thanks for the help.
—End Quote—
Can you please try upgrading to the latest version (2.1.0):

Make sure you save your licence information as it will be overwritten if you install over the top of the one you have now.

If this does not work, please email me your project files to:
martinb[at] imagineersystems(dot)com

—Quote (Originally by orobles)—
V2.0.0 on the OS-X mac. I am on After Effects CS4. Thanks for the help.
—End Quote—
Can you please try upgrading to the latest version (2.1.0):

Make sure you save your licence information as it will be overwritten if you install over the top of the one you have now.
If this does not work, please email me your project files to:
martinb[at] imagineersystems(dot)com

—Quote (Originally by orobles)—
To save my license info, I can just copy and paste it from the “help/view license” menu item correct?

Thanks.
—End Quote—
You can (it might be safe to paste it to a text editor as well), or you can just use it from the original email you received when you registered your host id.

—Quote (Originally by orobles)—
To save my license info, I can just copy and paste it from the “help/view license” menu item correct?
Thanks.
—End Quote—
You can (it might be safe to paste it to a text editor as well), or you can just use it from the original email you received when you registered your host id.

—Quote (Originally by martinb)—
Hi orobles,

I’ll quote J-P who mentioned this the other day in another thread (http://forum.imagineersystems.com/showthread.php?t=905):

Does that help?
—End Quote—
Thanks for the quick reply. I started the track from the object being very small. If I understand correctly, I should try starting the tracking from when it is the largest on screen and going backwards? My shot if for a commercial from the point of view of a dog on the floor. and he goes in and out (the camera that is). Thanks again… I am gonna try this right now. =)

—Quote (Originally by orobles)—
I just emailed you my project file.

Even in V2.1 which I just installed and got running with my license, I can’t get the 4 blue markers to reset so that the 100percent scale reference starts at my end frame.
—End Quote—
I did get it to now work with the new “corner pin only, supports RGWarp…” option. But it would be great to get the motion blur option to work properly since my scene has heavy motion blur in the original footage. Thanks for all the help!

Hi.
I have a shot with alot of distortion. Luckily Mocha tracked PERFECTLY!
but now my problem is, I need the corner pin and transform data, and i paste it into my after effects project… I can see it lines up PERFECTLY, but because of the scale going way past 100 percent, it takes my source image and makes it VERY soft, no matter how high res it I make it.
ok, so I precomp the layer on it’s own, so that I can collapse transformation, but it messes up the corner pin. I can’t figure this out at all.
I saw one other thread with someone with this same problem but I still can’t figure this out.
too weird, I even went back and made sure that I had way more pixels in my replacement art/layer than I even needed and it just won’t work due to going past 100percent in the transform data. Remove the scale transform data, and the corner pin doesn’t work.
Any help MAJORLY appreciated!!

—Quote (Originally by martinb)—
Hi orobles,
I’ll quote J-P who mentioned this the other day in another thread (http://forum.imagineersystems.com/showthread.php?t=905):
Does that help?
—End Quote—
Thanks for the quick reply. I started the track from the object being very small. If I understand correctly, I should try starting the tracking from when it is the largest on screen and going backwards? My shot if for a commercial from the point of view of a dog on the floor. and he goes in and out (the camera that is). Thanks again… I am gonna try this right now. =)

—Quote (Originally by martinb)—
Hi orobles,

What version of mocha are you running?
—End Quote—
V2.0.0 on the OS-X mac. I am on After Effects CS4. Thanks for the help.

—Quote (Originally by martinb)—
You can keep your tracking data from where you had it, but define the surface at the largest point when you are done.
—End Quote—
How do I “define” the surface? Not sure i follow. I just tried to track backwards but it still made my scale 100% on frame 0. My last frame is the one I would like to set as 100%. Thanks alot for the help!

—Quote (Originally by martinb)—
You can keep your tracking data from where you had it, but define the surface at the largest point when you are done.
—End Quote—
How do I “define” the surface? Not sure i follow. I just tried to track backwards but it still made my scale 100% on frame 0. My last frame is the one I would like to set as 100%. Thanks alot for the help!