Mocha 2022.5 v 9.5.4 - adjust track still unusable

So new version is out and still can’t work with Adjust track tool.
The new adjust tool - transform tools don’t work on reference points - can’t move all reference points together, so no out of frame track adjustment. - it’s useless for any non tutorial shots.

Classic Adjust - works only for frames AFTER the initial reference frame. If you try moving reference points in any frame before the initial reference frame - the tracking surface explodes.

Come on, I test it evey 6 months - it’s been over two years now since you introduced the new Adjust Track module and it’s still not fixed.

You promised it would get fixed - as it should since it’s pretty much one of core features in Mocha.

Marry tried showing how to work with new Adjust Track module on live Tuesday and she also stumbled trying to move all reference points at once, until she gave up after a couple of tries.
The Adjust Track module and when it will be fixed was literally the first question someone asked on that live.

And here we are, end of 2022, in a month or two you’ll be debuting Mocha 2023.And here I am and pretty much every single Mocha user I’ve talked to in the industry running Mocha 2020 as their daily driver - the last version that is actually working :confused:

Come on guys, I’m a software developer too. I understand that you might have built the new AT tool so that it is difficult to move all reference points at once (although two years?) but the classic AT module worked perfectly well - you broke it with the 2021 version. Seriously how hard is it to find a bug in a tool that you just copied over from a previous version - one evening is all it takes to compare the codes in both builds .

FFFFFFFIIIIIIIIIIIIIXXXXXXX IIIIIIIITTTTTTTT!

Hi, does Ctrl+A to select all then right click & hold not move all ref points for you?

Yes,
but the whole point is to make the transform tools work with them, just like they do in classic AT.
If half of your surface moves outside of frame, you might be able to maintain their relative position if all you need is to move the entire surface, but if you need to rotate or scale it - there is no chance you’ll be able to do it moving points separately. It was never an issue with the old AT as you could just hold Q,W or E keys and invoke transform commands - the same as you do on splines, selected vertices or the control surface itself. Now for some reason in the new AT tool the transform commands or even tools from the toolbar don’t work. I understand they could have missed it in their first or second iteration of the new tool, but it’s been over two years now.

I honestly don’t think they will ever fix it, the don’t care.
Every six months I start this thread, they tell me that everything works fine, then I prove it doesn’t, they tell me I can stil use the Classic AT - I prove them that I can’t because they broke it and still didn’t fix it - then they admit it’s a problem, tell me they added it to the bug tracker, promise it will get fixed. Another 6 months passes, a couple of new versions get released, I test the AT tools - nothing has changed.

And it’s baffling to me. I understand an ignored bug in UI or in some obscure function that doesn’t get used that often, but AdjustTrack???
I don’t think I’ve ever done a shot that didn’t require adjusting - it’s a core functionality of Mocha. And since version 2021 it’s broken and broken in a way that actually makes it impossible to track shots that were a piece of cake before.
Fixing a track was the key thing I taught artists in studios I was a super in. This was always the “aha” moment for them, that they don’t always have to get a perfect track, they just need to get the jitters right - if it drifts away, no matter, it’s an easy fix. Well it’s no longer an easy fix - if you’re just tracking transforms, you’ll get by, but if you’re tracking perspective, any attempt to adjust a track when even a single reference point is obscured ends up in a wobbly mess (a problem also visible in Marry’s live with a closing laptop screen :confused: )
The first thing I used to ask in every new studio was “Do you have Mocha?” If not, I told them to buy it. It’s amazing how many studios didn’t even know that Mocha exists as a standalone software and how much more it can do than the one bundled with AE.
Now what am I supposed to tell them? Buy Mocha but Mocha 2020? I know it’s not sold anymore - figure it out somehow.
Studios working on AE are lucky - I direct them towards Lockdown, but others? I still direct them towards Mocha since it’s still the best out there, but now I hear constant whining that it sucks. And you know what? It does suck.
If I have Mocha 2020 available (which luckily in most studios I still do as they also haven’t upgraded yet), tracking a shot is not an issue, even if the tracked surface completely disappears on fragments of a shot - it’s a pleasure because it’s simple and it solves unsolvable problems for other software in the pipeline.
But if I don’t, and the newest Mocha is all I’ve got, because the studio doesn’t have a history of working with Mocha - then it becomes a nightmare. 15 minutes of masking and tracking - hours of adjusting the main track - just because you were 2 pixels off with one reference point that has the biggest perspective weight on it :confused:

I’m glad the new tools work on shots where nothing is obscuring the tracked surface and it doesn’t get out of frame. I’m glad that we can use more than 4 reference points - although I’m still waiting for a tutorial for why we would actually need this since the points don’t extrapolate each others positions when moved so you still have to move all of your reference points one by one no matter if they are obscured or not :confused:

I’m just so angry that the software that literally changed compositing for me and has been my daily work horse for probably a decade has just died, for no reason at all. What, did BorisFX fire everyone from Imageneer team?
And I’m reading the forums, new users come here with difficult tracks, ask for help, and yeah, your track is difficult, it’s going out of frame, gets obscured a lot, suddenly makes a 90 rotation in two frames - it’s not a simple static shot.
If you have Mocha 2020 you can fix it in 5 clicks, if you’re on Mocha 2022, well you have to be patient, turn on planar grid, turn on trajectories, turn on 8x8 Checker to see what happens with the insert while you’re nudging the reference points. And prepare to go over every part of your clip 10-20-30 times to check if the insert is not overstretching or popping. How are we supposed to help that person - he’ll just give up.

Didn’t they say something in a thread a few months back like “I’ll bring it up and next team meeting””. I wonder what the story is with it? The only thing I can think, and this is pure speculation/opinion on my part, is that due to the way they remade the mocha software in 2021 they can’t apply some simple fix to it because they would need to rewrite the entire code or something - again, that is just an opinion and I have no idea what the deal is however I think it’s odd that no one really addresses the problems you articulated in a substantive way that actually solves the problem.

Yeah.
I also got this info in a mail a couple of times.
Last one was in April or May - like I said, I bring this up every six months or so.
But here we are and still nothing has been fixed.
And I can’t stress this enough - I wrote them an email the first week the 2021 version was released. I thought I was doing something wrong.
Two years have passed and I still haven’t upgraded from 2020.
The only interesting new feature is the Mesh tracking - but Lockdown just wipes the floor with Mocha in this department so I don’t miss it.
Megaplates seemed usefull - but it doesn’t work most of the time, and once you have all the layers tracked, building the megaplate manually in compositing takes a couple minutes - so it’s not really worth the time to try and traoubleshoot the automatic Megaplate creation.
So yeah, two years, 6-8 new versions, no new interesting features but broken old ones. Awesome development - and people say Autodesl sucks :slight_smile:

Hello @kaczorefx

Could you please link me to that examples where you show that classic AT is got broken in 2021 release?

No example needed it fails 100%. All you have to do is switch to AT (or reset) at a frame other than the first frame of the shot.
So let’s say you start AT in the middle of the shot.
If you go forward, everything works. You can move each reference point as you like.
But if you go backwards, so before your reference frame, it will brake.
You move the first reference point - looks good.
Move second point - looks good.
Move third point - looks good.
Move the last point - suddenly all 4 points explode, they move to completely different locations and get unlinked from the control surface corners.

Sorry, I can’t repro that,
Is that just with one Spline/Planer surface?
What type of media?

Hey @kaczorefx
We are listening seriously, but we couldn’t get the problem to surface - until now.

The good news is we’ve finally reproduced the problem with the information above. Maybe I overlooked this specific point about the fourth corner in our previous conversations, but that’s what broke it.
Now we know where the problem is exactly we can fix it, and you’re right, it seems to regress after v7.5.2.
Try as I might from the last few parts of our conversation I couldn’t get the problem to appear (even moving all points, but trying exactly what you wrote here is what we needed. It’s the FOUR points being keyframed specifically. :flushed:

The problem seems to occur specifically when you have keyframed ALL corners and the backward keys get introduced. It doesn’t reproduce when only SOME of the corners are keyframed.

We can now move forward with fixing this.

We’ll focus on getting this part fixed first and address the other problems separately.

And @kaczorefx I really do have to apologise. We’ve let you down here and the problem has persisted for some time. Now we know what we’re dealing with we can get it working again.

1 Like

Um, I don’t know what to say.
Better late than never?

And how are we on being able to transform all reference points in the new AT tool with Q,W,E transforms?

1 Like

@kaczorefx I really appreciate you raising hell about this, and I’m sorry we haven’t taken the opportunity to fix it before now. As Martin mentioned, we reproduced the problem you mentioned and also found two other problems related to classic AdjustTrack that are regressions since we added Transform AdjustTrack. Our dev team is investigating the issues and we aim to fix them in a maintenance release as soon as possible.

Regarding the shortcomings of Transform AdjustTrack, there is a hidden feature that I think we need to highlight. It is possible to keyframe the points individually. In our original design, this was the default mode, and it’s absolutely necessary for situations where points move out of frame. The problem is, if you’re not careful, it’s easy to create unexpected transforms, which is why we changed the default. If you hold down Ctrl-Alt (Cmd-Opt on Mac), while moving a point or nudging, it will not keyframe the other points.

There are a couple of situations where additional points are useful. For a full perspective shot, to handle situations where some of the original points are obscured, similar to adding extra reference points in classic AdjustTrack. The difference is that in classic AdjustTrack, the reference points control a single corner, whereas in Transform AdjustTrack they contribute to the overall transform. Another situation is for non-perspective shots, for example where you need to correct drift over a long pan, and you might be using a translation-only adjustment. These scenarios would both require the Ctrl-Alt trick to be effective, so we will look to expose that control in a more obvious way in the user interface in future.

Regarding QWE transforms, I don’t think there’s anything stopping us adding that. We already have multi-select and the nudge tool moves all the points together so we are half way there. We have an extremely full schedule at the moment, but will try to prioritise this for the next major release.

1 Like

Glad you finally acknowledged it. The new features are fun but without a robust hands on manual Adjust Track, which is our bread and butter in most shots that require Mocha for tracking, the last two years were very frustrating :confused:

The additional reference points:

  • the fact that additional reference points contribute to the overall transform is not the problem
  • the problem is that the previous points that are now out of frame (so useless) are also still contributing to the transform - so you can move your additional reference point as much as you like but you won’t get your control surface in the right spot because the points that are outside of frame are still pulling the corners of the ctrl surface. So either you force the ctrl surace to the correct position by dragging the additional point way further then it’s original feature on the image (so now the additional point is in a different image feature point than it was initially so it’s no longer a “reference” point) or if you want to keep the additional point on its image feature you also have to move the points that are now outside of frame for which you don’t see their image features (and if you do that, then what is the use for the additional reference point since you still have to move obscured/out of frame points to adjust the track)
  • and the third problem - the additional point should help us out, every time one of the corner points gets obscured and we can’t see it for adjustment, we pop an additional point on something nearby to help us out. Unfortunately it doesn’t work like that - we have to create all our additional points in advance together with the initial corner points, because of you decide to create one later on in the process: 1. It doesn’t follow the Adjusted track it just stays in place wherever you created it, 2. as soon as you touch a point like that the control surface explodes - usually it just disappears :frowning:
    Now I might be using additional points wrong, I know that.
    That’s why I’ve been asking for two years now for a tutorial on how they should be used. Right now we have one - the green ipad screen replacement. But in that tutorial none of the reference points go out of screen or get obstructed, so Marry is just doing a track that could easily be made with normal 4 point, but using 6 points - so more manual work for no apparent gain.
    So please, the same tutorial but with the ipad going partly out of screen, so that you begin with normal 4 point perspective adjustment as we do with every single shot, then an Oh shit moment when two of the corners go out of screen, and now show us how to add the additional two points on the markers in the middle of the screen so that we can continue adjusting the track with the two corner reference point out of frame.
    I hope it’s clear enough :wink:
1 Like