MOCHA 2022 Planar Surface Error

Getting an error with the planar surface and unable to adjust it without having the show layer outline button turned on. I wanted to hide everything else and just adjust the planar surface but I’m unable to adjust the surface. Only can adjust if I keep the show layer outline button toggled on. Is this a bug with the new Mocha 2022 update or what. Need a solution please.

This definitely appears to be a new bug. We changed the layer selection precedence for 2022 in order to make it easier to work with the grid and mesh selection in the insert module, but this seems to have caused a problem when you turn the layer splines off.

Terribly sorry about that, we’ll get a fix into 9.0.1 asap. In the meantime, just make the spline a little wider so you can adjust the surface points without hiding the spline.

1 Like

Glad it wasn’t a me problem and just a bug. Thank you

No worries, we’ve identified the issue and someone is working on it as we speak.

1 Like

Hi, I noticed this the other day & presumed it was my PC, I just looked now & when i put the cursor over the corners to adjust, the star shape doesn’t appear & won’t let me adjust, glad it isn’t me too :+1::+1::grin:
@martinb I’ve only had Mocha a few mths, i have Boris FX App Manager, do i need to look out for updates or do they happen automatically,
Thanks

@gid.joiner The problem here is specifically a 9.0.0 issue. Are you seeing this problem in an earlier version?

You would be notified of updates if you have it turned on in preferences (it is on by default).

Hi i’ve only had Mocha a few mths so i think i’ve only had the most recent update, i don’t know what a 9.0.0 issue is, but i could def do this adjust on the blue planer surface without the red spline track showing, that’s why i noticed it.
this is an image from a while back & i remember adjusting to fit


This is a quick screen capture of how it is now,
I can adjust the planer surface if the Layer Outlines are on, but not if they’re off,
showing or not showing the Spline Tangents doesn’t affect this outcome,
is this how you expect it to work?
& thanks yes updates are turned on in preferences :+1::+1:

Right, so it’s the same thing. Good to know it’s reproducible! We have a fix incoming.

1 Like

Thanks,
funny thing is if the Track outline is turned off when first creating the spline you can adjust the planer surface, switch the Track outline on & you can still adjust, but then turn it off again & the adjustment for planer surface goes away, something to do with that button
it’s the same on Adjust track & inset tab at the bottom,
I couldn’t post this screen grab on here so put it on YT
Thankyou. :+1::+1: (just realised 9.0.0 is the Mocha version no’ Doh!:man_facepalming::upside_down_face::woozy_face::rofl::+1:)
Screen capture of the Insert tab & Adjust track tab on Youtube

I’ve also been losing the transform tool randomly around my shapes few minutes in from rotoing it. I try to toggle the switch off/on and nothing. Or click on another shape. I usually have to clear my cache or close it and reenter.

To mention here, I have seen this same issue where the surface on a layer temporarily is not selectable.
A very quick workaround is to simply create a new layer and then delete it. Then you can select your layer and position the surface.

This has now been fixed and will be in the v9.0.1 maintenance release coming out today.

2 Likes

Thankyou, yep fixed on my machine :+1:

Thank you for the update.
We can now select planar surface but there is a similar error in the Adjust Track tool. I cannot select individual points when the Layer Outlines are off.

Sadly yes, we caught this too late. It will be in the next patch update. Sorry about that. :scream: