Mocha 4 edge width artifact on viewport layer matte / colourize layer matte

Hi Guys

I am testing out the new mocha4.0. Using the “Edge Widths” on a roto shape will result in an ugly artifact outline appearance of the mocha viewport (show layer matte / colourize layer matte). The issue is only when you are working with the viewport but this is very important as i work a lot of edge widths that no global motion blurring will compensate. edge widths are better for manual motion blurs on the edges. When you render the matte normally on image sequence, quicktime formats as mattes all the edge width artifacts issue are gone and look just fine. The issue is only when working, you have no idea what your rotos look like with edge widths on the viewport because of the annoying line artifacts. Mocha v3 doesn’t have this issue. See attached pic here.

as you can see here the outlines are very visible like halos when you put a value of any amount for the edge widths or manually adjusting them

as you can see here on matte overlay mode, the lines are more visible they look like they are part of the matte but when rendered as final mattes they are gone and looks normal. but i don’t want to work rendering the matte 1st before i can see what my roto looks like in mocha :slight_smile:

I am using a gaming laptop with the ff. specs: core i7 2ghz cpu, 16gb ddr3 ram, 120gb ssd, GPU Geforce GTX460M 1.5gb vram and OS windows 8.1 64bit

i hope you can look at the issue guys. this is very important for a lot of artists “edge widths” :slight_smile:


kind regards


Hi, thank you for letting us know. Can you please verify that you have the latest video card driver update for your machine? It will help us diagnose this on our end.

Hi Francis,

Can you try disabling offscreen buffers?

  1. Go to Preferences
  2. Go to the new Open GL tab
  3. Select "Disable Offscreen Buffers"
  4. Restart mocha

Hi Mary

Yep I confirm that im using the current updated Geforce drivers from nvidia attached screen grabs are here

Hello Martin

I also tested disabling the “Offscreen Buffers” but to no luck the results are same it’s even worse as it disabled open GL acceleration on the viewport. it is very slow panning around mocha4 view port with the offscreen buffer off as i don’t know what this option really means. I also enabled it back and disabled again same results, i also tested vertical sync on and off, the same results lowering / increasing vram still same. Mocha 3 doesn’t have these issues. Screen grabs are here

I hope you can look at these and test it on different systems at your end :slight_smile:


Imagineers :slight_smile: