Mocha AE not bringing in clip from After Effects


#1

Hi All

New to Mocha and I’m being driven completely crazy just trying to get a clip into it.

Simply want to take a clip from AfterEffects CC 2015.3 into Mocha AE to be tracked and then come back to AE. I select my footage and then select Track in Mocha AE. Mocha launches and starts with the new project dialogue but there’s no reference to the clip that I am trying to track at all. Instead it is asking me to select the clip. Found this odd because when watching a tutorial on the Imagineer website (Mocha AE for Absolute beginners) when the instructor does this the clips is prepped ready to begin in?

Why is this not happening for me?

Cheers


#2

Hi there!

What is the clip file format and codec you are trying to bring in from After Effects?

Mocha AE works by finding the path of the footage in your AE timeline and feeding into the application, so if it has trouble finding the clip, it will ask you for a new one.

Mocha not finding a clip is normally due to one of 2 reasons:

  1. The codec is not supported (or is corrupted)
  2. The file path has special characters that mocha cannot read (this is rare)

#3

Hi

The clip format was a camera native clip from the Sony A7sII. I believe this is a XAVC-S in 4K wrapped in a .mp4 file. It was coming from Adobe Premiere linked into an AE project via dynamic link. I find it odd that the path was an issue. What type of special characters would throw Mocha off? Spaces? Hyphens? Full Stops?

The clip works fine in Premiere and After Effects so I don’t think that the clip/codec is corrupted.

Any further advice?

Cheers

Alex

 


#4

It sounds like the codec is unsupported and you will have to save the file as a different type.


#5

I am having the same problem. We had the problem with a previous version of AE CC and thought maybe an update to AE 2015.3 CC would fix the problem. This unfortunately was not a fix. AE CC will not send information to the AE Mocha Plugin.

When I select my video track (.MTS File from a Canon C100), none of the clip information is there when Mocha opens.

No codec issues on the system for .MTS formats as we use this daily for productions. We keep everything updated.

There are NO special characters in the location, filenames, etc. The only thing is there are spaces in the folder structures.

 


#6

We don’t support those files. There are certain types of codecs and file types that mocha does not support, usually native, unprocessed codecs off of cameras and AVIs on Windows. You may need to convert the file to something mocha supports, such as quicktime or AVI with a basic codecor an image sequence. If your screen is black or white for clips but not for images, it is most likely the codec for the movie files that is causing the issue.

Keep in mind the Codec is not the same thing as the file type, it sounds like you have a codec problem with MTS files. A codec is the type of compression, the file type is AVI or MOV.
View Documentation: supported file list http://www.imagineersystems.com/support/documentation/#File_Formats
We do support the following:

Movie clip formats

  • AVI files (.avi)
  • DV Stream files (.dv)
  • MP4 files (.mp4)
  • MPG files (.mpg)
  • QuickTime Movie files (.mov and .qt)
  • RED files (.r3d)

Image formats

  • OpenEXR files (.exr)
  • OpenEXR 2.0 files (.exr)
  • Cineon files (.cin)
  • DPX files (.dpx)
  • JPEG files (.jpg and .jpeg)
  • PNG files (.png)
  • SGI files (.bw, .iris, .rgb, .rgba and .sgi)
  • TGA files (.tga)
  • TIFF files (.tif and .TIFF)
Of course, with the new mocha Pro 5 plugin that reads off your host timeline, what files we support or not in the standalone is moot, as if your host can read it then so can mocha.

Cheers,
Mary


#7

Conversion worked from MTS to MP4.

It’s a shame the plugin doesn’t support native files that the host software (After Effects) does.

 

Thanks for the help.


#8

Thats why we worked to get the mocha Pro 5 plugin up and running! It reads anything the host can read because it reads the timeline. You might want to try a trial! :slight_smile:


#9

Sorry Mary I don’t follow. I have the Mocha Plugin as supplied with After Effects and it does not read the native files on the timeline?


#10

So there’s the standalone light version that ships with AE, it’s called mocha AE, and it’s not a plugin, it is a standalone piece of software that installs with Adobe AE, though the way it interfaces into AE with the shape effect and the lens effect are plugins. There’s a new product out called mocha Pro 5 the Plug-In and it actually reads off your timeline and it is truly a plugin operating within the AE interface and reading from the AE timeline and GPU accelerated tracking. Notice how mocha AE that you have reads your clip, not your timeline, and that the mocha Pro standalone for example has to render to separate files and not back to the timeline. That’s the main difference. Also, everything available in mocha Pro, like the remove module, insert module, and lens module as well as the 3D solver, are not available in mocha AE. The plug-in is something we have worked on for the past year and offers a much more seamless workflow for our users with many more features. It’s also the lest expensive version of mocha Pro we have ever offered.

You can see the differences between the free version and everything else we have to offer here: http://www.imagineersystems.com/products/compare/

Here’s a very quick breakdown of what the plug-in in: http://www.imagineersystems.com/videos/top-10-list-mocha-pro-5-plug-in/


#11

I’m trying to use the light version of mocha that comes with AE and these file formats you’re listing still don’t seem to work for me. I’ve got several versions of the same file that I’ve exported through Adobe Media Encoder as AVI, DV, and MP4 and I get the same error every time I try to import them into Mocha AE.

I downloaded the Pro Trial and apparently you can only export 10 frames of tracking data which is just silly. What other options do I have to get this to work in Mocha AE?


#12

Codec is not the same thing as file type, so many AVIs might be encoded with a compression codec that Mocha can’t read. Try a PNG or TIFF sequence if you don’t have a lot of codec support or quicktime installed on your machine.

Or try installing a more varied codec support on your machine and make sure you have Quicktime essentials installed.


#13

Nov 2018 Update: Mocha AE is now a plug-in and will read ALL file types that After Effects supports.
Update the latest AE in Creative Cloud to get this feature.

New feature video: