Mocha AE - UI frozen, multi-screen issues, RTX 2080

Hi all

I have a new desktop since around one month. Everything was working allright. I was using mocha on a project without any problems. Since today I noticed some strange UI bugs and as I tried to fix them, I kinda broke the mocha AE plugin.

This is was happend:

  1. I was masking and doing tracking on R3D footage inside the mocha AE plugin.
  2. On my second screen (the one without the plugin window open) I noticed a flickering. After some minutes it went completly black. Windows still reconizes the monitor as connected and as soon as I close AE the screen comes back to live. (Screen 1 and m wacom as screen 3 continue to work properly)
  • Mercury transmit settings are completly turn off.
  • Tried on a clean project and other image file types, same results.
  1. So I went in the preferences of mocha and set it to start as full sceen… and that’s when it broke. When I open the mocha plugin now, the UI is frozen and flickers black every around 2 seconds or when I playback the clip. It doesn’t let me open the menu bar options (file, edit, track…), so I am not able to open the preferences and switch it back to windowed mode. I can make splines, playback, and hit other UI buttons (except the essentials/classic drop down menu). Looks like everything that opens a new tab or dropdown isn’t working.

  2. Restarting the PC or AE didn’t help. Reinstalling AE (keep settings) didn’t help. Didn’t try a clean AE install yet.

  3. Basicly mocha is broken and I can’t seem to fix it alone. Has anyone ever had this or similar issues?
    It seems like a graphics driver/card issue.

My System:
Windows 10 Pro 64Bit (up to date)
Intel Core i9-9900K
Asus Rog Strix RTX 2080 Ti (Studio Drivers, up to date)
64 GB RAM Corsair LPX
Gigabyte Aorus Master Z390
RAID 0, M.2 NVME SSD (System + Apps)
500GB EVO SSD (Cache)

Thanks in advance!
Claudio

Update 1:

I was able to set the plugin to start in windowed mode, using registry editor.

Computer\HKEY_CURRENT_USER\Software\Imagineer Systems Ltd\Mocha AE CC Plugin 6
set FullScreen from true to false.

The black second screen issue is still present, after I move the mocha program window to another screen.

Can you try deleting your registry files for Mocha entirely and restart Mocha? Usually that will reset everything.

Hey Mary

Thanks for your response and thanks for all the awesome tutorials!

As I wrote in my first response, I was able to get it to work again by editing the registry. I’ve also just cleared it the whole registry as you said. Sadly the screen flickering error still occurs as soon as I start to move the mocha window to another screen.

Best
Claudio

1 Like

Ah, sorry, I misread that.

OK, so (and I get this isn’t practical for working but I am trying to troubleshoot), what happens if you only use one screen? It might be a bug with a second screen that we will need to look into and this helps us track the error down.

Cheers,
Mary

Hey Mary

I was able to test the issue with different screen setups from 1 up to 3 monitors. It seems like the issue happens as soon as the mocha window touches a second screen while hovering the window.
I took some videos that could help you understand the error better.

I’ve also put a screen capture of the full screen issue at the end. This was recorded with only one monitor plugged.

I hope this helps and lets you figure it out! Thanks in advance!

This is helpful, we have been seeing some issues with dual monitor setups we are trying to track down. I will let @martinb know and see what we can do to track this down.

Thank you!
Mary