Mocha AE Will Not Start After Fresh Install

Are you getting any kind of crash log? Can you try downloading and installing a trial of Mocha Pro and see if that will launch? Boris FX | Downloads

If it doesn’t, we can narrow down the issue. And maybe get a log.

Hi Mary,

Sorry for the delay in response. Circling back to this to see if I can get it resolved.

Where would I typically find a crash log? I just installed a trial of Mocha Pro and that also did not launch.

Hi there,

You should be able to find it in C:\Users\MaryP\AppData\Local\BorisFX\mocha.log

Can you let me know if you see any crash errors in it? It might be quite long, I only need the most recent parts.

Cheers,
Mary

Mary,

Found the logs. No crash errors at all. Last entry in the log is just:

[Image Cache]: Using image cache directory 'C:\Users\mcorn\AppData\Local\Temp\BorisFX\Mocha AE Plugin\ImageCache

But that’s just for MochaAE. Trying out Pro - it just gives a lot on entry in the logs about the license, which makes sense as it’s just a trial for Pro.

Can you email me the Mocha Pro log? You said that was also still crashing? MaryP@borsifx.com

@user70 Can you also supply log details, please?

You can find the mocha.log file at:

  • Win10: %localappdata%\BorisFX\mocha.log (%localappdata% is usually C:\Users[yourusername]\AppData\Local)
  • macOS: ~/Library/Logs/BorisFX/mocha.log

Yes it was. I’ll send you a email here shortly.

Thank you, got the email, and forwarded it to @Martinb so we can take a look.

Is there any update to this ? I am, and have been having this same issue since AE21 and haven’t been able to use MochaAE in a while. I can’t even find the preferences to delete.

Click on Launch in Mocha AE, Get a spinning circle for about a sec then nothing happens. Just acts as if I didn’t even click it.

We are trying to get to the bottom of this still. Working with @martinb and the dev team on a solution.

Hi! Writing because I’m having the same issue. MochaAE is simply not launching. I’ve deleted preferences, reinstalled After Effects, updated operating system, to no avail. I’m working on a MacOS Monterey v12.3; AE version is 22.2.1

Let me know if a solution is found!

Hi all,

If you’re able to, can you install the After Effects beta version and let us know if you get the same launch issue?

Can everyone also tell me the size and bit depth of the footage they’re applying Mocha AE to?

For me the footage size doesn’t matter. I’ve tried 720, 1080, 4K it won’t open for anything. Don’t know the bitrates. I believe it stopped working for me on version 18.0.0 but don’t 100% remember.

It’s not working on 22.2.1. I just get the loading circle which then stops but Mocha AE doesn’t open.

It’s also not working on 18.4.1. The difference on that version of AE is that it crashes the program every time. Also tried installing 18.0.0 and that crashes as well.

Also tried the BETA and still didn’t work

Tried reinstalling drivers on GTX 1070. Both Studio and Game Ready and neither worked. Same thing happens.

Also can someone tell me where the preferences are so I can delete them. I can’t find them.

If it specifically crashes, can you get us the crash dumps? Here’s how to do that:

  1. Start a Command Prompt as Administrator
  2. Run: reg add “HKLM\SOFTWARE\Microsoft\Windows\Windows Error Reporting\LocalDumps”
  3. Run Mocha AE from After Effects
  4. After it crashes (or does nothing!), there should be a crash dump file in %LOCALAPPDATA%\CrashDumps.
  5. Send us the crash dump file.

If you don’t get a crash dump via the plugin, try running the Mocha AE process file directly. It won’t run externally and will show an error dialog if it runs, but you may get a crash dump that way. You can run the process from this path:

C:\Program Files\Adobe\Adobe After Effects 2022\Support Files\Plug-ins\Effects\mochaAE\MochaAE.bundle\Contents\Win64\mochaui\bin\mocha4ae_adobe.exe

To Disable crash dumps again (recommended):

  1. Start a Command Prompt as Administrator
  2. Run reg delete “HKLM\SOFTWARE\Microsoft\Windows\Windows Error Reporting\LocalDumps”

How do I send them ? It won’t let me attach them here.

You can email them to me directly: martinb [at] borisfx.com

The launch problem appears to be with a driver issue in Intel OpenCL devices. We’ve found an interim solution for users experiencing this launching problem on Windows.
This workaround involves stopping Mocha from enumerating the OpenCL devices, which will stop the intel device from being read.

We recommend backing up the registry before moving forward.
In the Windows registry, try changing the REG_DWORD values from 0 to 1 for each platform listed below:

  1. HKLM\SOFTWARE\Khronos\OpenCL\Vendors
  2. HKLM\SOFTWARE\Wow6432Node\Khronos\OpenCL\Vendors

You can change this value back if there is a problem with other software, but this has been confirmed to work for some users.

If you’re unfamiliar with changing keys in the registry, we can provide more detailed instructions.