Mocha bad argument provided

i use nuke 11 v2 and last version of mocha ofx
inside nuke when connect mocha node to rush and press launch mocha button ,inside mocha see this…

Hi Ali,

We are working on pinpointing this bug. Can you submit a case and I will forward it to the dev team? https://borisfx.com/support/open-a-case/

Cheers,
Mary

Do you have any nuke script or sample footage I can use to reproduce this issue?

I tried Importing a Cineon clip and connected it to Mocha and mocha opened up fine.
I also tried importing regular clips and changing the colorspace to Cineon and Alexa but it was working fine for me as well.

Maybe your sample footage/nuke script can help.

Thanks,
Linh

Hi.

I also have had this issue since the new update. I never had this issue before 5.6. I am using the OFX version for Nuke 10. It seems to be random as I’ve had it work and saved in a file and open the file later and the plugin gives that error. I’ve rolled back to 5.5 just to get through my current workload. Hopefully it gets resolved soon.

The footage that we are using are AlexaLogC DPXs, but once it breaks, the error will happen if I connect it to a checkerboard or any other input as well.

Thanks.

Darren

Hi, I would just like to add this is definitely an issue. I am using DPXs made from Alexa footage. Sometimes it works when connecting directly to the footage, but most of the time I am coming from comps made in Nuke studio which have a Metadata and timeclip node attached - these are important in the pipeline so needs to work downstream.

I am forwarding this to the team working on this bug, thank you.

We’re still trying to reproduce this, but can you please try:

  1. Clearing the global mocha cache under the file menu inside the Mocha GUI. i.e File > Clear Cache… > Check “Global cache”
  2. Purge the local Nuke cache

We’re trying to determine if legacy cache files may be conflicting here.

Same error. Cache cleaning didn’t help.

Same issue. Launched 5.5 with no issues and decided to update. After update I started getting the “bad argument” error. Also getting an “out of memory” error all of a sudden. Neither of these were an issue 5 minutes ago before the update. Script is nothing more than a plate, hold frame and paint w/alpha and a mocha pro node. Clearing cache made no difference. Running Nuke 11.2 on windows 10.

Hi
same problem here: Mocha OFX 5.6 on Nuke 11.2, Centos Linux 7.
Cache cleaning doesn’t help, out of memory error.

Hi. Any soon updates for this?

When you’re applying mocha, are you viewing through the node or just launching mocha without the output attached to a view node?

Just launching mocha without the attached viewer node.

Try attaching the view node to the output of the mocha node BEFORE opening the mocha GUI.

I think Nuke is not initialising the source material through the node until it’s actually rendered in a view, which is why you get the error.

Let me know if this works.

1 Like

It works OK! Thanks.

Same here. Just made the huge error of updating and now i can’t open the node. Did a bare bones (in Nuke X) a read node (4k square) reformat down to 2K to make it easier. Time clip to take just 1000 frames. Viewer on time clip to see the content and then Mocha Pro node. Open UI and get Bad Argument and elsewhere comments about memory. (Have 128GB RAM)

Any pointers?

The log just says Bad argument provided.

Tried in a variety of Nuke versions 11.0,1,2

help!

thanks
Paul

Ok, to be clear, you’re getting this issue even when the viewer is connected to the output of the mocha node before you open the GUI?

What are the frame range and colour settings?

Yes, i’d followed the instructions above.

However this morning i emptied the caches again and it started working. So i got to assume user error and i think i may have cancelled the clear caches dialog the first time round (or didn’t have global caches cleared)

So i think it’s all up and running again. Panic over :slight_smile:

thanks
Paul

What’s the status on this? We still see this? Not fixed? When can we expect a fix?

We will have a fix in the next point release! In the meantime, please attach a viewer to the nodes and that should work for you as a workaround.

1 Like