Mocha Camera solve doesn't show track points in nuke

Hi all,

So i’m starting to learn mocha pro and i’m following tutorials from mocha’s youtube channel on how to do a camera solve and export it into nuke, im using nuke’s version 12.2v4 and when I import my fbx track from mocha pro into nuke ( using readgeo node and camera ) the track points should appear and they don’t, the camera doesn’t move either, it’s like I did nothing and just created a normal camera.

If anybody knows how I can solve this problem i’ll really appreciate a response.
Thanks in advance to everyone!

Marc

What is your camera solve percentage? And does the camera have any keyframes? What number does the Nuke timeline start at? What number does the Mocha timeline start at? It sounds like something is either not aligning correctly OR the solve is incorrect. But I need to know more to help solve this issue for you.

Cheers,
Mary

Thanks for your quick reply!

So here are your questions:

  • What is your camera solve percentage?
    98%.

  • And does the camera have any keyframes?
    No.

  • What number does the Nuke timeline start at?
    It starts at frame 0.

  • What number does the Mocha timeline start at?
    it starts at 0.

I hope this helps!

Thanks

Marc

Hi Marc,

This is the second time I have seen some camera solver problems in the last two weeks, and I think we need to look into bug testing it. Let me loop in @martinb.

1 Like

Marc, what object type are you reading the points in as?
Have you selected “Point Cloud” instead of “Mesh”?

Yes, I’ve followed step by step the tutorial from your Youtube channel

Thanks for helping!

Hey just wanted to know if you guys have discovered anything about it.

Thanks!

I think you may need to send us your project file. Can you DM me the contents? We probably won’t need the footage, just the project will do so we can solve the shot and see where the problem is.

1 Like

Hey, I found the problem, i thought it was from mocha pro but it’s actually not, when i import the fbx file from mocha into maya it work perfectly!

The problem comes when importing into nuke and the problem is in the readgeo node, you can import the fbx file but then you can’t choose anything in the FBX OPTIONS animation stack and node name tabs, they appear like this: ------, when i think it should say something about the fbx file animation.

I know this is not your problem but i’d really appreciate a response if you know how can i get around this problem.

Thanks again!

I am not quite understanding. What does your node setup look like in Nuke? Can you send me a screenshot of the node tree? You might not have enough nodes. You need a read geo and a camera and the FBX is read into both.

Here you go!

Thanks so much, ok, yeah, at this point I think it may be best to email Martin the nuke file. You can cc me as well at maryp at borisfx.com and we can take a look. Martin will be martinb at the same.

1 Like

Hmmm, that IS a bit odd.

What version of Mocha Pro are you using?

I’m using mocha pro 2021