Mocha crashes on save tracking data

Mocha V1.0.1 RC1 Soho on WinXP

I have successfully completed a track and I want to export it to my DS. When I go to save the tracking data, mocha crashes with a GUI application error.

Thoughts?

Many thanks,
-dan

I upgraded to 1.2 and the DS .fraw data seems to work now.

Thanks for reading!

Hello Ijazn,

Thanks for the reply. I have tried the reinstall/un-install routine, but I did not try to clear the registry. I will try again today.

As for the support contact I used this page:
http://www.imagineersystems.com/company/contact/index.php

I also made a comment that at least on my pc (WinXP using IE) that the drop-down for Enquiry Type does not seem to work correctly. It always defaults back to SALES, which is likely why I never received an answer as it went into the sales dept, never to be seen again.

I’ll post my results when I try your fixes…

-David

Hi,

Did you have any issues installing v1.2.0? I get errors installing on XP Pro. In fact the only version I have had any luck running is v1.0.0 Soho. v1.0.0.Beta3 and v1.0.aRC1 were horrendously bad on my system.

The errors I get installing v1.2.0 are shown in the pics. Three emails to tech support have gone un-answered, so Mocha mostly collects dust over here. The last I tried working on these issues was back in May.

-David

After two trips into the registry to clear out junk, I have gotten Mocha v1.2.0 to install. Thanks.

I must point out what I have always considered sloppy programming practices, however. I founds LOTS of Imagineer junk in my registry. From my time at FXPHD I had tried several of your products, before buying Mocha. Even though all those programs had been removed, they still left trash in the registry. Each program had settings for the UI and all its settings. For Mocha and Monet, that was over 800 lines of text in the registry for programs that were no longer installed. I didn’t check the data for Motor before I deleted it.

This is just plain sloppy practice in my opinion.

Thanks again for the help, now its time to shake out the new version.

I picked this program back up after viewing the new tutorials, which helped immensely as to the proper procedures. Documentation and real world examples have been lacking.

-David

Hi drswoboda

Thank you for posting this, I am sorry about the delay in replying, however I have looked through our support emails and have not found any of the emails you have mentioned, would you be able to provide some further details on how you sent the message to us, so that we can track a possible flaw in the system.

As for the install. Essentially the error message you are getting is that the old version 1.0.0 had a corrupt install or uninstall which is now no longer able to be referenced when upgrading your version. There are two actions that you can try to remedy this

  1. Ensure that Mocha 1.0.0 is completely uninstalled
  • Navigate to to the Add/Remove Directory and ensure that any instances of Mocha is removed
  • Ensure that the directory C:\Program Files\Imagineer Systems Ltd\Mocha V1 is removed
  • Remove the registry settings in HKLM-Software-Imagineer Systems Ltd-Mocha 1 (Careful when doing this)
  1. Reinstall Mocha V1.0.0 and then uninstall. (Ensure there are no errors)
    To download:
    http://www.imagineersystems.com/downloads/mocha/mochaV1.0.0.exe

If you can pm me your details I can give you a call to go through this.