Mocha data drifts in Apple Motion

Fairly new at using Mocha Pro. I keep running in to a snag. In Mocha my track looks great, the surface tool moves exactly how I want the track to move. However, when I export the basic motion data to Apple Motion the tracking works for a few frames and then drifts off. I may be doing something very wrong but it seems like I am missing something real simple (prob operator error). I have followed all the info provided in the videos about importing data to motion and have double checked my settings and my video frame rate and pixel size.

The footage I am tracking in a large branch of a tree, I am trying to track an object onto the branch. Its not a crazy shot, just kinda wide and the camera pushes closer to the branch.

Thank you for any input.

 

 

Hi there,

Have you checked the motion tutorials for mocha?

http://www.imagineersystems.com/videos/mocha-fundamentals-chapter-7b-transform-data-in-final-cut-motion/
http://www.imagineersystems.com/videos/mocha-fundamentals-chapter-8b-corner-pin-in-final-cut-pro-and-motion/
http://www.imagineersystems.com/videos/fundamentals-of-mocha-09b-stabilization-in-final-cut-pro-motion/

It may be that your settings aren’t lining up between motion and mocha, or more likely your target object in motion isnt the same size as the footage in mocha, this can be a problem for your corner pin. Make sure your settings match to get the data across to motion.

Hello Mary,

 

Thanks for the response. I have checked out the tutorials and have found them very helpful. A good example of whats going wrong with me is in the first video you listed. In that video as soon as the new motion project that was created upon Mocha export opens the Surface or blue square is already tracked to the video. When I open my new motion project the bus surface is not tracking correctly.

 

Does that mean I have a setting wrong in mocha?

 

The video that is in the motion project is the same video from mocha so I know its the same size. Can you please explain what you mean by the target object isn’t the same size? Also I exported as a basic transform, should I have exported as a corner pin?

 

Sorry for al the trouble shooting questions.

 

Thanks

 

Patrick

 

I think a corner pin will set you right, also, you need to make sure you’re bringing the data in on the first frame of your clip in motion.

What I mean by the target object is the object that the corner pin is being applied to in motion, not the source clip. If the object is not the same size as the corner pin, you will have to follow those video instructions to alter the surface tool by using “align to surface” in mocha on the frame where your object needs to line up in motion.

No worries about questions, I am here to help.

Hi Mary,

 

I have gone trough and tried the corner pin, and it worked really well. As soon as I opened my project in motion the blue object object was perfectly tracked with the video.

 

My problem is that the object I plan on linking to this data is a character that has no set aspect ratio. Am I wrong in saying that with he corner pin the object must remain the same aspect ratio? It seems so with the “align to surface” steps. Maybe I am wrong but it seems like for an object with no set aspect ratio (a moving 2D character or particle emulator) would be best paired with transform data. Hmmm

 

 

With this same project I have another shot in which the camera does not move on the Z space. Its handheld and only slightly moves up and down. I was able to track this really well and export the transform data, that worked really well. I mention that because I am using the same steps with both.

 

This still leaves me wondering why my other shot has trouble specifically when the camera moves towards the subject on the Z plane.

 

1st shot with drift

 

2nd shot works fine

 

Thanks again for any advise!

Patrick