Mocha doens´t open ae-clip cause older project is missing

Hi there,

I am running into a problem when I try to track a shot in mocha (launched from AE). I tracked quite a few tracks already - everything went fine. But now when I start mocha (by selecting “Track in mocha ae” mocha is always looking for an older project I did almost a year ago. Then a dialog-box appears:
<p style="-qt-block-indent: 0; text-indent: 0px; margin: 0px;">The specified project file was not found or is otherwise inaccessible:</p>
<p style="-qt-block-indent: 0; text-indent: 0px; margin: 0px;">/Volumes/…/5U4A9182_159_to_260.mocha</p>
<p style="-qt-block-indent: 0; text-indent: 0px; margin: 0px;"></p>
I can close mocha but everytime I try again, I get the same message. The only way to use mocha right now is, to import the clip manually (directly in mocha). Is there a way to clear the created-projects-list or to avoid, mocha is looking for that project? What else could I do?

Many thanks in advance

Timo

 

hi Timo,

Can you tell me your exact steps to reproduce this issue? We don’t load any project data when launching from mocha AE, so i’m curious to know what is going on here.

What version are you using?

Hi,

 

thanks for your response. Probably I used the wrong terms due to my bad english-skills … So when I´d like to track a any clip in mocha (while I am working in ae), I go to “Track in mocha ae”. Then mocha ae launches. But then the dialog-box I described before, appears.

The specified project file was not found or is otherwise inaccessible:
/Volumes/…/5U4A9182_159_to_260.mocha

This is from a very old project I did one or two years ago. In the following time I did a few other mocha-trackings without havinganytrouble…

All I can do is to click “okay”. But the clip I was working on in AE doens´t open. I then have to import it via mocha ae …

Any ideas?

Thanks again,

t.

 

Does anybody have any idea?

Thanks again,

Timo

Try deleting your preferences:

OSX:
~/Library/Preferences/com.imagineersystems.[MOCHA VERSION].plist

Windows:
You will need to delete the registry settings.
HKEY_CURRENT_USER\Software\Imagineer Systems Ltd[MOCHA VERSION]

Hey Martin,

that doesn´t fix the problem. I deleted all three files:

com.imagineersystems.mocha AE CC - 2014.plist

com.imagineersystems.mocha shape converter for AE 3.plist

com.imagineersystems.mocha4ae_adobe.plist

 

After opening Mocha via AE´s “Track in Mocha” the same dialog box pops up … Any other suggestions?

Many thanks,

timo

 

One more thing … I just updated recently to AE 2015. Before in AE 2014 everything was fine…

And I just gave it a try - in the 2014-AE-version still everything works fine. No dialog-box, no missing files.

Does that help you? Any ideas how to fix it for the ae-2015-version as well?

Thanks again,

t.

Hi Timo,

Is 5U4A9182_159_to_260 the name of the clip you are trying to use mocha on? I think it would be useful to see the full error message including the whole path, which you should be able to find in the mocha log file. To show the log, open mocha then click Help | View Log. Latest entries are at the bottom, so if you make the error happen then immediately view log you should be able to find it easily.

Thanks,

J-P

Thanks for your response … and sorry for my delayed answer … I will post the log file in a sec …

somehow I can post the logfile-data (I copied and pasted it), tried with and without quotes …

 

Hi Timo,

Please email the log to martinb[at]imagineersystems.com

Hi Timo,

Unfortunately I couldn’t see anything useful in the log file. Do you have MochaImport+ installed? I believe this has the ability to make mocha AE reopen a previous project file.

Best regards,

J-P

Hi J-P,

thanks again. One more thought - isn´t it strange, that mocha works fine in the after effects 2014-version? So it has to do with the ae-cc-2015-version, no?

I have mochaimport+ installed - but I don´t want to reopen an old project. I get the error-message each time I want to open a new project (from ae). So I am not able to work with mocha right now (at least I can´t launch it from ae) …

t.

Hi Timo,

It’s not so strange that one version of mocha works and another doesn’t, because the link to that old project file must be stored somewhere and the storage locations for data like that will be different between the two versions.

I’m going to ask Mathias from mamoworld to take a look at this thread because he might have some thoughts about where this old project file is coming from and how to get rid of it.

Best regards,

J-P

Hi Timo,

in order to open existing projects with the “send to mocha” button of MochaImport+, it overwrites some preferences in on of the following files:

~/Library/Preferences/com.imagineersystems.mocha shape converter for AE 2.plist
~/Library/Preferences/com.imagineersystems.mocha shape converter for AE 3.plist
~/Library/Preferences/com.imagineersystems.mocha shape converter for AE 4.plist

Does it help if you delete those?

Usually, MochaImport+ modifies those plist files, launches mocha and undoes the changes again. But if AE crashed for whatever reason during the launch of mocha, it could be that the modifications survived and caused your issue.

Cheers,

Mathias

 

Hi Mathias,

Thanks for chiming in on this. For what it’s worth, deleting these files is no longer enough to clear the preferences on Mac, as they are cached and sometimes reappear with old information. The best way to do it is with the defaults command in the terminal:

defaults remove “com.imagineersystems.mocha shape converter for AE 2”
defaults remove “com.imagineersystems.mocha shape converter for AE 3”
defaults remove “com.imagineersystems.mocha shape converter for AE 4”

Best regards,

J-P

Hi Matthias, hi J-P,

 

many thanks for your help. In my library-folder I do have the following files:

com.imagineersystems.mocha AE CC - 2014.plist

com.imagineersystems.mocha shape converter for AE 3.plist

com.imagineersystems.mocha4ae_adobe.plist

 

So there are no files “… for AE2.plist” and “…for AE1.plist”.

 

Just copyied the commands J-P posted. Seems like, it worked once. But then again, the same error appeared. I then used mochaimport+ to send the clip to mocha. And: That works! Now the clip opens.

But: Now I get another message:
<p style="-qt-block-indent: 0; text-indent: 0px; margin: 0px;">The project was created in an earlier version and has been converted to the latest file format.</p>
<p style="-qt-paragraph-type: empty; -qt-block-indent: 0; text-indent: 0px; margin: 0px;"></p>
<p style="-qt-block-indent: 0; text-indent: 0px; margin: 0px;">mocha AE CC 4 project files are not supported in earlier versions.</p>
<p style="-qt-paragraph-type: empty; -qt-block-indent: 0; text-indent: 0px; margin: 0px;"></p>
<p style="-qt-block-indent: 0; text-indent: 0px; margin: 0px;">Would you like to save the project immediately with a new name?</p>
 

Is there a way to get of rid of this one as well?

Probably I should mention, that - if I launch mocha via AE CC 2015 - there is another temporary file. It is a copy of the 2014-File. But shouldn´t it be a file of 2015-Version?

Many thanks again,

Timo

<span style=“font-family: Arial;”><b><span style=“font-size: 14px; cursor: url(‘http://cdn2.reverso.net/lexi/v1781/static/img/CM.cur’), auto;”><span id=“ID0E5B” style=“cursor: url(‘http://cdn2.reverso.net/lexi/v1781/static/img/CM.cur’), auto;”> </span></span></b></span>

Hi Timo,

in the MochaImport+ settings there is a button “Advanced mocha project settings”. If you click it, a dialog appears that has a checkbox at the bottom that says “Use old mocha V3 project format”. Do you happen to have this checked? If it is not checked you shouldn’t get the info about the old project format.

Cheers,
Mathias

Hi Matthias,

checked it - but in the advanced setting I can only choose the color bit depth in mocha. Nothing else … probably because I use mocha ae?

Many thanks again,

t.

Hi Timo,

the support for mocha V4 projects has been added in MochaImport+ V5.

If you don’t have this option, you still use an older version that does not support the new format.

MochaImport+ V5 is a paid upgrade and the pricing depends on which previous version you own. If you have purchased an older version, just login at aescripts.com with your customer account and then visit

If you are logged in with the customer account that you used to purchase the a previous version, it will show an update price for you.

Cheers,

Mathias